Bug#784942: autopkgtest: fails to read Files: from perfectly valid .changes file

Martin Pitt mpitt at debian.org
Tue May 26 16:31:15 UTC 2015

Control: tag -1 unreproducible

Hey Antonio,

sorry for the late response.

Antonio Terceiro [2015-05-10 19:45 -0300]:
> I am missing anything?
> $ adt-run --user debci --output-dir /tmp/adt-run ../build-area/ruby-defaults_2.1.5.0_amd64.changes --- schroot debci-unstable-amd64
> adt-run: error: ../build-area/ruby-defaults_2.1.5.0_amd64.changes is invalid and does not contain Files:
> [20]$ cat ../build-area/ruby-defaults_2.1.5.0_amd64.changes

I tried that .changes files, and it works correctly here. Maybe just
pasting it into the email destroyed some subtle whitespace? Can you
attach the file instead?

I also got ruby-defaults from the archive, sbuilt it, and ran
adt-run on the binary unsigned .changes, which also worked.

If you can still reproduce this, I can also send you some patch for
enhancing debugging in runner/adt-run files_from_dsc() -- it seems the
parse_rfc822() runs into a corner case?


Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/autopkgtest-devel/attachments/20150526/21c87aef/attachment.sig>

More information about the autopkgtest-devel mailing list