Bug#844459: autopkgtest: Please add autopkgtest-virt-uchroot

Martin Pitt mpitt at debian.org
Thu Dec 8 16:59:44 UTC 2016

Hello Josch,

Johannes Schauer [2016-11-16 17:32 +0100]:
> For example, most notably, "mount -t proc proc /proc" never worked without
> doing the systemcalls manually using the perl script I present there. This
> problem of course might also have been due to remaining bugs in the tools I
> used (including my kernel) which are long fixed now.

Apparently they aren't yet (tested on Linux 4.8 and util-linux
2.29), or I'm missing some magic option. I also tried various
variations like

  unshare --propagation private -rmU --mount-proc sh -c 'whoami; findmnt /mnt'

So as that still seems too brittle, let's go ahead with lxc-*; this
can be changed later on to use util-linux tools once they become
sufficiently powerful.


Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/autopkgtest-devel/attachments/20161208/93241168/attachment.sig>

More information about the autopkgtest-devel mailing list