Bug#892023: autopkgtest-virt-qemu: Fails creating test environment sometimes

SZALAY Attila sasa at ubainba.hu
Sun Mar 4 10:00:19 UTC 2018

Package: autopkgtest
Version: 5.1
Severity: important

Dear Maintainer,

Because I need some VM level separation, I have to use qemu for testing my package.
Unfortunately, when I run my tests (there are a fair amount of them), most of the
time one test fails with a virtual host creation issue. As far as I can tell it
usually fails at the same test case but I think this is happen because the bug
is depending on the number of the created virtual host not because of the test case
itself. Especially because I run the same test script just on different package

Previously, when I was running the test with debug it has more chance to success, but
not any more.

By the way, the package, I try to use autpktest with is syslog-ng. The command I run is:
autopkgtest --debug syslog-ng_3.13.2-4~1.gbpa514e1_amd64.changes -- qemu /var/cache/autopkgtest/autopkgtest-sid.img

And the error message I receive is the following:
autopkgtest [09:35:09]: test basic:  - - - - - - - - - - results - - - - - - - - - -
basic                PASS
autopkgtest: DBG: sending command to testbed: copyup /tmp/autopkgtest.a1psrU/basic-artifacts/ /tmp/autopkgtest.output.k7snm27u/artifacts/
autopkgtest: DBG: got reply from testbed: ok
autopkgtest: DBG: testbed command ['rm', '-rf', '/tmp/autopkgtest.a1psrU/basic-artifacts', '/tmp/autopkgtest.a1psrU/autopkgtest_tmp'], kind short, sout raw, serr pipe, env []
autopkgtest: DBG: testbed command exited with code 0
autopkgtest: DBG: no need to restore click AppArmor profiles
autopkgtest [09:35:10]: test basic: preparing testbed
autopkgtest: DBG: testbed reset: modified=False, deps_installed=['syslog-ng-core', 'syslog-ng-mod-mongodb'](r: False), deps_new=['syslog-ng-core', 'syslog-ng-mod-sql'](r: False)
autopkgtest: DBG: testbed reset
autopkgtest: DBG: sending command to testbed: revert
qemu-system-x86_64: terminating on signal 15 from pid 4318 (/usr/bin/python3)
qemu-system-x86_64: terminating on signal 15 from pid 4318 (/usr/bin/python3)
<VirtSubproc>: failure: timed out on client shared directory setup
autopkgtest: DBG: TestbedFailure unexpected eof from the testbed
autopkgtest: DBG: testbed stop
autopkgtest: DBG: testbed close, scratch=/tmp/autopkgtest.a1psrU
autopkgtest: DBG: sending command to testbed: close
autopkgtest: DBG: TestbedFailure cannot send to testbed: [Errno 32] Broken pipe
autopkgtest: DBG: testbed stop
autopkgtest [09:35:36]: ERROR: testbed failure: cannot send to testbed: [Errno 32] Broken pipe
autopkgtest: DBG: testbed stop

Last time I felt enough debug-fu in myself I discovered that when this happens, the
serial console is unaccessible. Unfortunately I know barely anything about qemu I just
get to know how it can be used. But if somebody points me in the right direction I
can do more tests.

By the way, I just run the test to check how long it need to show the error message, but
now it passed.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages autopkgtest depends on:
ii  apt-utils       1.6~alpha7
ii  libdpkg-perl
ii  procps          2:3.3.12-4
ii  python3         3.6.4-1
ii  python3-debian  0.1.32

Versions of packages autopkgtest recommends:
ii  autodep8  0.11.1

Versions of packages autopkgtest suggests:
pn  lxc          <none>
pn  lxd-client   <none>
ii  qemu-system  1:2.11+dfsg-1
ii  qemu-utils   1:2.11+dfsg-1
ii  schroot      1.6.10-4

-- no debconf information

More information about the autopkgtest-devel mailing list