[Bash-completion-devel] Bug#486702: bash-completion: Fails to upgrade

David Paleino d.paleino at gmail.com
Tue Jun 17 20:23:32 UTC 2008

On Tue, 17 Jun 2008 21:16:23 +0200, Helge Kreutzmann wrote:

> Package: bash-completion
> Version: 20060301-4
> Severity: important
> (I think this is serious, but I'm not sure so I leave this as
> important; the version is taken from dpkg -l).

I think "important" is ok -- I'll leave other team members decide. :)

> I tried to update bash (via apt-get dist-upgrade) and it prompted me
> with the following debconf screen (output reformatted):
> Package configuration
> Modified configuration file
> A new version of configuration file /etc/bash_completion is available,
> but the version installed currently has been locally modified.
> What would you like to do about bash_completion?
> install_new
> keep_current
> diff
> sdiff
> shell
> Ok
> (Previously there was a non-debconf-prompt about those kind of
> changes).

Yes, I suppose this is related with the use of ucf ("Update Configuration
File"), I didn't do that, so don't ask me how it works :)

> Since I wanted to see a diff, but did not know what "sdiff" meant I
> tried it by selecting. After pressing enter, nothing happened anymore,
> the installation was stuck. To be sure, I let it run for >> 1 hour.
> After presseing Ctrl-C I got the following message:
> dpkg: error processing bash-completion (--configure):
>  subprocess post-installation script killed by signal (Interrupt)
> ....
> Errors were encountered while processing:
>  bash-completion
>  E: Sub-process /usr/bin/dpkg returned an error code (1)

This seems like a bug in ucf itself -- I don't believe bash-completion is
faulty here. CCing ucf maintainer (hi Manoj).

However, did you retry to upgrade? Please do, and report if anything changed.


 . ''`.  Debian maintainer | http://wiki.debian.org/DavidPaleino
 : :'  : Linuxer #334216 --|-- http://www.hanskalabs.net/
 `. `'`  GPG: 1392B174 ----|---- http://snipr.com/qa_page
   `-   2BAB C625 4E66 E7B8 450A C3E1 E6AA 9017 1392 B174
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/bash-completion-devel/attachments/20080617/a0c70147/attachment-0001.pgp 

More information about the Bash-completion-devel mailing list