[Bash-completion-devel] Bug#486702: bash-completion: Fails to upgrade

David Paleino d.paleino at gmail.com
Thu Jun 19 22:00:22 UTC 2008

tags 486702 confirmed
reassign 486702 ucf

On Thu, 19 Jun 2008 22:21:35 +0200, Helge Kreutzmann wrote:

> Hello David,


> On Tue, Jun 17, 2008 at 10:53:16PM +0200, David Paleino wrote:
> > On Tue, 17 Jun 2008 22:50:04 +0200, Helge Kreutzmann wrote:
> > > On Tue, Jun 17, 2008 at 10:23:32PM +0200, David Paleino wrote:
> > > > However, did you retry to upgrade? Please do, and report if anything
> > > > changed.
> > > 
> > > I tried it again using "sdiff" and it hung again, though I only let it
> > > hang for a few seconds. If you want to debug this, I can keep that
> > > state for a few days, or should I try "diff" instead?
> > 
> > Please, try "diff" -- I don't believe "a few seconds" will be different
> > from "a few days" :)
> > 
> > "sdiff" is side-by-side diff -- is it possible that your alpha machine is
> > having problems displaying it? (just a thought)
> I just used "diff" instead of "sdiff" and it worked (as it did
> previously now in the x86 chroot). 

Uhm, ok.
So, we now have two options:
1) it's an ucf bug
2) it's a sdiff bug.

Since you have an updated ucf version, I really suspect it's a sdiff bug. Does
that screen appear with any other package? If yes, could you try sdiff with
this other package? Does it work "stand-alone" in your chroot? (it does for me)

> For completeness, the following simple steps reproduce it:
> Setup up a etch chroot, e.g. by
> cdebootstrap --arch=i386 etch /var/chroot/sid http://...
> Copy the necessary files inside (fstab, passwd, resolve.conf, ...)
> Mount the necessary directories (using --bind), typically proc
> Edit sources.list to point to sid
> chroot in your new chroot
> apt-get update
> apt-get dist-upgrade
> apt-get dist-upgrade
> (yes, twice). In the second run, bash_completion will be
> installed/upgraded, and the dialogue appears. 

Ok, I can reproduce it.
I'm still of the idea that this is not our fault though, thus I'm reassigning
to ucf. Manoj, please feel free to reassign it elsewhere, if you feel it's not
your fault either (diff?)

> If I hear nothing form you, I'll clone this bug for the prompt.

The prompt is right. I've checked the postinst/postrm scripts, and they do
Probably this is ucf-related -- or probably is just a bug when switching from
debconf to ucf.

> As shown above, the config file was never changed by me,

Yes, ACK.

> so no prompt for an upgrade should be necessary

You're right.

> (and looking at the huge diff, I bet many system administrators will be
> rather lost as well).

Oh, come on, that's not that huge! :p

Ok, jokes aside, I believe that is a bug in etch > sid. We should really try
etch > lenny > sid, and see if this happens.


 . ''`.  Debian maintainer | http://wiki.debian.org/DavidPaleino
 : :'  : Linuxer #334216 --|-- http://www.hanskalabs.net/
 `. `'`  GPG: 1392B174 ----|---- http://snipr.com/qa_page
   `-   2BAB C625 4E66 E7B8 450A C3E1 E6AA 9017 1392 B174
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/bash-completion-devel/attachments/20080620/461b8df9/attachment-0003.pgp 

More information about the Bash-completion-devel mailing list