Bug#373164: [Build-common-hackers] Bug#373164: cdbs: stop overriding DEB_DESTDIR

Marc Dequènes (Duck) duck at duckcorp.org
Tue Jun 13 09:31:51 UTC 2006

tags 373164 + wontfix


Eduard Bloch <blade at debian.org> writes:

> Please stop using abusing the DEB_DESTDIR variable which have been used
> by module-assistant includes for many years now. Please do better
> research when starting using variables, blindly overriding the existing
> ones. Please give the variables useful names. DEB_DESTDIR does not mean
> the destination directory for the deb file. It means something different
> any maybe should be renamed to CDBS_CONTENTS_DIR. Exactly like most of
> your other variables, why are you using DEB_ prefix? CDBS_ would be
> more appropriate, it would describe who set it and why.

CDBS is using DEB_DESTDIR (and DEB_*) for years. I don't know which one
used it first, but this is quite an ancient behavior ; i'm astonished
you complained this late, as it is now *IMPOSSIBLE* to fix this problem,
too many packages would FTBFS if we change such variables.

I strongly agree CDBS_* would have been better, nevertheless, why should
module-assistant have the priviledge of DEB_* variables usage ? If the
closest relationship to debhelper wins, then CDBS wins.

Marc Dequènes (Duck)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 188 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/build-common-hackers/attachments/20060613/919c4437/attachment.pgp

More information about the Build-common-hackers mailing list