Bug#373164: [Build-common-hackers] Bug#373164: cdbs: stop overriding DEB_DESTDIR

Eduard Bloch edi at gmx.de
Tue Jun 13 09:44:04 UTC 2006

#include <hallo.h>
* Marc Dequènes [Tue, Jun 13 2006, 11:31:51AM]:
> tags 373164 + wontfix
> thanks

Then document it properly. What I expect as user is a good readable
overview of how CDBS poisons the environment: ie. a complete list of
variables set and overriden by it with links to the conflicting
packages. Currently, your manual is unreadable because all the var names
are spread over different paragraphs, I would like to see a summary, a
table with names, short descriptions and links.

> Eduard Bloch <blade at debian.org> writes:
> > Please stop using abusing the DEB_DESTDIR variable which have been used
> > by module-assistant includes for many years now. Please do better
> > research when starting using variables, blindly overriding the existing
> > ones. Please give the variables useful names. DEB_DESTDIR does not mean
> > the destination directory for the deb file. It means something different
> > any maybe should be renamed to CDBS_CONTENTS_DIR. Exactly like most of
> > your other variables, why are you using DEB_ prefix? CDBS_ would be
> > more appropriate, it would describe who set it and why.
> CDBS is using DEB_DESTDIR (and DEB_*) for years. I don't know which one
> used it first, but this is quite an ancient behavior ; i'm astonished
> you complained this late, as it is now *IMPOSSIBLE* to fix this problem,
> too many packages would FTBFS if we change such variables.

I sent a complaint to your mailing list before. Apparently it has been

> I strongly agree CDBS_* would have been better, nevertheless, why should
> module-assistant have the priviledge of DEB_* variables usage ? If the
> closest relationship to debhelper wins, then CDBS wins.

And if the closest relationship of the var name and var meaning counts,
then module-assistant wins.


More information about the Build-common-hackers mailing list