[Build-common-hackers] Standardisation of the name of the patching targets included in debian/rules.
cjwatson at debian.org
Mon Feb 4 11:01:14 UTC 2008
On Mon, Feb 04, 2008 at 05:28:14PM +0900, Simon Horman wrote:
> On Sun, Feb 03, 2008 at 08:14:35PM +0100, Stefano Zacchiroli wrote:
> > On Sun, Feb 03, 2008 at 11:10:41AM +0100, Martin Quinson wrote:
> > > I find personnaly patch/unpatch more easy to understand, but YMMV...
> > I think (hope) that no one will be able to find a reason why the two
> > target should *not* be called "patch" / "unpatch". They are IMO the only
> > 2 that people will be able to guess out of the blue.
> > So please go for patch/unpatch.
> Fine by me.
> Though if you dug a bit deeper I suspect you would find rather a
> lot of packages that supply patch/unpatch targets under various names.
> Perhaps a policy is in order? That way lintian and friends would
> alert packagers to the problem.
(The discussion is long, but has recent activity.)
Colin Watson [cjwatson at debian.org]
More information about the Build-common-hackers