Emilio Pozuelo Monfort
pochu at debian.org
Tue Jan 4 15:26:03 UTC 2011
On 04/01/11 14:25, Jonas Smedegaard wrote:
>>> The variable $(nostrip_package) has a high risk of clashing with user
>>> environment: Pick a CDBS-specific name instead - e.g.
>>> $(cdbs_pd_nostrip_package) - or if sensible to reuse across snippets
>>> then perhaps $(cdbs_nostrip_package) instead.
>> i changed the name to $(cdbs_pd_common_nostrip_package)
>> i don't know exactly about reusability (the check as it is right now
>> tests for both the "nostrip" flag or whether we are building
>> dbg-libraries (unlikely with pd-externals, acutally)
>> so i think it might make sense to move the snippet into buildvars.mk,
>> but i am not so literate with cdbs (and its policies) yet, so i leave
>> that decision to you.
> I am not really knowledgeable about -dbg packages, but I do believe that nostrip
> and -dbg are not entirely the same, so should not be tied too closely together.
With the risk of speaking nonsense (as I haven't been following this thread),
I'll say that dh_strip already looks for "nostrip" in DEB_BUILD_OPTIONS. Not
sure why you need to check for it too.
More information about the Build-common-hackers