dr at jones.dk
Tue Jan 4 15:55:43 UTC 2011
On Tue, Jan 04, 2011 at 03:26:03PM +0000, Emilio Pozuelo Monfort wrote:
>On 04/01/11 14:25, Jonas Smedegaard wrote:
>>>> The variable $(nostrip_package) has a high risk of clashing with
>>>> user environment: Pick a CDBS-specific name instead - e.g.
>>>> $(cdbs_pd_nostrip_package) - or if sensible to reuse across
>>>> snippets then perhaps $(cdbs_nostrip_package) instead.
>>> i changed the name to $(cdbs_pd_common_nostrip_package) i don't know
>>> exactly about reusability (the check as it is right now tests for
>>> both the "nostrip" flag or whether we are building dbg-libraries
>>> (unlikely with pd-externals, acutally)
>>> so i think it might make sense to move the snippet into
>>> buildvars.mk, but i am not so literate with cdbs (and its policies)
>>> yet, so i leave that decision to you.
>> I am not really knowledgeable about -dbg packages, but I do believe
>> that nostrip and -dbg are not entirely the same, so should not be
>> tied too closely together.
>With the risk of speaking nonsense (as I haven't been following this
>thread), I'll say that dh_strip already looks for "nostrip" in
>DEB_BUILD_OPTIONS. Not sure why you need to check for it too.
Thanks. Not nonsense at all, but PureData has oddly named library
filenames that are skipped by default by dh_strip - and unfortunately
not only by default: apparently dh_strip cannot be told explicitly what
files to work on.
* Jonas Smedegaard - idealist & Internet-arkitekt
* Tlf.: +45 40843136 Website: http://dr.jones.dk/
[x] quote me freely [ ] ask before reusing [ ] keep private
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 836 bytes
Desc: Digital signature
More information about the Build-common-hackers