[buildd-tools-devel] Bug#539570: reliance on ~/stats should be properly documented

Daniel Moerner dmoerner at gmail.com
Sun Aug 2 01:03:51 UTC 2009

Package: sbuild
Version: 0.58.6-1
Severity: normal


I was surprised when I ran sbuild-createchroot today because it
produced this error:

STATS_DIR directory '/root/stats' does not exist at /usr/share/perl5/Sbuild/Conf.pm line 70.   

Obviously, 'mkdir -p /root/stats' solves this problem. However, this
requirement doesn't look to be documented in man 8
sbuild-createchroot. It's also confusing because the README.Debian
seems to suggest that the stats directories are in /var/lib/sbuild.

Daniel Moerner

For reference, from #debian-devel today:

[17:52] <dmoerner> why does sbuild demand that /root/stats exist when i run sbuild-createchroot? i'm not seeing it documented in the manpage
[17:52] <KiBi> dmoerner: demands ~/stats more generally; please report a bug.
[17:52] <KiBi> (I've always been time-constrained when I hit this annoyance, never reported it :p)
[17:58] <dmoerner> KiBi: thanks for the confirmation, i'll file a bug
[17:59] <KiBi> dmoerner: I'd bet it comes from the fact sbuild was mostly used on the buildds, and they were expected to keep some tracks of stats.
[17:59] <KiBi> rleigh might (co|i)nfirm that.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages sbuild depends on:
ii  adduser                       3.110      add and remove users and groups
ii  libsbuild-perl                0.58.6-1   Tool for building Debian binary pa
ii  perl                          5.10.0-24  Larry Wall's Practical Extraction 
ii  perl-modules                  5.10.0-24  Core Perl modules

Versions of packages sbuild recommends:
ii  debootstrap                   1.0.15     Bootstrap a basic Debian system
ii  fakeroot                      1.12.5     Gives a fake root environment

Versions of packages sbuild suggests:
pn  deborphan                     <none>     (no description available)
ii  wget                          1.11.4-4   retrieves files from the web

-- no debconf information

More information about the Buildd-tools-devel mailing list