<div dir="ltr">Sorry for the late reply.<br><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Apr 11, 2017 at 10:39 AM, Johannes Schauer <span dir="ltr"><<a href="mailto:josch@debian.org" target="_blank">josch@debian.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi,<br>
<br>
Quoting Michael Stapelberg (2017-04-08 11:28:12)<br>
> One area where sbuild sorely lacks is configuration, though: pbuilder is very<br>
> easy to set up, whereas sbuild requires reading through<br>
> <a href="https://wiki.debian.org/sbuild" rel="noreferrer" target="_blank">https://wiki.debian.org/sbuild</a><wbr>, performing a bunch of steps, only to end up<br>
> with a setup which works fine for unstable, but seems very clumsy when<br>
> building packages for experimental or backports.<br>
><br>
> One solution to this issue that I can see is to add a new binary<br>
> package to src:sbuild which — possibly after a brief debconf prompt —<br>
> performs all the necessary steps to end up with a setup that just<br>
> works.<br>
><br>
> What are your thoughts on this? Would patches be welcome to add such a<br>
> package?<br>
<br>
patches totally welcome! :D<br></blockquote><div><br></div><div>Cool! I’ll see if I can whip up such a package by working through the wiki page.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
This is a nice idea!<br>
<br>
Maybe these packages could be named sbuild-backend-${foo} where $foo is the<br>
respective backend? At first, a package sbuild-backend-schroot would be cool<br>
because schroot is the default backend. It would be nice if that would set up<br>
sbuild schroots for stable-backports, unstable and experimental. Maybe that<br>
package should also install and activate cron-jobs to regularly update those<br>
schroots?<br></blockquote><div><br></div><div>Which other backends even are there, and do we really need to offer our users that choice, when we’re talking about a package with sane defaults for people who prefer not to make these choices right now? :)</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
What irks me is, that this setup would be Debian specific. It doesn't make much<br>
sense for Debian's downstreams to have have schroots for Debian. Maybe the<br>
distribution name should be part of the package name? Or maybe it should be<br>
easy for downstreams that care to override the set of distributions the<br>
schroots are created for?<br></blockquote><div><br></div><div>Putting Debian into the package name seems reasonable.</div><div><br></div><div>How about sbuild-debian-dev-setup?</div><div><br></div><div>I originally thought of sbuild-debian-setup, but it could be confused to mean “a setup which reflects Debian’s official setup”, i.e. the buildds.</div><div><br></div><div>The “setup” suffix to me conveys that this package offers only configuration, not new software. Perhaps there’s a more idiomatic term for that in Debian?</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
Thanks!<br>
<br>
cheers, josch<br>
</blockquote></div><br><br clear="all"><div><br></div>-- <br><div class="gmail_signature" data-smartmail="gmail_signature">Best regards,<br>Michael</div>
</div></div>