[Debburn-devel] Unexpected joliet directory length...
Peter Samuelson
peter at p12n.org
Tue Sep 16 17:35:42 UTC 2008
[Harald Hoyer]
> if (this_dir == root && strcmp(short_name, "..") == 0) {
> - statbuf = root_statbuf;
> - lstatbuf = root_statbuf;
> + if (!root_statbuf.st_ctime) {
> + stat_filter(dirname(whole_path), &root_statbuf);
> + }
> + memcpy(&statbuf, &root_statbuf, sizeof(statbuf));
> + memcpy(&lstatbuf, &root_statbuf, sizeof(lstatbuf));
Why did you replace "=" with memcpy? They do exactly the same thing,
and "=" is a lot shorter and easier to read. Is there a problem with
it that I don't know about?
--
Peter Samuelson | org-tld!p12n!peter | http://p12n.org/
More information about the Debburn-devel
mailing list