[Debian-eeepc-devel] Bug#500187: wireless-key does not work on eeePC 900A

InSa insa_hc at yahoo.it
Fri Sep 26 09:46:54 UTC 2008

Sorry, I did not give you all info. I have an eeepc 900 and I am using
current sid with 2.6.26-1-686 kernel.

On Fri, 26 Sep 2008 12:03:44 +0300
Damyan Ivanov <dam at modsoftsys.com> wrote:

> The "HAL status 3" error rings a bell from the past. Please verify 
> that
>  * you have ath5k blacklisted (and initrds updated)

ath5k is already blacklisted.

>  * you use the madwifi-source package from sid and build the kernel 
>    module package from it with m-a

I have purged every madwifi* packages and reinstalled madwifi with "m-a a-i
madwifi" but wifi still does not work.

> Hmm. Perhaps another sleep is needed *before* the modprobe in the 
> Atheros case? (that's in /etc/acpi/actions/wireless.sh)

I am not sure that is the problem. With wifi disabled and every ath*
module unloaded if I run "modprobe ath_pci" kernel.log reports the same error:

Sep 26 11:35:27 cheyenne kernel: [  915.791869] AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, RF2417)
Sep 26 11:35:27 cheyenne kernel: [  915.808337] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 18 (level, low) -> IRQ 18
Sep 26 11:35:27 cheyenne kernel: [  915.812512] MadWifi: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3)
Sep 26 11:35:27 cheyenne kernel: [  915.812533] ACPI: PCI interrupt for device 0000:01:00.0 disabled

++ Powered by Sid ++

More information about the Debian-eeepc-devel mailing list