[Debian-olpc-devel] Bug#477045: sugar-sharedstate: FTBFS: dh_install: sugar-sharingtest-activity missing files (debian/tmp/usr/share/activities/*), aborting

Jonas Smedegaard dr at jones.dk
Thu Apr 24 20:47:58 UTC 2008

Hash: SHA1

On Thu, Apr 24, 2008 at 10:15:15PM +0200, Santiago Ruano Rincón wrote:
>On Thu, Apr 24, 2008 at 06:22:00PM +0200, Jonas Smedegaard wrote:
>> On Thu, Apr 24, 2008 at 05:46:07PM +0200, Santiago Ruano Rincón wrote:

>> >I've fix this in the git repo, but I don't want to upload it before 
>> >having your approval,
>> Great to hear that you fixed it.
>Actually, I was not due the gcc transition, the activity was installed 
>in a wrong place.

I knew that already, actually - since April 17th when I fixed same issue 
with sugar-chat-activity which unfortunately haven't passed NEW queue 
yet.  I just hadn't reached sugar-sharedstate in my list of packages to 

>> You write that the fix is in "the git repo", but i don't get it when 
>> pulling.  Did you publish your changes to the Git at collab-maint 
>> Alioth group, or somewhere else?
>mmm, try again please.

Thanks - I got it now.  And your fix is same as I intended to do.


I'd appreciate if coordinating on this list if you want to change any of 
the files below debian/cdbs, as I intend for them to be included with 
the core cdbs package (or really, with todays surprise upload of 
debhelper 7 I consider abandoning cdbs altogether, but that's another 
story, and not right now).

I will replace with the python-sugar.mk from the Chat activity, which 
has the following changes:

  * Same change to install path
  * Tightened build-dependency on python-sugar-toolkit
  * No *.xo removal (not sure yet that it should be handled there)

I'll move the *.xo removal to the main rules file for now (and probably 
adopt it for the Chat activity too - thanks!).

>> >and, as Holger reported, I have journal, calculate, sharingtest and 
>> >pippy installed, but I don't see any of them.
>> I don't understand.  Where did Holger report this?  And what do you 
>> mean "installed" - did you install packages from somewhere or raw 
>> Activity zipfiles or what?
>I'm using the sugar debian packages. I've tried again and I only see 
>the journal activity.

I understand now what you are talking about.  And yes, same issue with 
those other activities.  I hope to reach them all tonight.

Reason I don't see the problem myself is that it only happens when a too 
new python-sugar-toolkit is installed at activity-package build time.

  - Jonas

- -- 
* Jonas Smedegaard - idealist og Internet-arkitekt
* Tlf.: +45 40843136  Website: http://dr.jones.dk/

  - Enden er nær: http://www.shibumi.org/eoti.htm
Version: GnuPG v1.4.6 (GNU/Linux)


More information about the Debian-olpc-devel mailing list