[gyoto] annotated tag upstream/0.2.2 created (now 585e627)
Thibaut Jean-Claude Paumard
thibaut at moszumanska.debian.org
Fri Sep 19 12:50:10 UTC 2014
This is an automated email from the git hooks/post-receive script.
thibaut pushed a change to annotated tag upstream/0.2.2
in repository gyoto.
at 585e627 (tag)
tagging fa5c38593c5d49d35ad6744522beb011477c57ea (commit)
replaces upstream/0.1.0
tagged by Thibaut Paumard
on Fri Sep 19 14:48:51 2014 +0200
- Log -----------------------------------------------------------------
Release 0.2.2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
iQIcBAABCAAGBQJUHCZAAAoJEJOUU0jg3ChA3rsP/2QOYVe8sVz78bgh0nhWF2yy
osvvHFP6n+XIo5C2nNkcIuLwyWuDiMTj4fJQdd/tDRuJkGyOgIu/mXQ7mpqRqYDm
JzhlRC/FtPx0eqgXmk+Q0TRlE9whL7hh5lah8S0DDa6Yz+3jmr7pkIeFqEPArSsP
yig4bvAHj35YKtJtx7Uo+rZJ3bMh0klYy5bualG2TtwRada87qb+HZq+iW/+Aj76
8HSVwf0BWJGCp6/j5U1gp120Bxhil7L94w3BT23xp6e0P+9vdzRN80Zy3BSD6Xor
FiQjCg+nn3/xzk8SkhcQAuDvJlGDGQNVRwPKwga73gF8IweNxUWDy8/pPqyyb2Wu
AQqDT40R4/FuW8/nXz12c7A9ASjoMXxsrDLCop6uSwSEhqThws+RtPyuXNs7IQJK
f9NpmY6FHz73PxFtBYnl9V0mVtts1rvl4LTTY7/WjsDZgHLLLEIO066z8bdQ8C61
CzeKv6ePPCdv8gkIU+DKVSzEG4u34zLdzeyaMwBa6mTUFtEXXsrc8Wdpd6ztc3S0
3lVSghQQVl729JXF0oYqi9jn2P/T2jh1hrjnKApR5135SqO93ccJLe9IM1sdbiDT
etDeLUC1tq9AE8xt5xhY7qt4EuEe1NIvM3YnhK+VNOM7uhM2dYAp4bo7JqUCEM72
UTZUm9Io02H2kmYmDduo
=kt3L
-----END PGP SIGNATURE-----
Frederic (38):
PageThorne: added the possibility to compute observed
Added ThinDiskIronLine astrobj to compute iron line profiles of thin disk
PatternDisk: implemented bilinear interpol for getVelocity() and emission()
KerrBL:
Added the possibility to raytrace only primary image of astrobj.
ThinDiskIronLine: changed default velocity when emission=0
Disk3D, Disk3D_BB: code cleaning + added flags to allow raytracing
UniformSphere: added possibility to emit isotropic constant emission
In Disk3D_BB: Updated radiative transfer treatment
Disk3D: Adding default value of opacity_ in constructor.
Disk3D_BB -> DynamicalDisk3D
Added Makefile.in
DynamicalDisk3D: code cleaning, proper implementation
Disk3D: changing value of deltat inside object to constant value
DynamicalDisk3D: added novel_ flag to ignore velocity when emitter velocity is not provided.
In KerrBL::diff changed derlim_hor from 1e5 to 1e4.
WorldlineIntegState: update in warning message
WorldlineIntegState: still updating warning message
UniformSphere.C: add optically thin case for isotropic_=1 in emission
UniformSphere: added spectral dependence (photon index)
RotStar3_1: updated myrk4_ada to follow the change in WlIntegState
Website change
Website changing
Website update
Still updating website
Still updating website
PolishDoughnut::emission: temperature calculation changed, previous was buggy
Code cleaning in KerrBL.
Code cleaning in PolishDoughnut/Komissarov
PolishDoughnut: erased Impact_ ; directional and angle-averaged synchrotron in Komissarov
Add doc/user_guide
Astrobj: add "const" keyword to rMax()
ThinDiskPL: just remove Rmin and Rmax, they shadow InnerRadius and OuterRadius!
Add new astrobj: DirectionalDisk
DirectionalDisk: implemented trilinear interpolation in emission()
Biblio manual added
Debug check-directionaldisk
Adding risco_ and rmb_ in NumericalMetricLorene
Thibaut Paumard (133):
Implement reading opacity extension in Disk3D. Beware: read, but not use.
add copyopacity= keyword to yorick/stdplug/gyoto_Disk3D.C
Fix Astrobj::getSubcontractor to throw error by default when kind is not found
errmode should be 0 by default in Spectrometer as well
implement mask in screen to compute only parts of an image
update data pointer correctly to make tracing a subset of the field correct
Merge branch 'master' of github-paumard:gyoto/Gyoto
* change Worldline::Integstate::nextStep() and Metric::*::myrk4_adaptive() to accept h1max parameter
implement Astrobj::Complex::deltaMax()
make sure h1max >= h1min
implement deltaMAx for UniformSphere and Torus
add members and accessors to UniformSphere to fine tune getDelta from XML or Yorick code
New astrobj StarTrace, currently too slow.
automatically check startrace.
optimize StarTrace
yorick interface for StarTrace
make startrace from star
make star from startrace in yorick
some doc in include/GyotoStarTrace.h
Make sure an Intensity FITS file can bre readiy used as a mask.
document StarTrace in Yorick plug-in
yorick/gyoto_Scenery.C: bugfix in maxiter keyword
KerrBL::CheckCons: make limarg relative to KK
yorick/mk-movie*.i: precompute mask, set aspect ratio to 4:3
Merge branch 'master' of github-paumard:gyoto/Gyoto
use "approximate" formula in getRayCoord for small angles, this is numerically more accurate than the mathematically exact expression. Set h1max to 1e10, but it could be even bigger.
Make Gyoto work for large distances:
Add DeltaMin and DeltaMax attributes to Metric::Generic, support it in KerrBL
add DiffTol and DeltaMaxOverR attributes to some of KerrBL, KerrKS and RotStar31
* rename functions from setMass/getMass style to mass()/mass() style.
rename RotStar3_1::integKind, RotStar3_1::fileName. Make sure compilation goes fine with HOME_LORENE set.
change method names in Screen: inclination, PALN, argument, distance
Simplify interaction between PolishDoughnut and PolishDoughnut::intesection and
fix "../include/GyotoPolishDoughnut.h:251: error: a class-key must be used when declaring a friend "
get/setMetric->metric, get/setRmax->rMax
Merge branch 'master' of github-paumard:gyoto/Gyoto
rename methods set/getScreen -> screen, fix last remaining warning
Add some API compatibility deprecation code
rename set/getKind -> kind everywhere, make sure Gyoto compiles with and withoug GYOTO_NO_DEPRECATED
rename set/getAstrobj -> astrobj
rename get/setSpectrometer -> spectrometer
rename get/setSpectrum -> spectrum and get/setOpacity -> opacity
rename get/setDelta/Delta0/Alpha0 -> delta/delta0/alpha0
rename get/setRadius/SmallRadius/LargeRadius/CentralDensity -> radius/smallRadius/largeRadius/centralDensity
rename get/set lambda, centralTempOverVirial, beta, constant, exponent
rename get/SetFlag_radtransf -> opticallyThin, nThreads, resolution, nSamples, spectralOversampling
get/set alpha0 and delta0 in Screen support in Yorick, support unit
add alpha0, delta0 in the doc of gyoto.Screen in the Yorick plug-in
rename set intensity/spectrum/binSpectrumConverter in Astrobj and Scenery
update autotools scripts, include new "compile" script.
Update configure script. Add "--enable-deprecated" option. The code should never be pushed when enabling this option is required to build the code.
Add work-in-progress (WIP) class
add WIP, use single call gmunu() in Metric::Generic and KerrBL (10% speed gain)
move delta_max_over_r_ machinery to Metric::Generic
code cleanup: remove useless constructors and destructors (in Metrics), protect kind(string) and coordKind(int) which should generally not be used.
Add Keplerian keyword in order to get circulartVelocity to return the Keplerian velocity
+ KerrKS: make it actually work, with the generic integrator. Using the specific integrator is an option, but it is currently broken.
Include new metric (WIP): NumericalMetricLorene
Provide a proper system for running the yorick plug-in from the built source tree. Just use the script yorick/yorick which is generated at configure time.
add some eye-candy in test suite
Implement KerrBL::christoffel(dst, pos)
KerrBL: allow using the generic integrator.
Allow setting FixedStar spectrum and opacity in the yorick plug-in
avoid div by zero in yorick/check-helpers.i
ensure gyoto.so is compiled before gyoto_std.so, which needs it on MacOS X
Add support for Boost ODEint integrators. Adds new build dependency on Boost.
Support the 4 Boost Runge-Kutta integrators
provide deltaMax, deltaMin and deltaMaxOverR interface directly in Worldline and Scenery for the new integrators.
access new integrator in Scenery from yorick
improve new integrators (initialize minimally)
allow setting abstol and reltol in new integrators
fix Worldline constructors and initializers to clone/init the IntegState when appropriate
implement non-adaptive boost steppers
store boost integrator kind in an enum instead of a string
support compiling without boost
put BOOST_CPPFLAGS in pkg-config file
put CXXFLAGS in gyoto.pc to convey -std=c++11
give access to the new integrator tuning parameters in yorick/Photon and Star
Few fixes for compilation under MacOS:
abide by delta_max_over_r_ in generic myrk4_adaptive, fix bug in Metric::Generic::deltaMax(pos, h) in case of Cartesian coordinates
Merge branch 'master' into odeint
Merge branch 'master' of github-paumard:gyoto/Gyoto
Merge branch 'master' into odeint
clone Scenery internal photon when ray-tracing in Yorick
Merge branch 'master' into odeint
Don't store Photon parameters in the Scenery object, but directly in the Photon template it holds. This avoids getting out-of-sync.
Merge branch 'master' into odeint
include <array> in GyotoWorldline.h
update configure to test for more flags to enable C++11, and to chicken out if none work.
Fix bug in Photon that would initialize the coordinate when it's supposed to remain uninitialized.
ensure the right compiler is used with compiling the yorick plug-in, and document how to select a compiler in INSTALL
Merge branch 'master' into odeint
improve configure to error out if boost was requested but C++11 or Boost not found
Merge branch 'master' of github-paumard:gyoto/Gyoto
Merge branch 'master' into odeint
* Fix bug that would break adaptive integration for the Legacy integrator in multi-threaded operation
Document and compare the integrators in the user guide
fix getRayCoord to work better for very small angle increments
Merge branch 'master' into odeint
fix bug in getRayCoord
Merge branch 'master' into odeint
* yorick: add haveUDUNITS()
ensure Gyoto builds and make check works even without xerces.
repair support building and checking without cfitsio
repair building *with* cfitsio (!)
fix many pedantic warnings (--enable-hardening)
more pedantic warnings
Merge branch 'master' of github-paumard:gyoto/Gyoto
fix more warnings
add configure option --disable-c++11
reorder configure script
Update manual:
Document how to extend Gyoto in the user guide.
doc build system:
Change dot operator syntax in Yorick plug-in.
fix lib/BlackBodySpectrum.C to compile with the minimal feature-set (--disable-xerces etc)
yorick: improve dot operator to support everything the () operator supports; improve doc
remove doc/user_guide/.gitignore
split ygyoto_private.h out of ygyoto.h
document Worldline and Worldline::IntegState
* remove const spcifier from Astrobj::rMax()
yorick: rename "accessor" to "closure", improve on_print method
fix minor bugs in yorick check files
Don't hide parameters with default values in fillElement, this way the user have almost a complete view of the parameters they might want to set when printing an object.
use boost::multiprecision in Screen::getRayCoord() to avoid loosing information due to the trigonometric functions
yorick/gyotoy.i: fix SAVE button label in export dialog, reorder buttons in import dialg
Merge branch 'master' of github-paumard:gyoto/Gyoto
Prepare for releasing 0.2.0:
Released 0.2.0
Released 0.2.1:
Correct KerrBL::circularVelocity()
Correct also the generic implementation of circularVelocity()
Release 0.2.2
-----------------------------------------------------------------------
This annotated tag includes the following new commits:
new ecedb39 Correct KerrBL::circularVelocity()
new 44a8a25 Correct also the generic implementation of circularVelocity()
new fa5c385 Release 0.2.2
The 3 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails. The revisions
listed as "adds" were already present in the repository and have only
been added to this reference.
--
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/debian-science/packages/gyoto.git
More information about the debian-science-commits
mailing list