[Gnuk-users] Error changing the PIN: Conditions of use not satisfied

Vagrant Cascadian vagrant at debian.org
Wed Sep 27 05:18:36 UTC 2017

Hey, really excited to try to use gnuk for real!

With a freshly flashed gnuk 1.2.5 on an FST-01, using Debian Stretch, I
cannot seem to change the PIN. I figured I should set a PIN before
uploading keys to it, and tried following the instructions here:


Was hoping to get it set up in "admin less mode", but I could probably
handle having an admin and reset pin as well, if that's not really

I'm not sure if there'se some important step I'm missing, or if
something is genuinely wrong with the gnuk build, the FST-01 hardware,
or somewhere in the gnupg stack:

  $ gpg --edit-card

  Reader ...........: 234B:0000:FSIJ-1.2.5-87023833:0
  Application ID ...: D276000124010200FFFE870238330000
  Version ..........: 2.0
  Manufacturer .....: unmanaged S/N range
  Serial number ....: 87023833
  Name of cardholder: [not set]
  Language prefs ...: [not set]
  Sex ..............: unspecified
  URL of public key : [not set]
  Login data .......: [not set]
  Signature PIN ....: forced
  Key attributes ...: rsa2048 rsa2048 rsa2048
  Max. PIN lengths .: 127 127 127
  PIN retry counter : 3 3 3
  Signature counter : 0
  Signature key ....: [none]
  Encryption key....: [none]
  Authentication key: [none]
  General key info..: [none]

  gpg/card> passwd
  gpg: OpenPGP card no. D276000124010200FFFE870238330000 detected
  Error changing the PIN: Conditions of use not satisfied

Tried with and without entering "admin" command first.  The retry
counter isn't changing, so I'm correctly entering the default pin.

First was using gnupg from Debian stretch (2.1.18-6), and then tried a
local build of the version on it's way to stable-proposed-updates
(2.1.18-8~deb9u1), since it contained some patches related to scdaemon,
but no luck.

Any thoughts or recommended further troubleshooting steps?

live well,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 832 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/gnuk-users/attachments/20170926/2b9e702d/attachment.sig>

More information about the gnuk-users mailing list