[Letsencrypt-devel] Bug#805185: letsencrypt - too lose dependencie

Bastian Blank waldi at debian.org
Sun Nov 15 17:14:33 UTC 2015

Package: letsencrypt
Version: 0.0.0.dev20151114-1
Severity: serious

letsencrypt have a unversioned dependency on python-letsencrypt.
However it fails to run if the version is different:

| Traceback (most recent call last):
|   File "/usr/bin/letsencrypt", line 5, in <module>
|     from pkg_resources import load_entry_point
| pkg_resources.DistributionNotFound: The 'letsencrypt==0.0.0.dev20151114' distribution was not found and is required by the application


-- System Information:
Debian Release: 8.2
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

More information about the Letsencrypt-devel mailing list