[Letsencrypt-devel] Bug#825635: python-acme: In backports python-letsencrypt(PL) depends on python-acme(PA)>=0.5 but PA(0.6) breaks PL<0.6

Rowan Thorpe rowan at rowanthorpe.com
Sat May 28 10:58:09 UTC 2016

Source: python-acme
Severity: important

Dear Maintainer,

* What led up to the situation?

I've been using python-letsencrypt (and therefore python-acme) OK from
jessie-backports, but today when provisioning a new server the latest state in
apt prevents installing either, due to the mutual breakage described in the
subject line. In more detail:

 python-letsencrypt (0.5.0-1~bpo8+1 - jessie-backports)
  depends on python-acme (>=0.5.0)


 python-acme (0.6.0-1~bpo8+1 - jessie-backports)
  breaks python-letsencrypt (<0.6.0)

-- System Information:
Debian Release: 8.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

More information about the Letsencrypt-devel mailing list