[Letsencrypt-devel] Bug#825750: letsencrypt: missing dependency

vincent vincent at autistici.org
Sun May 29 13:37:57 UTC 2016

Package: letsencrypt
Version: 0.5.0-1~bpo8+1
Severity: important
Tags: upstream

Dear Maintainer,

I have tried to install python-letsnecrypt by using the jessie-backports reposistory.
However it looks like it cannot be installed due to a missing dependency:

 % sudo apt-get -t jessie-backports install letsencrypt
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 letsencrypt : Depends: python-letsencrypt (= 0.5.0-1~bpo8+1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

% sudo apt-cache show python-letsencrypt                                                                                                                                                  :(
Package: python-letsencrypt
Version: 0.5.0-1~bpo8+1
Installed-Size: 734
Maintainer: Debian Let's Encrypt <letsencrypt-devel at lists.alioth.debian.org>
Architecture: all
Depends: python-acme (>= 0.5.0), python-configargparse, python-configobj, python-cryptography (>= 0.7), python-dialog, python-mock, python-openssl, python-parsedatetime, python-pkg-resources, python-psutil, python-rfc3339, python-six, python-tz, python-zope.component, python-zope.interface, python:any (<< 2.8), python:any (>= 2.7.5-5~)
Recommends: letsencrypt
Breaks: python-letsencrypt-apache (<< 0.5.0)
Description-en: Let's Encrypt main library
 The objective of Let's Encrypt and the ACME (Automated Certificate
 Management Environment) protocol is to make it possible to set up an
 HTTPS server and have it automatically obtain a browser-trusted
 certificate, without any human intervention. This is accomplished by
 running a certificate management agent on the web server.
 This agent is used to:
   - Automatically prove to the Let's Encrypt CA that you control the website
   - Obtain a browser-trusted certificate and set it up on your web server
   - Keep track of when your certificate is going to expire, and renew it
   - Help you revoke the certificate if that ever becomes necessary.
 This package contains the main libraries.
Description-md5: 0db0027fd10a6c6971e59a98760dceff
Homepage: https://letsencrypt.org/
Section: python
Priority: extra
Filename: pool/main/p/python-letsencrypt/python-letsencrypt_0.5.0-1~bpo8+1_all.deb
Size: 133584
MD5sum: 5fee698f30d1e2083f599f29eb9eb15e
SHA1: 20662ccd93dc12acde0b11e8a0a4aea7c9ed2e3b
SHA256: 13112a355d46f9fad27daca3e09813782a9416fe73f68710c1447adbbe5ee60d

The issue seems to be related to the most version of python-acme who breaks python-letsencrypt << 0.6.0

 % sudo dpkg -i python-letsencrypt_0.5.0-1\~bpo8+1_all.deb                                                                                                                                   :(
(Reading database ... 51620 files and directories currently installed.)
Preparing to unpack python-letsencrypt_0.5.0-1~bpo8+1_all.deb ...
Unpacking python-letsencrypt (0.5.0-1~bpo8+1) over (0.5.0-1~bpo8+1) ...
dpkg: dependency problems prevent configuration of python-letsencrypt:
 python-acme (0.6.0-1~bpo8+1) breaks python-letsencrypt (<< 0.6.0) and is installed.
  Version of python-letsencrypt to be configured is 0.5.0-1~bpo8+1.

dpkg: error processing package python-letsencrypt (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

-- System Information:
Debian Release: 8.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages letsencrypt depends on:
ii  dialog              1.2-20140911-1
ii  python              2.7.9-1
pn  python-letsencrypt  <none>
pn  python:any          <none>

letsencrypt recommends no packages.

Versions of packages letsencrypt suggests:
pn  python-letsencrypt-apache  <none>
pn  python-letsencrypt-doc     <none>

More information about the Letsencrypt-devel mailing list