[PKG-OpenRC-Debian] Bug#819258: openrc: dependency resolving fails using init-system-helpers

Adam Borowski kilobyte at angband.pl
Sat Mar 26 02:02:00 UTC 2016

On Fri, Mar 25, 2016 at 06:05:44PM +0100, Kevin Velghe wrote:
> Yesterday, I upgraded lvm2. During the upgrade, I got the following error:
>  insserv: Service mountdevsubfs has to be enabled to start service lvm2
>  insserv: exiting now!
> This was fixed by manually enabling mountdevsubfs using insserv, after
> which I could finish upgrading. This morning however, booting hanged at
> lvm. Downgrading lvm2 didn't solve the problem, so I tried booting using
> sysv-rc, which had the same problem. systemd booted well, as did openrc
> 0.20.4-1.
> So it seems openrc is able to handle the dependencies well, but that the
> current init-system-helpers does at least part of the work the sysv-rc
> way, which seems unable to handle it.

I've tried multiple scenarios but failed to reproduce your problem.
Including dist-upgrades:
  jessie sysv-rc -> unstable -> openrc
  jessie sysv-rc -> openrc -> unstable

So there's something more complex on your system than just lvm2.  Letting us
know what might be helpful in trying to find out what's amiss for you.

> I'm sorry if this should have been reported to init-system-helpers, I
> wasn't sure as it is openrc-specific.

As you say that sysv-rc failed too, it doesn't sound like anything related
to openrc.

A tit a day keeps the vet away.

More information about the OpenRC-devel mailing list