[PKG-Openstack-devel] Bug#930134: Please package new upstream version

Thomas Goirand zigo at debian.org
Tue Jun 11 08:27:50 BST 2019

On 6/10/19 9:59 PM, Jonas Meurer wrote:
> Hi Thomas,
> Thomas Goirand:
>>> do you have plans to update the python-falcon packages to a newer
>>> upstream version (2.0.0 being the most recent one at the moment)
>>> anytime soon?
>>> python3-falcon is a dependency for mailman3 and starting with mailman3
>>> version 3.2.2, falcon > 1.0.0 is required. So I'll have to wait for the
>>> python-falcon update before being able to update mailman3 to latest
>>> upstream release.
>> OpenStack Train (ie: the next version, due for early September) also
>> needs version 2.0.0, so I will package that. However, I don't see any
>> urgency during the Buster freeze.
> Sounds reasonable to me. I agree that we're not in a rush and can easily
> wait until after the Buster release.
>> Also, the current OpenStack version
>> needs 1.4.1, so uploading 2.0.0 to Experimental would break it.
> Mh, but the version in Debian is 1.0.0, so that doesn't work for current
> OpenStack version either, right? Mailman3 would be fine with any version
> newer than 1.0.0, so 1.4.1 would be sufficient.
> Cheers
>  jonas

Falcon 1.4.1 requires python3-mimeparse (>= 1.5.2), which isn't packaged
in Debian. Can you fill a bug against it so that it gets upgraded in
Experimental as well? Otherwise, I wont be able to do the work.


Thomas Goirand (zigo)

More information about the Openstack-devel mailing list