[Pkg-amule-devel] Bug#760434: amule: unusable GUI

Olly Betts olly at survex.com
Sat Sep 13 16:10:17 UTC 2014

On Tue, Sep 09, 2014 at 10:19:50PM +1000, Dmitry Smirnov wrote:
> I regret to report that on up-to-date "testing" amule 2.3.1+git1a369e47-1 is
> completely unusable because its GUI becomes unresponsive within minutes after
> start. It is enough to switch between Searches/Downloads/Statistics/About
> etc.  just few times to "About" dialog to pop-up empty -- then GUI stops
> responding and some time later amule terminates.
> It seems that regression is likely to be due to migration to WX-3.0.
> I had to revert to version 2.3.1-11 which works perfectly.

There are two big changes between 2.3.1-11 and 2.3.1+git1a369e47-1 - one
of them is indeed the switch to wx3.0, but the other is a switch to an
upstream git snapshot of amule.

I think it would be prudent to rebuild 2.3.1+git1a369e47-1 against wx2.8
and test if that has similar issues before blaming wx3.0 for these
problems.  While they could be related to wx3.0, I've not seen such
issues in any other packages.

Also, upstream's response to the forwarded ticket might be more useful
if you could show it happens with wx2.8 too.

I tried rebuilding 2.3.1+git1a369e47-1 with wx2.8 myself, but I couldn't
trigger this behaviour from either the package in sid or my rebuilt
version (I tried switching between tabs over and over as described
above), so that's rather inconclusive.  I wasn't connected to any
networks though, so that's perhaps why it didn't manifest.

I noticed wx upstream has applied a fix for the wxExecuteData issue
(http://trac.wxwidgets.org/ticket/16325) - I can apply that to the
wxwidgets3.0 package if you'd prefer to try updating 2.3.1-11 to work
with wx3.0.


More information about the Pkg-amule-devel mailing list