[pkg-boost-devel] Debian Lenny: compatibility between libcgal-dev and libboost1.35-dev

Joachim Reichel joachim.reichel at gmx.de
Thu Aug 6 20:56:53 UTC 2009

Hi Stephen,

> I'm running Debian Lenny on an amd64 box and I needed to load
> libcgal-dev to build pgRouting application. I have been using
> libboost1.35-dev and see that the packaging is broken if I try to
> install libcgal-dev.
> I might be able to backup to libboost 1.34.1, but it would be nice if
> libcgal would install on the newer version. I realize this might be an
> issue also with the boost team with respect to package names and
> version, but maybe you guys can work this out so users like me don't get
> tripped up by this problem.

the problems you are describing are unavoidable if there are several
versions of some library, but it is not possible to install the -dev
packages of both versions simultaneously. In lenny, CGAL is built
against Boost 1.34, although there is problem (known) with building
against 1.35. But such a change won't happen for lenny since it gets
only updates for security issues or grave bugs.

If I'm not mistaken most packages in lenny using Boost use 1.34,
therefore I'd suggest to install the 1.34 packages, or built CGAL
yourself against Boost 1.35.

About upcoming Debian releases: I'm aware of changes in the Boost
packaging, but don't recall the exact details at the moment. In
particular, I don't know whether it will be possible to install the -dev
packages of two Boost versions simultaneously. Maye the Boost team can
make a comment on that.


More information about the pkg-boost-devel mailing list