Subject: [Pkg-cacti-maint] Bug#758174: cacti: Error in /usr/share/cacti/site/scripts/loadavg_multi.pl script

From: Noel David Torres Taño <[email-masked]>
Date: Fri, 15 Aug 2014 02:47:16 +0100

Package: cacti
Version: 0.8.8a+dfsg-5+deb7u3
Severity: normal
Tags: patch l10n

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
fresh install of cacti on new machine, Spanish locale
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
no data from load average plugin
   * What outcome did you expect instead?
correct data

*** End of the template - remove these lines ***

I have noticed that no data were being graphed. Cacti's perl script expects this:
9:36pm  up 15 days, 11:37,  2 users,  load average: 0.14, 0.13, 0.10
but 'uptime' gives this:
02:44:06 up  7:06,  1 user,  load average: 0,00, 0,01, 0,05

Please note the differences in the decimal dot/comma.

patch is very simple:

4c4
< open(PROCESS, "LANG=C uptime |");
---
> open(PROCESS, "uptime |");

Thanks

-- System Information:
Debian Release: 7.5
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'testing-proposed-updates'), (500, 'proposed-updates'), (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.14-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=es_ES.UTF-8, LC_CTYPE=es_ES.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

---

From: Paul Gevers <[email-masked]>
Date: Mon, 18 Aug 2014 17:24:37 +0200

Control: forcemerge 704057 -1

> 02:44:06 up  7:06,  1 user,  load average: 0,00, 0,01, 0,05

Thanks for reporting this issue. However, it is a duplicate and already
fixed the current version of cacti.

Paul