Subject: [Pkg-cacti-maint] Bug#866773: Upgrade trouble because of upgrade_file path in update_database.php is wrong

From: ISHIKAWA Mutsumi <[email-masked]>
Date: Sun, 02 Jul 2017 00:42:37 +0900

Package: cacti
Version: 1.1.10+ds1-5
Severity: important
Tag: patch

Upgrade previous version 0.8.8h+ds1-9 in unstable to current
version 1.1.10+ds1-5 will cause trouble. Web UI and poller will
stop to work completely.

database upgrade script file path in
/usr/share/cacti/cli/upgrade_database.php is wrong, so the script
nothing to do.

--- cacti-1.1.10+ds1/cli/upgrade_database.php~	2017-07-02 00:02:52.000000000 +0900
+++ cacti-1.1.10+ds1/cli/upgrade_database.php	2017-07-02 00:06:24.120721633 +0900
@@ -118,7 +118,7 @@
 	}
 
 	// construct version upgrade include path
-	$upgrade_file = dirname(__FILE__) . '/../install/upgrades/' . str_replace('.', '_', $cacti_version) . '.php';
+	$upgrade_file = dirname(__FILE__) . '/../site/install/upgrades/' . str_replace('.', '_', $cacti_version) . '.php';
 	$upgrade_function = 'upgrade_to_' . str_replace('.', '_', $cacti_version);
 
 	// check for upgrade version file, then include, check for function and execute

-- 
ISHIKAWA Mutsumi
 <[email-masked]>, <[email-masked]>, <[email-masked]>

---

From: Paul Gevers <[email-masked]>
Date: Sat, 1 Jul 2017 19:46:52 +0200

Control: severity -1 serious
Control: tags -1 pending

> /usr/share/cacti/cli/upgrade_database.php is wrong, so the script

The logic in that file changed between 1.1.5 and 1.1.10, and indeed, I
haven't check upgrades in the last package and failed to see the impact
of the change.

This is RC, setting severity accordingly.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 01 Jul 2017 17:48:15 +0000

Processing control commands:

> severity -1 serious
Bug #866773 [cacti] Upgrade trouble because of upgrade_file path in update_database.php is wrong
Severity set to 'serious' from 'important'
> tags -1 pending
Bug #866773 [cacti] Upgrade trouble because of upgrade_file path in update_database.php is wrong
Added tag(s) pending.

-- 
866773: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=866773
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (Debian Bug Tracking System)
Date: Tue, 04 Jul 2017 18:39:05 +0000

Your message dated Tue, 04 Jul 2017 18:34:03 +0000
with message-id <[email-masked]>
and subject line Bug#866773: fixed in cacti 1.1.10+ds1-6
has caused the Debian Bug report #866773,
regarding Upgrade trouble because of upgrade_file path in update_database.php is wrong
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
866773: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=866773
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Upgrade trouble because of upgrade_file path in update_database.php is wrong
From: ISHIKAWA Mutsumi <[email-masked]>
To: [email-masked]
Date: Sun, 02 Jul 2017 00:42:37 +0900

Package: cacti
Version: 1.1.10+ds1-5
Severity: important
Tag: patch

 

Subject: Bug#866773: fixed in cacti 1.1.10+ds1-6
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Tue, 04 Jul 2017 18:34:03 +0000

Source: cacti
Source-Version: 1.1.10+ds1-6

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Tue, 04 Jul 2017 07:16:45 +0200
Source: cacti
Binary: cacti
Architecture: source
Version: 1.1.10+ds1-6
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 866773
Changes:
 cacti (1.1.10+ds1-6) unstable; urgency=medium
 .
   * Fix upgrade script to find the upgrade functions in the Debian file
     layout (Closes: #866773) Thanks to ISHIKAWA Mutsumi
   * Add upgrade code for grant on mysql.time_zone_name
   * Bump version of dbconfig-common to ensure we have the fix for postinst
     code working
Checksums-Sha1:
 cd83b13285eeba13a647ef4d95b383b81c57c324 2131 cacti_1.1.10+ds1-6.dsc
 009128c21e820094b12c7facd0b7a37f89d602e8 49616 cacti_1.1.10+ds1-6.debian.tar.xz
Checksums-Sha256:
 21a449825f0018c2c084bc6c6cfb210da9d0a16955692fb121d4e5b2d6f4c0c7 2131 cacti_1.1.10+ds1-6.dsc
 5edf409da013057e3bc7502f3d755730b257e68fe9e1c343199fe60db3c2f81a 49616 cacti_1.1.10+ds1-6.debian.tar.xz
Files:
 872b166290d77a6915e75bc5358f4c31 2131 web extra cacti_1.1.10+ds1-6.dsc
 45363166eec39c24c54165a0099b4b8a 49616 web extra cacti_1.1.10+ds1-6.debian.tar.xz