Subject: [Pkg-cacti-maint] Please sponsor cacti and cacti spine.

From: Mahyuddin Susanto <[email-masked]>
Date: Thu, 02 Feb 2012 20:30:45 +0700

Dear Sean and Paul,

As subject, cacti and cacti-spine need to upload to unstable. cacti
and spine source can be found at:
 - http://mentors.debian.net/debian/pool/main/c/cacti/cacti_0.8.7i-3.dsc
 -
http://mentors.debian.net/debian/pool/main/c/cacti-spine/cacti-spine_0.8.7i-2.dsc

Changelog for Cacti is:
cacti (0.8.7i-3) unstable; urgency=low

  * debian/patches/01_config.php.patch: refreshed to fix error
    on upgrade because /etc/cacti/debian.php has been rewrite
    during installation. (Closes: #654352), Thanks to Michael Reincke.
  * debian/control: Move apache to recommends to allow other web-server to
    be installed. (Closes: #654843)
  * debian/cacti.templates: Updated debconf template and package
description,
    suggested by debian-l10n-english. (Closes: #653897)
  * Update debconf translations:
    - Spanish by Javier Fernández-Sanguino Peña (Closes: #656405)
    - French by Christian Perrier (Closes: #657280)
    - Polish by Micha? Ku?ach. (Closes: #657294)
    - Danish by Joe Dalton. (Closes: #657339)
    - Dutch by Jeroen Schot. (Closes: #657468)
    - Swedish by Martin Bagge. (Closes: #657546)
    - Indonesian by Mahyuddin Susanto. (Closes: #657609)
    - Russian by Yuri Kozlov. (Closes: #657705)

 -- Mahyuddin Susanto <[email-masked]>  Thu, 02 Feb 2012 20:20:58 +0700

And for spine is:
cacti-spine (0.8.7i-2) unstable; urgency=low

  * debian/control: Add libmysqlclient-dev to Build-Depend to pick up
latest
    libmysqlclient.

 -- Mahyuddin Susanto <[email-masked]>  Thu, 02 Feb 2012 20:25:17 +0700

Thanks!
- -- 
[ Mahyuddin Susanto ] - http://udienz.web.id
GPG: 4096R/90B36C5B
Debian Maintainer & Ubuntu Developer

---

From: sean finney <[email-masked]>
Date: Thu, 2 Feb 2012 19:38:22 +0100

Hi Mahyuddin,

> As subject, cacti and cacti-spine need to upload to unstable. cacti

Great work!  I will look at it ASAP.  Just to make certain, everything's
in git, right?

	sean

---

From: Paul Gevers <[email-masked]>
Date: Thu, 02 Feb 2012 21:07:55 +0100

Hi Mahyuddin,

On 02-02-12 14:30, Mahyuddin Susanto wrote:
> As subject, cacti and cacti-spine need to upload to unstable.

I believe I wrote this before, but I don't have upload rights for cacti
until DMUA is set and I am added as an uploader. I don't expect this to
happen very soon as I find it necessary to earn the trust.

Paul

---

From: Paul Gevers <[email-masked]>
Date: Thu, 02 Feb 2012 21:27:08 +0100

Mahyuddin,

>     suggested by debian-l10n-english. (Closes: #653897)

I believe something went wrong with applying the proposed changes to our
git repository. Could you review the proposed text in bug 653897 and
renew the changes (also from the translations).

Paul

---

From: Mahyuddin Susanto <[email-masked]>
Date: Fri, 03 Feb 2012 12:54:47 +0700

> Great work!  I will look at it ASAP.  Just to make certain, everything's

Right, everything at GIT

> On 02/03/2012 03:07 AM, Paul Gevers wrote:
>> Hi Mahyuddin,
>> 

Paul, i think you can add yourself at Uploaders field now. and for DMUA,
only DD can set it sponsorsee can not set DMUA field.

--

---

From: sean finney <[email-masked]>
Date: Fri, 3 Feb 2012 08:08:01 +0100

Hi Guys,

(this is regarding cacti, spine will be next)

> only DD can set it sponsorsee can not set DMUA field.

I've gone ahead and added Paul to Uploaders, and set the DMUA field.  I still
have to sponsor the next upload, but after that he will be able to directly
upload and/or sponsor work, since his key is already in the debian-maintainers
keyring.  

Regarding the latest changes, I took a brief look over the diff from the
previous upload, and fixed one tiny problem in the postrm (removing the
lighttpd.conf file after ucf --purging it).  I have to admit that I wasn't
paying super close attention to the translation discussion, Mahyuddin could
you double check on that?  

Also, if I run debian/rules clean ru.po seems to get touched and fuzzied.
Again, I plead ignorance.  But either way I will do a quick smoke test on
the latest stuff and if there aren't any major problems I will tag/push/upload
it, as the rest can be fixed in a subsequent upload.

Thanks!
	sean

---

From: sean finney <[email-masked]>
Date: Fri, 3 Feb 2012 10:36:28 +0100

Grumble, I seem to be having a problem after installation.  I installed
the previous (broken) 0.8.7i-2, and then upgraded to the new -3 version,
but the default graphs are never generated.  cranking up the logging I get:

02/03/2012 01:10:01 AM - POLLER: Poller[0] NOTE: Poller Int: '300', Cron Int: '300', Time Since Last: '300', Max Runtime '298', Poller Runs: '1'
02/03/2012 01:10:01 AM - POLLER: Poller[0] NOTE: There are no items in your poller for this polling cycle!
02/03/2012 01:10:01 AM - SYSTEM STATS: Time:0.1111 Method:cmd.php Processes:1 Threads:N/A Hosts:2 HostsPerProcess:2 DataSources:0 RRDsProcessed:0

Can anyone confirm this behavior?  Will hold off on the upload for another
day in the meantime...

On Fri, Feb 03, 2012 at 08:08:01AM +0100, sean finney wrote:
> _______________________________________________
> Pkg-cacti-maint mailing list
> [email-masked]
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-cacti-maint
> 

--

---

From: Paul Gevers <[email-masked]>
Date: Fri, 09 Mar 2012 23:40:50 +0100

Sean,

> Can anyone confirm this behavior?  Will hold off on the upload for another

Any errors with building or with file permissions? I see:
"""
find debian/cacti/usr/share/cacti/cli -type f -print0 | xargs -0 file |\
                grep /usr/bin/php | cut -d: -f1 | xargs chmod ug+x
chmod: missing operand after `ug+x'
"""

If I run
$ find debian/cacti/usr/share/cacti/cli -type f -print0 | xargs -0 file
manually, I get things like:
"""
debian/cacti/usr/share/cacti/cli/add_data_query.php:
PHP script, ASCII text executable
"""

Shouldn't the grep be changed to """grep "PHP script, ASCII text
executable" """?

I fail to build a package now.

Paul

---

From: Mahyuddin Susanto <[email-masked]>
Date: Sun, 25 Mar 2012 00:28:31 +0700

Hi Guys, sorry for disappearing for a long time

> I fail to build a package now.

I can confirm this, and seems like your recent change at debian/rules
has successfully solved this problem. I grab cacti repository from
alioth and i have tested in my local machine, and all going fine.

$ apt-cache policy cacti
cacti:
  Installed: 0.8.7i-3
  Candidate: 0.8.7i-3
  Version table:
 *** 0.8.7i-3 0
        100 /var/lib/dpkg/status
     0.8.7i-2 0
        500 http://buaya.klas.or.id/debian/ testing/main amd64 Packages
        500 http://kambing.ui.ac.id/debian/ testing/main amd64 Packages
        499 http://kambing.ui.ac.id/debian/ unstable/main amd64 Packages

-- 
[ Mahyuddin Susanto ]