Subject: [Pkg-cacti-maint] Bug#796009: Package cacti depends on libjs-jquery-cookie. Currently libjs-jquery-cookie is shown as Recommended

From: Manos Saratsis <[email-masked]>
Date: Tue, 18 Aug 2015 14:52:56 +0000 (UTC)

Package: cacti
Version: 0.8.8a+dfsg-5+deb7u4
I am using "Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.63-2 x86_64 GNU/Linux" and I have installed cacti on this box.I installed only the packages that cacti depends on but not the recommended and there was a jquery related issue that I could not navigate through graphs by clicking on the different graph trees but this works when you open the graph tree in new tab.I suggest that the package cacti depends on the libjs-jquery-cookie and shouldn't be on the recommended packages list.
KR,Manos

---

From: [email-masked] (Debian Bug Tracking System)
Date: Thu, 20 Aug 2015 06:39:09 +0000

Processing control commands:

> tags -1 wontfix
Bug #796009 [cacti] Package cacti depends on libjs-jquery-cookie. Currently libjs-jquery-cookie is shown as Recommended
Added tag(s) wontfix.

-- 
796009: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=796009
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Paul Gevers <[email-masked]>
Date: Thu, 20 Aug 2015 08:21:53 +0200

Control: tags -1 wontfix

Hi Manos,

On 18-08-15 16:52, Manos Saratsis wrote:
> I am using "Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.63-2 x86_64 GNU/Linux"
> and I have installed cacti on this box.

Great.

> I installed only the packages that cacti depends on but not the
> recommended

This is your choice, but not the default in Debian.

> and there was a jquery related issue that I could not
> navigate through graphs by clicking on the different graph trees but
> this works when you open the graph tree in new tab.

I understand that cacti is less manageable than ideal, but I believe it
still works.

> I suggest that the package cacti depends on the libjs-jquery-cookie and
> shouldn't be on the recommended packages list.

I don't agree. Recommends is exactly for this purpose¹:
 This declares a strong, but not absolute, dependency.
 The Recommends field should list packages that would be found together
 with this one in all but unusual installations.

This means that your setup is "unusual" and that is your own choice.

Paul

¹
https://www.debian.org/doc/debian-policy/ch-relationships.html#s-binarydeps

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 04 Apr 2016 20:00:05 +0000

Your message dated Mon, 4 Apr 2016 21:56:57 +0200
with message-id <[email-masked]>
and subject line close cacti bug 796009
has caused the Debian Bug report #796009,
regarding Package cacti depends on libjs-jquery-cookie. Currently libjs-jquery-cookie is shown as Recommended
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: Package cacti depends on libjs-jquery-cookie. Currently libjs-jquery-cookie is shown as Recommended
From: Manos Saratsis <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Tue, 18 Aug 2015 14:52:56 +0000 (UTC)

Package: cacti

Subject: close cacti bug 796009
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 4 Apr 2016 21:56:57 +0200

Version: 0.8.8c+ds1-1

The corresponding changelog (use system versions of javascripts):

cacti (0.8.8c+ds1-1) experimental; urgency=medium

  * New upstream release
  * Strip several parts from the upstream source
    - convenience copies (javascript and adodb) that have a corresponding
      package in Debian
    - other unused javascript files (some lacking source)
    - font files without source
  * Drop patches now applied upstream
  * Upstream now has a DFSG treeview, drop Debian patches
  * Drop recommends on jquery (too old for this treeview, use
    convenience copy in source)
  * Add patch to use system versions of javascripts
  * Update d/copyright
  * Update standards to 3.9.6 (no changes)
  * Update d/watch, d/rules and d/copyright to download and strip source

 -- Paul Gevers <[email-masked]>  Mon, 08 Dec 2014 21:28:05 +0100