Subject: [Pkg-cacti-maint] Bug#1028764: cacti: FTBFS: make[1]: *** [debian/rules:55: override_dh_fixperms] Error 123

From: Lucas Nussbaum <[email-masked]>
Date: Sat, 14 Jan 2023 13:33:06 +0100

Source: cacti
Version: 1.2.23+ds1-1
Severity: serious
Justification: FTBFS
Tags: bookworm sid ftbfs
User: [email-masked]
Usertags: ftbfs-20230113 ftbfs-bookworm

Hi,

During a rebuild of all packages in sid, your package failed to build
on amd64.

Relevant part (hopefully):
> make[1]: Entering directory '/<<PKGBUILDDIR>>'
> # normalize permissions in the site directory
> find /<<PKGBUILDDIR>>/debian/cacti/usr/share/cacti/site/ -type d -exec chmod 755 {} \;
> find /<<PKGBUILDDIR>>/debian/cacti/usr/share/cacti/site/ -type f -exec chmod 644 {} \;
> find /<<PKGBUILDDIR>>/debian/cacti/usr/share/cacti/site/scripts -type f -exec chmod 755 {} \;
> # and then fix the special case files
> chmod 644 /<<PKGBUILDDIR>>/debian/cacti/usr/share/cacti/site/scripts/.htaccess
> find /<<PKGBUILDDIR>>/debian/cacti/usr/share/cacti/site/scripts -type f -name '*.php' -exec chmod 644 {} \;
> find /<<PKGBUILDDIR>>/debian/cacti/usr/share/cacti/cli -type f -print0 | xargs -0 file | \
> 	grep -e /usr/bin/php -e "a /usr/bin/env php script, ASCII text executable" | \
> 	cut -d: -f1 | xargs chmod 755
> chmod: missing operand after ‘755’
> Try 'chmod --help' for more information.
> make[1]: *** [debian/rules:55: override_dh_fixperms] Error 123

The full build log is available from:
http://qa-logs.debian.net/2023/01/13/cacti_1.2.23+ds1-1_unstable.log

All bugs filed during this archive rebuild are listed at:
https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=ftbfs-20230113;users=[email-masked]
or:
https://udd.debian.org/bugs/?release=na&merged=ign&fnewerval=7&flastmodval=7&fusertag=only&fusertagtag=ftbfs-20230113&fusertaguser=[email-masked]&allbugs=1&cseverity=1&ctags=1&caffected=1#results

A list of current common problems and possible solutions is available at
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

If you reassign this bug to another package, please mark it as 'affects'-ing
this package. See https://www.debian.org/Bugs/server-control#affects

If you fail to reproduce this, please provide a build log and diff it with mine
so that we can identify if something relevant changed in the meantime.

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Thu, 19 Jan 2023 10:39:05 +0000

Your message dated Thu, 19 Jan 2023 10:34:35 +0000
with message-id <[email-masked]>
and subject line Bug#1028764: fixed in cacti 1.2.23+ds1-2
has caused the Debian Bug report #1028764,
regarding cacti: FTBFS: make[1]: *** [debian/rules:55: override_dh_fixperms] Error 123
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
1028764: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1028764
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: FTBFS: make[1]: *** [debian/rules:55: override_dh_fixperms] Error 123
From: Lucas Nussbaum <[email-masked]>
To: [email-masked]
Date: Sat, 14 Jan 2023 13:33:06 +0100

Source: cacti
Version: 1.2.23+ds1-1
Severity: serious
Justification: FTBFS
Tags: bookworm sid ftbfs
User: [email-masked]

Hi,

Subject: Bug#1028764: fixed in cacti 1.2.23+ds1-2
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Thu, 19 Jan 2023 10:34:35 +0000

Source: cacti
Source-Version: 1.2.23+ds1-2
Done: Paul Gevers <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Thu, 19 Jan 2023 10:30:29 +0100
Source: cacti
Architecture: source
Version: 1.2.23+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Closes: 1028141 1028764
Changes:
 cacti (1.2.23+ds1-2) unstable; urgency=medium
 .
   * d/rules: fix for new 'file' behavior (Closes: #1028764)
   * Adapt for changes in php-phpmyadmin-motranslator (Closes: #1028141)
   * d/rules: don't compress CHANGELOG symlink
   * tests: several improvement + re-add my own old check-all-pages
Checksums-Sha1:
 c899490dcfe791e43eaf45e271a7b3010ed4b3f5 2239 cacti_1.2.23+ds1-2.dsc
 78a80966aeb6a0bba6d01a17a48e3c9f9eba1c73 59744 cacti_1.2.23+ds1-2.debian.tar.xz
Checksums-Sha256:
 171c174043d54ab5a919be28759201133e4e10648933408dd03435a7e3f46031 2239 cacti_1.2.23+ds1-2.dsc
 1d6a8c1e709a988b7ddbaaff7effcaab47a77afc052f46b62094f947ebff277e 59744 cacti_1.2.23+ds1-2.debian.tar.xz
Files:
 7138b354efe00651e97de1b5db9e7704 2239 web optional cacti_1.2.23+ds1-2.dsc
 bcbe43d723e813e9b35a0d07cb192394 59744 web optional cacti_1.2.23+ds1-2.debian.tar.xz