Subject: [Pkg-cacti-maint] Bug#783402: cacti package is completely broken, nothing works out of the box

From: "[email-masked]" <[email-masked]>
Date: Sun, 26 Apr 2015 18:58:49 +0000

Package: cacti
Version: 0.8.8a+dfsg-5+deb7u4
Severity: important

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
installed cacti package

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

apt-get install cacti
followed installation instructions

   * What was the outcome of this action?
cacti doesn't work.
It does not generate files in the rra/ directory
It does not show any graphs

Also, the installed HTML documentation has broken links to wrong paths of CSS files

   * What outcome did you expect instead?

Should work out of the box.
And the HTML documentation should be built and linked correctly

See these reports which have been closed by the upstream developer who says they're the debian package's fault:
http://bugs.cacti.net/view.php?id=2558
http://bugs.cacti.net/view.php?id=2554

*** End of the template - remove these lines ***

-- System Information:
Debian Release: 7.6
  APT prefers oldstable
  APT policy: (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.49
ii  libapache2-mod-php5                      5.4.39-0+deb7u2
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.40-0+wheezy1
ii  perl                                     5.14.2-21+deb7u2
ii  php5-cli                                 5.4.39-0+deb7u2
ii  php5-mysql                               5.4.39-0+deb7u2
ii  php5-snmp                                5.4.39-0+deb7u2
ii  rrdtool                                  1.4.7-2
ii  snmp                                     5.4.3~dfsg-2.8+deb7u1
ii  ucf                                      3.0025+nmu3

Versions of packages cacti recommends:
ii  apache2                      2.2.22-13+deb7u3
ii  apache2-mpm-prefork [httpd]  2.2.22-13+deb7u3
ii  iputils-ping                 3:20101006-1+b1
ii  libjs-jquery                 1.7.2+dfsg-1
ii  libjs-jquery-cookie          6-1
ii  logrotate                    3.8.1-4
ii  mysql-server                 5.5.40-0+wheezy1

Versions of packages cacti suggests:
pn  moreutils  <none>
pn  php5-ldap  <none>

-- debconf information excluded

---

From: Paul Gevers <[email-masked]>
Date: Sun, 26 Apr 2015 22:18:06 +0200

Control: clone -1 -2
Control: retitle -2 cacti package is missing or misplacing manual.css
Control: severity -2 minor
Control: tags -1 moreinfo

Hi Teo,

Please at least read the README.Debian file provided with cacti before
filing bugs.

> It does not generate files in the rra/ directory

Have you waited at least five minutes before looking in this directory?
Have you changed ANY of the default settings? What are the file
permissions of the /var/lib/cacti/rra directory? Can you share the log
file in /var/log/cacti?

> It does not show any graphs

If there aren't any rrd files, that is the logical consequence. If the
rrd files only contain one datapoint yet, that is also the normal behavior.

> Should work out of the box.

Fully agree, and every time I try, it does (unless errors occur during
installation of course). Although

> And the HTML documentation should be built and linked correctly

Indeed, but please don't put multiple bugs into one bug report. Do you
care to tell me which html documentation is missing and where it is
linked incorrectly? (seems like your cacti bug 2554)

> http://bugs.cacti.net/view.php?id=2554

Indeed, please report bugs in Debian packages to Debian, unless
requested by the maintainer to do it upstream. There is always a large
chance that the bug is Debian specific.

The warning you reported in 2551 is not created by the cacti package,
but is (probably) related to the fact that adodb is a dependency of
cacti. You could take this up with the adodb maintainer, I suspect this
warning may not be needed anymore (I remember I saw it long time ago,
not sure if it is too long ago).

The answer to your reported issue (explanation about the admin/admin
username/password combo) in 2252 is in README.Debian. Do you think this
issue warrants a debconf popup?

I can reproduce the issue that
http://<host>/cacti/docs/html/unix_configure_cacti.html can not find the
css file. Cloning this bug.

Do you have the relevant part (the part where you installed cacti and
its dependencies) of /var/log/apt/term.log, so that I can check for
common errors?

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 26 Apr 2015 20:21:08 +0000

Processing control commands:

> clone -1 -2
Bug #783402 [cacti] cacti package is completely broken, nothing works out of the box
Bug 783402 cloned as bug 783416
> retitle -2 cacti package is missing or misplacing manual.css
Bug #783416 [cacti] cacti package is completely broken, nothing works out of the box
Changed Bug title to 'cacti package is missing or misplacing manual.css' from 'cacti package is completely broken, nothing works out of the box'
> severity -2 minor
Bug #783416 [cacti] cacti package is missing or misplacing manual.css
Severity set to 'minor' from 'important'
> tags -1 moreinfo
Bug #783402 [cacti] cacti package is completely broken, nothing works out of the box
Added tag(s) moreinfo.

-- 
783402: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783402
783416: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783416
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Matteo Sisti Sette <[email-masked]>
Date: Sun, 26 Apr 2015 23:34:27 +0200

> Have you waited at least five minutes before looking

LOL yes, of course. Much more.
The cronjob was installed, and I also tried to run poller.php manually 
(which produced no output at all nor error messages). But after more 
than half an hour still no file was generated in the rra directory.

> Have you changed ANY of the default settings?

No, except the ones I was prompted for.

> What are the file
> permissions of the /var/lib/cacti/rra directory?

The rra directory was owned by user root and group www-data. The user 
www-data which belongs to the group www-data is the one Apache runs as.
The permissions were 770. So the permissions look fine.
Anyway, I tried changing them to 777 (and waiting 5 minutes, and 
manually running poller.php), but it didn't fix the issue. Also tried 
changing the ownership to the user www-data (and waiting, etc). Nothing. 
So I reverted ownership and permission to the original.

> Can you share the log

Attached. At some point I changed the log level to "debug", then back to 
"low".

> If there aren't any rrd files,

Yeah, that's the problem, there aren't any rrd files.

By the way, I think the very fact that poller.php doesn't issue any 
error message (neither to the output nor to logs) while it's not 
generating any rrd file (or whatever it is supposed to generate) is a 
bug in itself, regardless of why the rrd files are not being generated.

> Do you

No html is missing or linked incorrectly. Just CSS. Yes it's 2554, which 
you said you could reproduce.

> issue warrants a debconf popup?

Not sure what a debconf popup is. I think at the end of the debian 
package installation process a message should be output (be it a popup 
or a simple message in the terminal) saying something more or less like
"You can/should now complete cacti setup by logging in at 
http://yoursite.com/cacti and logging in with user 'admin' and password 
'admin"

> its dependencies) of /var/log/apt/term.log, so that I can check for

Attached.

One thing that I then noticed is that
  ps aux |grep snmpd
didn't output anything.
Isn't a snmpd daemon supposed to be running? May this be the problem?

  service snmpd start
didn't issue any error (nor a message saying something like the daemon 
already being running), but even after that, ps aux |grep snmpd didn't 
output anything.

Indeed, I examined /etc/init.d/snmpd
and I found out it tests for the existence of two binaries under 
/usr/sbin and exits if they don't exist. These files didn't exist.
I'm using the past tense because by now I have already uninstalled 
everything.
So maybe something is wrong with the snmpd package rather than cacti?

---

From: Paul Gevers <[email-masked]>
Date: Mon, 27 Apr 2015 08:04:35 +0200

Control: clone -1 -2 -3
Control: retitle -2 cacti should ask for interface admin password
Control: severity -2 normal
Control: tags -2 confirmed
Control: retitle -3 cacti should finish the install process
Control: severity -3 normal
Control: tags -3 confirmed
Control: tags 783416 confirmed
Control: close -1 0.8.8a+dfsg-6

Could you please recreate the poller cache and see if that solves your
issue? I fixed this issue in 0.8.8a+dfsg-6 (upstream bug 2229).

System Utilities -> Rebuild Poller Cache.

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 27 Apr 2015 06:09:13 +0000

Processing control commands:

> clone -1 -2 -3
Bug #783402 [cacti] cacti package is completely broken, nothing works out of the box
Bug 783402 cloned as bugs 783446-783447
> retitle -2 cacti should ask for interface admin password
Bug #783446 [cacti] cacti package is completely broken, nothing works out of the box
Changed Bug title to 'cacti should ask for interface admin password' from 'cacti package is completely broken, nothing works out of the box'
> severity -2 normal
Bug #783446 [cacti] cacti should ask for interface admin password
Severity set to 'normal' from 'important'
> tags -2 confirmed
Bug #783446 [cacti] cacti should ask for interface admin password
Added tag(s) confirmed.
> retitle -3 cacti should finish the install process
Bug #783447 [cacti] cacti package is completely broken, nothing works out of the box
Changed Bug title to 'cacti should finish the install process' from 'cacti package is completely broken, nothing works out of the box'
> severity -3 normal
Bug #783447 [cacti] cacti should finish the install process
Severity set to 'normal' from 'important'
> tags -3 confirmed
Bug #783447 [cacti] cacti should finish the install process
Added tag(s) confirmed.
> tags 783416 confirmed
Added tag(s) confirmed.
> close -1 0.8.8a+dfsg-6
Bug #783402 [cacti] cacti package is completely broken, nothing works out of the box
Marked as fixed in versions cacti/0.8.8a+dfsg-6.
Bug #783402 [cacti] cacti package is completely broken, nothing works out of the box
Marked Bug as done

-- 
783402: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783402
783416: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783416
783446: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783446
783447: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=783447
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 03 Aug 2015 18:21:04 +0000

Your message dated Mon, 03 Aug 2015 18:18:49 +0000
with message-id <[email-masked]>
and subject line Bug#783416: fixed in cacti 0.8.8f+ds1-2
has caused the Debian Bug report #783416,
regarding cacti package is missing or misplacing manual.css
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti package is completely broken, nothing works out of the box
From: "[email-masked]" <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sun, 26 Apr 2015 18:58:49 +0000

Package: cacti

Dear Maintainer,

apt-get install cacti

-- System Information:
Debian Release: 7.6
  APT prefers oldstable

Subject: Bug#783416: fixed in cacti 0.8.8f+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 03 Aug 2015 18:18:49 +0000

Source: cacti
Source-Version: 0.8.8f+ds1-2

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Mon, 03 Aug 2015 19:58:53 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8f+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 783416 793401
Changes:
 cacti (0.8.8f+ds1-2) unstable; urgency=medium
 .
   * Update loadavg_multi_locale_friendly.patch (Closes: #793401)
   * Add missing manual.css (Closes: #783416)
   * Fix d/rules override_dh_*configure target (Wasn't ever run,
     althought that wasn't too bad until now)
Checksums-Sha1:
 1a2ba4b3b308d2f5b10a972a3c156283d71d8f1a 1591 cacti_0.8.8f+ds1-2.dsc
 a096e23b1cd454f3844aca726c93cb1215f3e650 46156 cacti_0.8.8f+ds1-2.debian.tar.xz
 c4e8c1640327949e25551fdf4beb4f4250cf0e9f 1992498 cacti_0.8.8f+ds1-2_all.deb
Checksums-Sha256:
 625fbc475679fe4ef5ef22ac6f7b2c0fc1de9688cbbfbe56f04869bc11f79e70 1591 cacti_0.8.8f+ds1-2.dsc
 9a6e3c87f6754228dbd8421f47c40d4f1460b96ff20274455808f5ed625bcc39 46156 cacti_0.8.8f+ds1-2.debian.tar.xz
 b7d60080f5bf02b5f4290e000ec19ae63991290eafd2b65edbe0e1545f329644 1992498 cacti_0.8.8f+ds1-2_all.deb
Files:
 3e49fb915c0e5a169bf901eef4fc35ee 1591 web extra cacti_0.8.8f+ds1-2.dsc
 a531b18e66d8c58bc2f8dfac0cc59c4b 46156 web extra cacti_0.8.8f+ds1-2.debian.tar.xz
 0512296afd73d18f58ef133962e9159b 1992498 web extra cacti_0.8.8f+ds1-2_all.deb

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 17 Apr 2016 18:36:08 +0000

Your message dated Sun, 17 Apr 2016 18:34:27 +0000
with message-id <[email-masked]>
and subject line Bug#783446: fixed in cacti 0.8.8g+ds1-2
has caused the Debian Bug report #783446,
regarding cacti should ask for interface admin password
to be marked as done.

Package: cacti

Dear Maintainer,

apt-get install cacti

-- System Information:
Debian Release: 7.6
  APT prefers oldstable

Subject: Bug#783446: fixed in cacti 0.8.8g+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sun, 17 Apr 2016 18:34:27 +0000

Source: cacti
Source-Version: 0.8.8g+ds1-2

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Format: 1.8
Date: Sun, 17 Apr 2016 19:55:43 +0200
Source: cacti
Binary: cacti
Architecture: source
Version: 0.8.8g+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 783446 783447 815987 816962 818647
Changes:
 cacti (0.8.8g+ds1-2) unstable; urgency=medium
 .
   [ Paul Gevers ]
   * Next upstream version, strip include/js/jquery.js from source
   * Make sure the web-interface doesn't ask unnecessary questions after
     install (Closes: #783447)
   * Use the MySQL connection password as initial password for the admin
     user (Closes: #783446) and mention this in the NEWS.Debian file
   * Improve fix for CVE-2016-2313 such that it doesn't cause a regression
     for setups that rely on http authentication of users unknown to cacti.
     - Add improve_fix_for_CVE-2016-2313.patch
   * Full update of README.Debian
   * CVE-2016-3172
     - Add CVE-2016-3172_sql-injection-in-tree.php.patch (Closes: #818647)
   * Update Brazilian Portuguese, thanks to Diego Neves (Closes: #816962)
   * Drop old code in postinst to (re)move old configuration files this is
     already fixed in jessie
   * Bump version for libphp-adodb as mysqli doesn't work otherwise
   * Add new php-xml & php-mbstring to Depends for php7.0
   * Add add_rrdtool-1.5_to_utilities.php.patch to prevent error in
     utilities.php with rrdtool version 1.5
   * Remove Mahyuddin from uploaders (thanks for the fish)
 .
   [ Nishanth Aravamudan ]
   * Update to PHP7.0 dependencies (LP: #1544352)
   * Default to mysqli driver for database connection, as the mysql driver
     has been removed in PHP7.0 (LP: #1544352) (Closes: #815987)
Checksums-Sha1:
 6886b225b9df2e688c0b177d0a89c5baf3c7ae73 1571 cacti_0.8.8g+ds1-2.dsc
 8c1b1c46caa858521cca1e9f676aad7b5ef500cb 47472 cacti_0.8.8g+ds1-2.debian.tar.xz
Checksums-Sha256:
 ea004d0269efdf957984ae13c1bf4040dd6e0416f4b66629fdbf261deddf3c39 1571 cacti_0.8.8g+ds1-2.dsc
 20cd1269b804126cb83f3be15d77e4baea8e29df0751f0addb01ef5c6a2e9f0a 47472 cacti_0.8.8g+ds1-2.debian.tar.xz
Files:
 9b7bbe22e077f97f3ba6091f551aa2ab 1571 web extra cacti_0.8.8g+ds1-2.dsc
 5e8b3d0cbd7a75a39fad62514fdb8824 47472 web extra cacti_0.8.8g+ds1-2.debian.tar.xz

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 17 Apr 2016 18:36:11 +0000

Your message dated Sun, 17 Apr 2016 18:34:27 +0000
with message-id <[email-masked]>
and subject line Bug#783447: fixed in cacti 0.8.8g+ds1-2
has caused the Debian Bug report #783447,
regarding cacti should finish the cli part of the install process
to be marked as done.

Package: cacti

Dear Maintainer,

apt-get install cacti

-- System Information:
Debian Release: 7.6
  APT prefers oldstable

Subject: Bug#783447: fixed in cacti 0.8.8g+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sun, 17 Apr 2016 18:34:27 +0000

Source: cacti

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Format: 1.8