Subject: [Pkg-cacti-maint] Bug#841312: cacti-spine: FTBFS: configure: error: MySQL libraries not found

From: Chris Lamb <[email-masked]>
Date: Wed, 19 Oct 2016 15:34:11 +0100

Source: cacti-spine
Version: 0.8.8h-1
Severity: serious
Justification: fails to build from source
User: [email-masked]
Usertags: ftbfs
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

cacti-spine fails to build from source in unstable/amd64:

  […]

  Unpacking zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) ...
  Selecting previously unselected package libmysqlclient-dev.
  Preparing to unpack .../03-libmysqlclient-dev_5.7.15-1_amd64.deb ...
  Unpacking libmysqlclient-dev (5.7.15-1) ...
  Selecting previously unselected package libpci3:amd64.
  Preparing to unpack .../04-libpci3_1%3a3.3.1-1.1_amd64.deb ...
  Unpacking libpci3:amd64 (1:3.3.1-1.1) ...
  Selecting previously unselected package libsensors4:amd64.
  Preparing to unpack .../05-libsensors4_1%3a3.4.0-3_amd64.deb ...
  Unpacking libsensors4:amd64 (1:3.4.0-3) ...
  Selecting previously unselected package libwrap0:amd64.
  Preparing to unpack .../06-libwrap0_7.6.q-25_amd64.deb ...
  Unpacking libwrap0:amd64 (7.6.q-25) ...
  Selecting previously unselected package libsnmp-base.
  Preparing to unpack .../07-libsnmp-base_5.7.3+dfsg-1.5_all.deb ...
  Unpacking libsnmp-base (5.7.3+dfsg-1.5) ...
  Selecting previously unselected package libsnmp30:amd64.
  Preparing to unpack .../08-libsnmp30_5.7.3+dfsg-1.5+b1_amd64.deb ...
  Unpacking libsnmp30:amd64 (5.7.3+dfsg-1.5+b1) ...
  Selecting previously unselected package libwrap0-dev:amd64.
  Preparing to unpack .../09-libwrap0-dev_7.6.q-25_amd64.deb ...
  Unpacking libwrap0-dev:amd64 (7.6.q-25) ...
  Selecting previously unselected package libssl-dev:amd64.
  Preparing to unpack .../10-libssl-dev_1.0.2j-1_amd64.deb ...
  Unpacking libssl-dev:amd64 (1.0.2j-1) ...
  Selecting previously unselected package libsensors4-dev.
  Preparing to unpack .../11-libsensors4-dev_1%3a3.4.0-3_amd64.deb ...
  Unpacking libsensors4-dev (1:3.4.0-3) ...
  Selecting previously unselected package libudev-dev:amd64.
  Preparing to unpack .../12-libudev-dev_231-9_amd64.deb ...
  Unpacking libudev-dev:amd64 (231-9) ...
  Selecting previously unselected package libpci-dev.
  Preparing to unpack .../13-libpci-dev_1%3a3.3.1-1.1_amd64.deb ...
  Unpacking libpci-dev (1:3.3.1-1.1) ...
  Selecting previously unselected package libsnmp-dev.
  Preparing to unpack .../14-libsnmp-dev_5.7.3+dfsg-1.5+b1_amd64.deb ...
  Unpacking libsnmp-dev (5.7.3+dfsg-1.5+b1) ...
  Selecting previously unselected package help2man.
  Preparing to unpack .../15-help2man_1.47.4_amd64.deb ...
  Unpacking help2man (1.47.4) ...
  Setting up mysql-common (5.8+1.0.0) ...
  update-alternatives: using /etc/mysql/my.cnf.fallback to provide /etc/mysql/my.cnf (my.cnf) in auto mode
  Processing triggers for libc-bin (2.24-5) ...
  Setting up help2man (1.47.4) ...
  Setting up libsensors4:amd64 (1:3.4.0-3) ...
  Processing triggers for man-db (2.7.5-1) ...
  Setting up libmysqlclient20:amd64 (5.7.15-1) ...
  Setting up libpci3:amd64 (1:3.3.1-1.1) ...
  Setting up libudev-dev:amd64 (231-9) ...
  Setting up libwrap0:amd64 (7.6.q-25) ...
  Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) ...
  Setting up libsnmp-base (5.7.3+dfsg-1.5) ...
  Setting up libsnmp30:amd64 (5.7.3+dfsg-1.5+b1) ...
  Setting up libmysqlclient-dev (5.7.15-1) ...
  Setting up libwrap0-dev:amd64 (7.6.q-25) ...
  Setting up libssl-dev:amd64 (1.0.2j-1) ...
  Setting up libsensors4-dev (1:3.4.0-3) ...
  Setting up libpci-dev (1:3.3.1-1.1) ...
  Setting up libsnmp-dev (5.7.3+dfsg-1.5+b1) ...
  Setting up cacti-spine-build-deps (0.8.8h-1) ...
  Processing triggers for libc-bin (2.24-5) ...
  
  **************************************************************************************
  ** Environment                                                                      **
  **************************************************************************************
  
  PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=988541d05689
  TERM=xterm
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  PWD=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h
  OLDPWD=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=[email-masked]
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  GPG_KEY=1E953E27D4311E58
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  **************************************************************************************
  ** Building cacti-spine 0.8.8h-1 on amd64                                           **
  **************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package cacti-spine
  dpkg-buildpackage: info: source version 0.8.8h-1
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Paul Gevers <[email-masked]>
   dpkg-source --before-build cacti-spine-0.8.8h
  dpkg-buildpackage: info: host architecture amd64
  dpkg-source: info: using options from cacti-spine-0.8.8h/debian/source/options: --extend-diff-ignore=(^|/)(config\.guess|config\.sub|aclocal\.m4|configure|ltmain\.sh|Makefile\.in)$
   fakeroot debian/rules clean
  dh clean --with autoreconf
     dh_testdir
     dh_auto_clean
     dh_autoreconf_clean
     dh_clean
   debian/rules build
  dh build --with autoreconf
     dh_testdir
     dh_update_autotools_config
     dh_autoreconf
  libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, 'config'.
  libtoolize: copying file 'config/ltmain.sh'
  libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
  libtoolize: copying file 'm4/libtool.m4'
  libtoolize: copying file 'm4/ltoptions.m4'
  libtoolize: copying file 'm4/ltsugar.m4'
  libtoolize: copying file 'm4/ltversion.m4'
  libtoolize: copying file 'm4/lt~obsolete.m4'
  libtoolize: Consider adding '-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
  configure.ac:12: warning: AM_INIT_AUTOMAKE: two- and three-arguments forms are deprecated.  For more info, see:
  configure.ac:12: http://www.gnu.org/software/automake/manual/automake.html#Modernize-AM_005fINIT_005fAUTOMAKE-invocation
  configure.ac:69: installing 'config/compile'
  configure.ac:12: installing 'config/missing'
  Makefile.am: installing 'config/depcomp'
     debian/rules override_dh_auto_configure
  make[1]: Entering directory '/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h'
  ./configure --host=x86_64-linux-gnu \
                         --build=x86_64-linux-gnu \
                         --prefix=/usr \
                         --bindir=/usr/sbin \
  	       CFLAGS="-g -O2 -fdebug-prefix-map=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h=. -fstack-protector-strong -Wformat -Werror=format-security" CPPFLAGS="-Wdate-time -D_FORTIFY_SOURCE=2" CXXFLAGS="-g -O2 -fdebug-prefix-map=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h=. -fstack-protector-strong -Wformat -Werror=format-security" FCFLAGS="-g -O2 -fdebug-prefix-map=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h=. -fstack-protector-strong" FFLAGS="-g -O2 -fdebug-prefix-map=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h=. -fstack-protector-strong" GCJFLAGS="-g -O2 -fdebug-prefix-map=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h=. -fstack-protector-strong" LDFLAGS="-Wl,-z,relro -Wl,--as-needed" OBJCFLAGS="-g -O2 -fdebug-prefix-map=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h=. -fstack-protector-strong -Wformat -Werror=format-security" OBJCXXFLAGS="-g -O2 -fdebug-prefix-map=/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h=. -fstack-protector-strong -Wformat -Werror=format-security" 
  checking build system type... x86_64-pc-linux-gnu
  checking host system type... x86_64-pc-linux-gnu
  checking for a BSD-compatible install... /usr/bin/install -c
  checking whether build environment is sane... yes
  checking for a thread-safe mkdir -p... /bin/mkdir -p
  checking for gawk... no
  checking for mawk... mawk
  checking whether make sets $(MAKE)... yes
  checking whether make supports nested variables... yes
  checking for gawk... (cached) mawk
  checking for x86_64-linux-gnu-gcc... x86_64-linux-gnu-gcc
  checking whether the C compiler works... yes
  checking for C compiler default output file name... a.out
  checking for suffix of executables... 
  checking whether we are cross compiling... no
  checking for suffix of object files... o
  checking whether we are using the GNU C compiler... yes
  checking whether x86_64-linux-gnu-gcc accepts -g... yes
  checking for x86_64-linux-gnu-gcc option to accept ISO C89... none needed
  checking whether x86_64-linux-gnu-gcc understands -c and -o together... yes
  checking for style of include used by make... GNU
  checking dependency style of x86_64-linux-gnu-gcc... gcc3
  checking how to run the C preprocessor... x86_64-linux-gnu-gcc -E
  checking whether ln -s works... yes
  checking how to print strings... printf
  checking for a sed that does not truncate output... /bin/sed
  checking for grep that handles long lines and -e... /bin/grep
  checking for egrep... /bin/grep -E
  checking for fgrep... /bin/grep -F
  checking for ld used by x86_64-linux-gnu-gcc... /usr/bin/ld
  checking if the linker (/usr/bin/ld) is GNU ld... yes
  checking for BSD- or MS-compatible name lister (nm)... /usr/bin/x86_64-linux-gnu-nm -B
  checking the name lister (/usr/bin/x86_64-linux-gnu-nm -B) interface... BSD nm
  checking the maximum length of command line arguments... 1572864
  checking how to convert x86_64-pc-linux-gnu file names to x86_64-pc-linux-gnu format... func_convert_file_noop
  checking how to convert x86_64-pc-linux-gnu file names to toolchain format... func_convert_file_noop
  checking for /usr/bin/ld option to reload object files... -r
  checking for x86_64-linux-gnu-objdump... x86_64-linux-gnu-objdump
  checking how to recognize dependent libraries... pass_all
  checking for x86_64-linux-gnu-dlltool... no
  checking for dlltool... no
  checking how to associate runtime and link libraries... printf %s\n
  checking for x86_64-linux-gnu-ar... x86_64-linux-gnu-ar
  checking for archiver @FILE support... @
  checking for x86_64-linux-gnu-strip... x86_64-linux-gnu-strip
  checking for x86_64-linux-gnu-ranlib... x86_64-linux-gnu-ranlib
  checking command to parse /usr/bin/x86_64-linux-gnu-nm -B output from x86_64-linux-gnu-gcc object... ok
  checking for sysroot... no
  checking for a working dd... /bin/dd
  checking how to truncate binary pipes... /bin/dd bs=4096 count=1
  checking for x86_64-linux-gnu-mt... no
  checking for mt... no
  checking if : is a manifest tool... no
  checking for ANSI C header files... yes
  checking for sys/types.h... yes
  checking for sys/stat.h... yes
  checking for stdlib.h... yes
  checking for string.h... yes
  checking for memory.h... yes
  checking for strings.h... yes
  checking for inttypes.h... yes
  checking for stdint.h... yes
  checking for unistd.h... yes
  checking for dlfcn.h... yes
  checking for objdir... .libs
  checking if x86_64-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
  checking for x86_64-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
  checking if x86_64-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
  checking if x86_64-linux-gnu-gcc static flag -static works... yes
  checking if x86_64-linux-gnu-gcc supports -c -o file.o... yes
  checking if x86_64-linux-gnu-gcc supports -c -o file.o... (cached) yes
  checking whether the x86_64-linux-gnu-gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
  checking whether -lc should be explicitly linked in... no
  checking dynamic linker characteristics... GNU/Linux ld.so
  checking how to hardcode library paths into programs... immediate
  checking whether stripping libraries is possible... yes
  checking if libtool supports shared libraries... yes
  checking whether to build shared libraries... yes
  checking whether to build static libraries... yes
  checking whether to enable -Wall... no
  checking for help2man... /usr/bin/help2man
  checking for help2man... /usr/bin/help2man
  checking for threadsafe gethostbyname()... no
  checking for gethostbyname_r in -lnls... no
  checking for socket in -lsocket... no
  checking for floor in -lm... yes
  checking for pthread_exit in -lpthread... yes
  checking for deflate in -lz... yes
  checking for kstat_close in -lkstat... no
  checking for CRYPTO_realloc in -lcrypto... yes
  checking for ANSI C header files... (cached) yes
  checking sys/socket.h usability... yes
  checking sys/socket.h presence... yes
  checking for sys/socket.h... yes
  checking sys/select.h usability... yes
  checking sys/select.h presence... yes
  checking for sys/select.h... yes
  checking sys/wait.h usability... yes
  checking sys/wait.h presence... yes
  checking for sys/wait.h... yes
  checking sys/time.h usability... yes
  checking sys/time.h presence... yes
  checking for sys/time.h... yes
  checking assert.h usability... yes
  checking assert.h presence... yes
  checking for assert.h... yes
  checking ctype.h usability... yes
  checking ctype.h presence... yes
  checking for ctype.h... yes
  checking errno.h usability... yes
  checking errno.h presence... yes
  checking for errno.h... yes
  checking signal.h usability... yes
  checking signal.h presence... yes
  checking for signal.h... yes
  checking math.h usability... yes
  checking math.h presence... yes
  checking for math.h... yes
  checking malloc.h usability... yes
  checking malloc.h presence... yes
  checking for malloc.h... yes
  checking netdb.h usability... yes
  checking netdb.h presence... yes
  checking for netdb.h... yes
  checking for signal.h... (cached) yes
  checking stdarg.h usability... yes
  checking stdarg.h presence... yes
  checking for stdarg.h... yes
  checking stdio.h usability... yes
  checking stdio.h presence... yes
  checking for stdio.h... yes
  checking syslog.h usability... yes
  checking syslog.h presence... yes
  checking for syslog.h... yes
  checking for netinet/in_systm.h... yes
  checking for netinet/in.h... yes
  checking for netinet/ip.h... yes
  checking for netinet/ip_icmp.h... yes
  checking for unsigned long long... yes
  checking for long long... yes
  checking for an ANSI C-conforming const... yes
  checking for size_t... yes
  checking whether time.h and sys/time.h may both be included... yes
  checking whether struct tm is in sys/time.h or time.h... time.h
  checking return type of signal handlers... void
  checking for malloc... yes
  checking for calloc... yes
  checking for gettimeofday... yes
  checking for strerror... yes
  checking for strtoll... yes
  checking priv.h usability... no
  checking priv.h presence... no
  checking for priv.h... no
  checking whether we are using Solaris privileges... no
  checking sys/capability.h usability... no
  checking sys/capability.h presence... no
  checking for sys/capability.h... no
  checking whether we are using Linux Capabilities... no
  checking for mysql_init in -lmysqlclient_r... no
  configure: error: MySQL libraries not found
  debian/rules:23: recipe for target 'override_dh_auto_configure' failed
  make[1]: *** [override_dh_auto_configure] Error 1
  make[1]: Leaving directory '/home/lamby/temp/cdt.20161019163212.J91Hw9gpQ6.db.cacti-spine/cacti-spine-0.8.8h'
  debian/rules:4: recipe for target 'build' failed
  make: *** [build] Error 2

  […]

The full build log is attached.

Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      [email-masked] / chris-lamb.co.uk
       `-

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 21 Oct 2016 10:27:17 +0000

Your message dated Fri, 21 Oct 2016 10:23:13 +0000
with message-id <[email-masked]>
and subject line Bug#841312: fixed in cacti-spine 0.8.8h-2
has caused the Debian Bug report #841312,
regarding cacti-spine: FTBFS: configure: error: MySQL libraries not found
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
841312: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=841312
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti-spine: FTBFS: configure: error: MySQL libraries not found
From: Chris Lamb <[email-masked]>
To: [email-masked]
Date: Wed, 19 Oct 2016 15:34:11 +0100

Source: cacti-spine
Version: 0.8.8h-1
Severity: serious

Dear Maintainer,

  […]

  

  […]

Regards,

Subject: Bug#841312: fixed in cacti-spine 0.8.8h-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Fri, 21 Oct 2016 10:23:13 +0000

Source: cacti-spine
Source-Version: 0.8.8h-2

We believe that the bug you reported is fixed in the latest version of
cacti-spine, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti-spine package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Fri, 21 Oct 2016 09:31:26 +0200
Source: cacti-spine
Binary: cacti-spine
Architecture: source
Version: 0.8.8h-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti-spine - Multi-Threading poller for cacti
Closes: 825076 834057 841312
Changes:
 cacti-spine (0.8.8h-2) unstable; urgency=medium
 .
   * Link against libmysqlclient instead of libmysqlclient_r (Closes:
     #825076, #841312)
   * Also use upstream LDFLAGS to prevent FTBFS on kfreebsd (Closes:
     #834057)
   * Add fix_typos.patch to fix a typo found by Lintian
   * Raise compat level to 10
   * Build depend on default-libmysqlclient-dev iso libmysqlclient-dev
   * Add lintian-overrides for no-debconf-templates as we use cactis
     templates
Checksums-Sha1:
 de234f84542dc5b10cff2b2530c27ae3556e10de 1686 cacti-spine_0.8.8h-2.dsc
 3f3b5738dbcffcc4ab75c8fba7cb19041a208cc8 15668 cacti-spine_0.8.8h-2.debian.tar.xz
Checksums-Sha256:
 b13bdd5a6435db1d349376ace7f1f9b16126bce826e5ff05937744c3e3f8395e 1686 cacti-spine_0.8.8h-2.dsc
 18b941fcc58b1bb3e00b54206566d2248a7ce3b5d4bfb32bb1f5240d0490e839 15668 cacti-spine_0.8.8h-2.debian.tar.xz
Files:
 ce8319d400bba4c249f92e8f11372491 1686 web extra cacti-spine_0.8.8h-2.dsc
 5b9405f8cc466019771dc88a0f5bca86 15668 web extra cacti-spine_0.8.8h-2.debian.tar.xz