Subject: [Pkg-cacti-maint] Bug#1058866: cacti: Cacti package does not include spine.conf.sample

From: Piotr Górski <[email-masked]>
Date: Sun, 17 Dec 2023 09:15:57 +0100

Package: cacti
Version: 1.2.24+ds1-1+deb12u1
Severity: normal

Dear Maintainer,

Cacti package does not include file spine.conf.sample needed during installation of cacti-spine:

# apt install cacti-spine
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  libgnutls-dane0 libunbound8
Aby je usunąć należy użyć "apt autoremove".
Zostaną zainstalowane następujące NOWE pakiety:
  cacti-spine
0 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 0 B/71,6 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 199 kB miejsca na dysku.
Wybieranie wcześniej niewybranego pakietu cacti-spine.
(Odczytywanie bazy danych ... 166740 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../cacti-spine_1.2.24-1_amd64.deb ...
Rozpakowywanie pakietu cacti-spine (1.2.24-1) ...
Konfigurowanie pakietu cacti-spine (1.2.24-1) ...
Error: The new file /usr/share/cacti/conf_templates/spine.conf.sample does not exist!
dpkg: błąd przetwarzania pakietu cacti-spine (--configure):
 podproces zainstalowany pakiet cacti-spine skrypt post-installation zwrócił kod błędu 1
Przetwarzanie wyzwalaczy pakietu man-db (2.11.2-2)...
Wystąpiły błędy podczas przetwarzania:
 cacti-spine
E: Sub-process /usr/bin/dpkg returned an error code (1)

-- System Information:
Debian Release: 12.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable'), (100, 'bookworm-fasttrack'), (100, 'bookworm-backports-staging')
Architecture: amd64 (x86_64)

Kernel: Linux 6.1.0-13-amd64 (SMP w/8 CPU threads; PREEMPT)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_FIRMWARE_WORKAROUND, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=pl_PL.UTF-8, LC_CTYPE=pl_PL.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cacti depends on:
ii  dbconfig-common                     2.0.24
ii  dbconfig-no-thanks                  2.0.24
ii  debconf [debconf-2.0]               1.5.82
ii  fonts-dejavu-core                   2.37-6
ii  fonts-dejavu-extra                  2.37-6
ii  fonts-fork-awesome                  1.2.0+ds1-1
ii  javascript-common                   11+nmu1
ii  libapache2-mod-php8.2 [php-json]    8.2.7-1~deb12u1
ii  libjs-chart.js                      3.9.1+~0.2.1-2
ii  libjs-jquery                        3.6.1+dfsg+~3.5.14-1
ii  libjs-jquery-colorpicker            1.2.20-4
ii  libjs-jquery-cookie                 12-4
ii  libjs-jquery-hotkeys                0~20130707+git2d51e3a9+dfsg-2.1
ii  libjs-jquery-jstree                 3.3.12+dfsg1-2
ii  libjs-jquery-metadata               12-4
ii  libjs-jquery-tablesorter            1:2.31.3+dfsg1-3
ii  libjs-jquery-timepicker             1.6.3-4
ii  libjs-jquery-ui                     1.13.2+dfsg-1
ii  libjs-jquery-ui-theme-smoothness    1.12.1+dfsg-1.1
ii  libjs-jquery-ui-theme-south-street  1.12.1+dfsg-1.1
ii  libjs-jquery-ui-theme-ui-darkness   1.12.1+dfsg-1.1
ii  libjs-jquery-ui-touch-punch         0.0~git20141218.2.4bc0091+dfsg1-4.1
ii  libphp-phpmailer                    6.6.3-1
ii  node-d3                             5.16.0-10
ii  node-ua-parser-js                   0.8.1+ds+~0.7.36-3
ii  perl                                5.36.0-7+deb12u1
ii  php                                 2:8.2+93
pn  php-cli                             <none>
ii  php-gd                              2:8.2+93
ii  php-gmp                             2:8.2+93
ii  php-ldap                            2:8.2+93
ii  php-mbstring                        2:8.2+93
ii  php-mysql                           2:8.2+93
ii  php-phpmyadmin-motranslator         5.3.0-1
ii  php-phpseclib                       2.0.42-1
ii  php-snmp                            2:8.2+93
ii  php-twig                            3.5.1-1
ii  php-xml                             2:8.2+93
ii  php8.2 [php]                        8.2.7-1~deb12u1
ii  php8.2-cli [php-json]               8.2.7-1~deb12u1
ii  php8.2-gd [php-gd]                  8.2.7-1~deb12u1
ii  php8.2-gmp [php-gmp]                8.2.7-1~deb12u1
ii  php8.2-ldap [php-ldap]              8.2.7-1~deb12u1
ii  php8.2-mbstring [php-mbstring]      8.2.7-1~deb12u1
ii  php8.2-snmp [php-snmp]              8.2.7-1~deb12u1
ii  php8.2-xml [php-xml]                8.2.7-1~deb12u1
ii  rrdtool                             1.7.2-4+b8
ii  snmp                                5.9.3+dfsg-2
ii  ucf                                 3.0043+nmu1

Versions of packages cacti recommends:
ii  apache2 [httpd]                                2.4.57-2
ii  iputils-ping                                   3:20221126-1
ii  logrotate                                      3.21.0-1
ii  mysql-community-server [virtual-mysql-server]  8.0.35-1debian12

Versions of packages cacti suggests:
pn  cacti-spine  <none>
pn  moreutils    <none>
ii  snmpd        5.9.3+dfsg-2

-- debconf information:
* cacti/webserver: apache2

---

From: Paul Gevers <[email-masked]>
Date: Sun, 17 Dec 2023 10:00:51 +0100

Control: tags -1 moreinfo

Hi Piotr,

Thanks for reporting issues that you encounter.

> Cacti package does not include file spine.conf.sample needed during installation of cacti-spine:

I confirmed it doesn't contain the file, see 
https://packages.debian.org/bookworm/amd64/cacti-spine/filelist

> E: Sub-process /usr/bin/dpkg returned an error code (1)

Interestingly our testing infrastructure doesn't show the problem: 
https://piuparts.debian.org/bookworm/pass/cacti-spine_1.2.24-1.log

Do you know of any particularities of your system that may be relevant here?

Paul

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Sun, 17 Dec 2023 09:03:04 +0000

Processing control commands:

> tags -1 moreinfo
Bug #1058866 [cacti] cacti: Cacti package does not include spine.conf.sample
Added tag(s) moreinfo.

-- 
1058866: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1058866
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Paul Gevers <[email-masked]>
Date: Sun, 17 Dec 2023 10:08:05 +0100

Control: tags -1 - moreinfo
Control: tags -1 confirmed

> Do you know of any particularities of your system that may be relevant 

OK, that was easier to find that I expected. postinst uses this file 
(removed in 2013) when there is no /etc/dbconfig-common/cacti.conf file. 
I guess that condition is very rare as nobody has reported the issue in 
10 years. Do you happen to know *why* you don't have that file, to 
understand the use case I need to support?

Paul

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Sun, 17 Dec 2023 09:15:03 +0000

Processing control commands:

> tags -1 - moreinfo
Removed tag(s) moreinfo.
> tags -1 confirmed
Added tag(s) confirmed.

---

From: Paul Gevers <[email-masked]>
Date: Wed, 29 Jan 2025 20:31:55 +0100

Control: reassign -1 cacti-spine
Control: fixed -1 1.2.27-1
Control: close -1

> understand the use case I need to support?
I have removed the code in cacti-spine a while back:

cacti-spine (1.2.27-1) unstable; urgency=medium

   * New upstream version 1.2.27
   * d/control: update Maintainer to tracker address
   * postinst: drop obsolete code for spine.conf.sample

  -- Paul Gevers <[email-masked]>  Thu, 29 Aug 2024 18:02:39 +0200

Paul

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Wed, 29 Jan 2025 19:33:03 +0000

Processing control commands:

> reassign -1 cacti-spine
Bug #1058866 [cacti] cacti: Cacti package does not include spine.conf.sample
Bug reassigned from package 'cacti' to 'cacti-spine'.
No longer marked as found in versions cacti/1.2.24+ds1-1+deb12u1.
Ignoring request to alter fixed versions of bug #1058866 to the same values previously set
> fixed -1 1.2.27-1
Bug #1058866 [cacti-spine] cacti: Cacti package does not include spine.conf.sample
Marked as fixed in versions cacti-spine/1.2.27-1.
> close -1
Bug #1058866 [cacti-spine] cacti: Cacti package does not include spine.conf.sample
Marked Bug as done