Subject: [Pkg-cacti-maint] Bug#934898: cacti: php configuration via apache config file is not enabled with php7.3 in buster and newer.

From: Ronny Aasen <[email-masked]>
Date: Fri, 16 Aug 2019 11:22:00 +0200

Package: cacti
Version: 1.2.2+ds1-2
Severity: normal

Dear Maintainer,

After installing cacti 1.2.2+ds1-2 on a fresh buster installation, I had 
problems with some third party plugins. And I noticed that php values 
set in the Apache configuration file was not enabled.
The reason being that the module name for php7.3 have changed since 
php5.  so the snippet inside <IfModule mod_php.> in 
/etc/apache2/conf-available/cacti.conf is never considered.

the fix was simple, replace with <IfModule mod_php7.c>

Kind regards
Ronny Aasen

-- System Information:
Debian Release: 10.0
   APT prefers stable-updates
   APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cacti depends on:
ii  dbconfig-common                           2.0.11
ii  dbconfig-mysql                            2.0.11
ii  debconf [debconf-2.0]                     1.5.71
ii  fonts-dejavu-core                         2.37-1
ii  fonts-dejavu-extra                        2.37-1
ii  fonts-fork-awesome                        1.1.5+ds1-2
ii  javascript-common                         11
ii  libapache2-mod-php                        2:7.3+69
ii  libapache2-mod-php7.3 [libapache2-mod-ph  7.3.4-2
ii  libjs-c3                                  0.4.11+dfsg-2
ii  libjs-chart.js                            2.7.3+dfsg-5
ii  libjs-d3                                  3.5.17-2
ii  libjs-jquery                              3.3.1~dfsg-3
ii  libjs-jquery-colorpicker                  1.2.17-1
ii  libjs-jquery-cookie                       12-1.1
ii  libjs-jquery-hotkeys                      0~20130707+git2d51e3a9+dfsg-2
ii  libjs-jquery-jstree                       3.3.7+dfsg1-1
ii  libjs-jquery-metadata                     12-1.1
ii  libjs-jquery-tablesorter                  1:2.31.1+dfsg1-1
ii  libjs-jquery-timepicker                   1.2-1
ii  libjs-jquery-ui                           1.12.1+dfsg-5
ii  libjs-jquery-ui-theme-smoothness          1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-south-street        1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-ui-darkness         1.12.1+dfsg-1
ii  libjs-jquery-ui-touch-punch 
0.0~git20141218.2.4bc0091+dfsg1-2
ii  libphp-phpmailer                          6.0.6-0.1
ii  perl                                      5.28.1-6
ii  php-gd                                    2:7.3+69
ii  php-ldap                                  2:7.3+69
ii  php-mbstring                              2:7.3+69
ii  php-mysql                                 2:7.3+69
ii  php-php-gettext                           1.0.12-0.1
ii  php-phpseclib                             2.0.14-1
ii  php-snmp                                  2:7.3+69
ii  php-twig                                  2.6.2-2
ii  php-xml                                   2:7.3+69
ii  php7.3-cli [php-cli]                      7.3.4-2
ii  php7.3-gd [php-gd]                        7.3.4-2
ii  php7.3-json [php-json]                    7.3.4-2
ii  php7.3-ldap [php-ldap]                    7.3.4-2
ii  php7.3-mbstring [php-mbstring]            7.3.4-2
ii  php7.3-snmp [php-snmp]                    7.3.4-2
ii  php7.3-xml [php-xml]                      7.3.4-2
ii  rrdtool                                   1.7.1-2
ii  snmp                                      5.7.3+dfsg-5
ii  ucf                                       3.0038+nmu1

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.38-3
ii  iputils-ping                                3:20180629-2
ii  logrotate                                   3.14.0-4
ii  mariadb-server-10.3 [virtual-mysql-server]  1:10.3.15-1
ii  php-gmp                                     2:7.3+69
ii  php7.3-gmp [php-gmp]                        7.3.4-2

Versions of packages cacti suggests:
pn  cacti-spine  <none>
pn  moreutils    <none>
pn  snmpd        <none>

-- debconf information excluded

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Thu, 19 Sep 2019 12:06:06 +0000

Your message dated Thu, 19 Sep 2019 12:04:08 +0000
with message-id <[email-masked]>
and subject line Bug#934898: fixed in cacti 1.2.6+ds1-2
has caused the Debian Bug report #934898,
regarding cacti: php configuration via apache config file is not enabled with php7.3 in buster and newer.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
934898: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=934898
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: php configuration via apache config file is not enabled with php7.3 in buster and newer.
From: Ronny Aasen <[email-masked]>
To: [email-masked]
Date: Fri, 16 Aug 2019 11:22:00 +0200

Package: cacti
Version: 1.2.2+ds1-2
Severity: normal

Dear Maintainer,

Kind regards
Ronny Aasen

-- System Information:
Debian Release: 10.0

Subject: Bug#934898: fixed in cacti 1.2.6+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Thu, 19 Sep 2019 12:04:08 +0000

Source: cacti
Source-Version: 1.2.6+ds1-2

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Tue, 17 Sep 2019 20:31:04 +0200
Source: cacti
Architecture: source
Version: 1.2.6+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Closes: 934898
Changes:
 cacti (1.2.6+ds1-2) unstable; urgency=medium
 .
   [ Paul Gevers]
   * Fix autopkgtest regression with 0001-Resolving-Issue-2899.patch from
     upstream
   * Apache skipped the php section in apache.conf since PHP 7 (Closes:
     #934898)
   * Translations were broken since 1.2.4+ds1-1. Import upstream solution
     enabling the use of php-phpmyadmin-motranslator.
 .
   [ Rafael David Tinoco ]
   * Prepare sql commands for MySQL 8 (See: #933683)
Checksums-Sha1:
 45a7ca87931f89fd779dc1915819e62c44e4ab5e 2106 cacti_1.2.6+ds1-2.dsc
 57bc5939cd475c34c25a32e0775992bbed9b9653 58044 cacti_1.2.6+ds1-2.debian.tar.xz
Checksums-Sha256:
 4cced6565c60293ef6e6a8efafdef9802f2f6803506c7098abb698c45043dbfa 2106 cacti_1.2.6+ds1-2.dsc
 0011c0afecee14506c01e222a103f13ab7828d0ce63f9ecbe19dacf20f1f8e10 58044 cacti_1.2.6+ds1-2.debian.tar.xz
Files:
 7412178d6359328d54b62d5ed196517f 2106 web optional cacti_1.2.6+ds1-2.dsc
 44ef4db2837e89baab772bd1eb3e64a2 58044 web optional cacti_1.2.6+ds1-2.debian.tar.xz