Subject: [Pkg-cacti-maint] Bug#930254: cacti 1.2.2 fails to read snmp gauges

From: Norman Rasmussen <[email-masked]>
Date: Sun, 09 Jun 2019 04:01:57 -0700

Package: cacti
Version: 1.2.2+ds1-2
Severity: normal

Cacti 1.2.2 has a bug where snmp gauges read as zero -
https://github.com/Cacti/cacti/issues/2474

The bug was fixed for version 1.2.3 (and 1.2.4 was released just 2 days
ago too).

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (700, 'testing'), (650, 'stable')
Architecture: i386 (x86_64)
Foreign Architectures: amd64

Kernel: Linux 4.14.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8), LANGUAGE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages cacti depends on:
ii  dbconfig-common                           2.0.9
ii  dbconfig-mysql                            2.0.9
ii  debconf [debconf-2.0]                     1.5.69
ii  fonts-dejavu-core                         2.37-1
ii  fonts-dejavu-extra                        2.37-1
ii  fonts-fork-awesome                        1.1.5+ds1-2
ii  javascript-common                         11
ii  libapache2-mod-php                        2:7.3+69
ii  libapache2-mod-php7.3 [libapache2-mod-ph  7.3.4-2
ii  libjs-c3                                  0.4.11+dfsg-2
ii  libjs-chart.js                            2.7.3+dfsg-3
ii  libjs-d3                                  3.5.17-2
ii  libjs-jquery                              3.3.1~dfsg-3
ii  libjs-jquery-colorpicker                  1.2.17-1
ii  libjs-jquery-cookie                       12-1.1
ii  libjs-jquery-hotkeys                      0~20130707+git2d51e3a9+dfsg-2
ii  libjs-jquery-jstree                       3.3.7+dfsg1-1
ii  libjs-jquery-metadata                     12-1.1
ii  libjs-jquery-tablesorter                  1:2.31.1+dfsg1-1
ii  libjs-jquery-timepicker                   1.2-1
ii  libjs-jquery-ui                           1.12.1+dfsg-5
ii  libjs-jquery-ui-theme-smoothness          1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-south-street        1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-ui-darkness         1.12.1+dfsg-1
ii  libjs-jquery-ui-touch-punch               0.0~git20141218.2.4bc0091+dfsg1-2
ii  libphp-phpmailer                          6.0.6-0.1
ii  perl                                      5.28.1-6
ii  php                                       2:7.3+69
ii  php-gd                                    2:7.3+69
ii  php-ldap                                  2:7.3+69
ii  php-mbstring                              2:7.3+69
ii  php-mysql                                 2:7.3+69
ii  php-php-gettext                           1.0.12-0.1
ii  php-phpseclib                             2.0.13-1
ii  php-snmp                                  2:7.3+69
ii  php-twig                                  2.6.0-1
ii  php-xml                                   2:7.3+69
ii  php7.3 [php]                              7.3.0-2
ii  php7.3-cli [php-cli]                      7.3.4-2
ii  php7.3-gd [php-gd]                        7.3.4-2
ii  php7.3-json [php-json]                    7.3.4-2
ii  php7.3-ldap [php-ldap]                    7.3.4-2
ii  php7.3-mbstring [php-mbstring]            7.3.4-2
ii  php7.3-snmp [php-snmp]                    7.3.4-2
ii  php7.3-xml [php-xml]                      7.3.4-2
ii  rrdtool                                   1.6.0-1+b4
ii  snmp                                      5.7.3+dfsg-4+b2
ii  ucf                                       3.0036

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.38-3
ii  default-mysql-server                        1.0.3
ii  iputils-ping                                3:20161105-1
ii  logrotate                                   3.11.0-0.1
ii  mariadb-server-10.1 [virtual-mysql-server]  10.1.37-0+deb9u1
ii  php-gmp                                     2:7.3+69
ii  php7.3-gmp [php-gmp]                        7.3.4-2

Versions of packages cacti suggests:
ii  cacti-spine  1.2.2-1
ii  moreutils    0.60-1
ii  snmpd        5.7.3+dfsg-4+b2

-- debconf information excluded

-- debsums errors found:
debsums: changed file /usr/share/cacti/site/lib/snmp.php (from cacti package)
debsums: Error: symlink loop detected in path 'usr/share/cacti/site/plugins/index.php'. Please file a bug again cacti.

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 15 Jul 2019 12:51:08 +0000

Your message dated Mon, 15 Jul 2019 12:49:05 +0000
with message-id <[email-masked]>
and subject line Bug#930254: fixed in cacti 1.2.4+ds1-1
has caused the Debian Bug report #930254,
regarding cacti 1.2.2 fails to read snmp gauges
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
930254: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=930254
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti 1.2.2 fails to read snmp gauges
From: Norman Rasmussen <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sun, 09 Jun 2019 04:01:57 -0700

Package: cacti
Version: 1.2.2+ds1-2
Severity: normal

-- System Information:

-- debsums errors found:

Subject: Bug#930254: fixed in cacti 1.2.4+ds1-1
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 15 Jul 2019 12:49:05 +0000

Source: cacti
Source-Version: 1.2.4+ds1-1

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 14 Jul 2019 21:33:08 +0200
Source: cacti
Architecture: source
Version: 1.2.4+ds1-1
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Closes: 930252 930254 931702
Changes:
 cacti (1.2.4+ds1-1) unstable; urgency=medium
 .
   * New upstream release 1.2.4
     - Fixed upgrade script (Closes: #931702)
     - Fixed snmp gauges (Closes: #930254)
   * Depends i.s.o. Recommends on php-gmp (Closes: #930252)
   * Drop dependency on php-php-gettext as it is optional for cacti and it's
     going to be removed due to CVE-2016-6175
   * Refresh patches
   * Update d/debian.php.dist with changes in include/config.php
Checksums-Sha1:
 f04d26c2fa1e5295667c46c1c017cfef81479336 2106 cacti_1.2.4+ds1-1.dsc
 5bcf2410f398f22ea55696428dfdc9f033303e0c 12751572 cacti_1.2.4+ds1.orig-docs-source.tar.gz
 2dd0b758ec81e6bea540a32512a04a2b9f0cd55e 3855916 cacti_1.2.4+ds1.orig.tar.xz
 07caf3a9ae2b7a94ed799a729bb54df1db66727e 52824 cacti_1.2.4+ds1-1.debian.tar.xz
Checksums-Sha256:
 ae902602e58214172a74dd20ae141e899f9f8dc51532ad235e0c16535d95d8a3 2106 cacti_1.2.4+ds1-1.dsc
 5d94359ea0b15cfe8f96ddc9999394594563cb34de2bb500a54f7b27565b44b4 12751572 cacti_1.2.4+ds1.orig-docs-source.tar.gz
 e02bcb38ce10b5eebf9a88d4cc42e3a3274c6b710a0274866695b5c9723d3c6d 3855916 cacti_1.2.4+ds1.orig.tar.xz
 d75da23091d7d18219e3e2d5863681e46f185bfed793d1c5434f8530a7d6866f 52824 cacti_1.2.4+ds1-1.debian.tar.xz
Files:
 3aac4292bc06ee30aac4bc839539a648 2106 web optional cacti_1.2.4+ds1-1.dsc
 ebdf0461474378c083051b44ce15aa34 12751572 web optional cacti_1.2.4+ds1.orig-docs-source.tar.gz
 40f029c323a6c619f08abe1eb3da2a83 3855916 web optional cacti_1.2.4+ds1.orig.tar.xz
 c3a6b4fc3026253bbbe8029ebcfaa5f4 52824 web optional cacti_1.2.4+ds1-1.debian.tar.xz

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Tue, 30 Jul 2019 21:09:05 +0000

Your message dated Tue, 30 Jul 2019 21:05:29 +0000
with message-id <[email-masked]>
and subject line Bug#930254: fixed in cacti 1.2.2+ds1-2+deb10u1
has caused the Debian Bug report #930254,
regarding cacti 1.2.2 fails to read snmp gauges
to be marked as done.

Package: cacti
Version: 1.2.2+ds1-2
Severity: normal

-- System Information:

-- debsums errors found:

Subject: Bug#930254: fixed in cacti 1.2.2+ds1-2+deb10u1
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Tue, 30 Jul 2019 21:05:29 +0000

Source: cacti
Source-Version: 1.2.2+ds1-2+deb10u1

Format: 1.8
Date: Tue, 16 Jul 2019 21:40:32 +0200
Source: cacti
Architecture: source
Version: 1.2.2+ds1-2+deb10u1
Distribution: buster
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Closes: 930252 930254 931702
Changes:
 cacti (1.2.2+ds1-2+deb10u1) buster; urgency=medium
 .
   * Depends i.s.o. Recommends on php-gmp as this is now a requirement of
     the upstream code (Closes: #930252)
   * Fix reading of snmp gauges (0001-Resolving-issue-2474.patch) (Closes:
     #930254)
   * Fix upgrade from stretch (0001-Resolving-issue-2482.patch); the
     upgrade code attempted to drop a non-existing primary key (Closes:
     #931702)
Checksums-Sha1:
 b039288a904c37c17eda9aa6e80cbb4d584961a0 2138 cacti_1.2.2+ds1-2+deb10u1.dsc
 eaf26456366472a2b783a4c262498d873bcb4685 53992 cacti_1.2.2+ds1-2+deb10u1.debian.tar.xz
Checksums-Sha256:
 4cc5c1dc912b666fbd079d9aaf253cc46a292fba1ba7d8e65c1e54cbe83fd75d 2138 cacti_1.2.2+ds1-2+deb10u1.dsc
 deeef66fd08da653658b37862a2942a51e352c628cea69041d46acc6eaa7a459 53992 cacti_1.2.2+ds1-2+deb10u1.debian.tar.xz
Files:
 5af1dd73887cae535eb30e4ec6e71485 2138 web optional cacti_1.2.2+ds1-2+deb10u1.dsc
 48ee9c46a505a0e981f491a8a3c4a7e3 53992 web optional cacti_1.2.2+ds1-2+deb10u1.debian.tar.xz