Subject: [Pkg-cacti-maint] Bug#1022229: Failing tests with PHP 8.2

From: David Prévot <[email-masked]>
Date: Sat, 22 Oct 2022 12:48:17 +0200

Package: cacti
Version: 1.2.22+ds1-1
Severity: important
Control: block 1014460 by -1

Hi Paul,

There are some tests failure under PHP 8.2.

https://release.debian.org/britney/pseudo-excuses-experimental.html#php-defaults

A quick look shows some deprecation messages, but no activity upstream
on the related files.

Regards

David

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Sat, 22 Oct 2022 10:51:05 +0000

Processing control commands:

> block 1014460 by -1
Bug #1014460 [release.debian.org] transition: php8.2
1014460 was blocked by: 1022228 1022227
1014460 was not blocking any bugs.
Added blocking bug(s) of 1014460: 1022229

-- 
1014460: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1014460
1022229: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1022229
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Wed, 02 Nov 2022 21:21:10 +0000

Your message dated Wed, 02 Nov 2022 21:19:19 +0000
with message-id <[email-masked]>
and subject line Bug#1022229: fixed in cacti 1.2.22+ds1-2
has caused the Debian Bug report #1022229,
regarding [cacti] Failing tests with PHP 8.2
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: Failing tests with PHP 8.2
From: David Prévot <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 22 Oct 2022 12:48:17 +0200

Package: cacti
Version: 1.2.22+ds1-1
Severity: important

Hi Paul,

Regards

David

Subject: Bug#1022229: fixed in cacti 1.2.22+ds1-2
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Wed, 02 Nov 2022 21:19:19 +0000

Source: cacti
Source-Version: 1.2.22+ds1-2
Done: Paul Gevers <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Wed, 02 Nov 2022 21:24:38 +0100
Source: cacti
Architecture: source
Version: 1.2.22+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Closes: 1022229
Changes:
 cacti (1.2.22+ds1-2) unstable; urgency=medium
 .
   [ Debian Janitor ]
   * Remove constraints unnecessary since buster (oldstable)
   * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository-Browse.
   * Update standards version to 4.6.1, no changes needed.
   * Remove empty maintainer scripts: cacti (preinst)
 .
   [ Paul Gevers ]
   * Add 31bfd4b5c1d33af02911441111a430597b9f1021.patch to fix php8.2
     deprecation warnings (Closes: #1022229)
Checksums-Sha1:
 8d812cd0163d2ec02ca9dc94e639028673d6afbc 2236 cacti_1.2.22+ds1-2.dsc
 c4954bc9a62d25ec3cc3259ac07842e528112eb0 58916 cacti_1.2.22+ds1-2.debian.tar.xz
Checksums-Sha256:
 a22ee55fd20a7765bd03e4609e6eab3264e0596c731d5dc95f4c22b485a2b0e6 2236 cacti_1.2.22+ds1-2.dsc
 000fc4a7fb82840ebdb8b77a1692dd4e234a4e7695156bff795337878fbcb496 58916 cacti_1.2.22+ds1-2.debian.tar.xz
Files:
 73b8ea77b3c264c0c557961a82ba823c 2236 web optional cacti_1.2.22+ds1-2.dsc
 19606b2a5404471275b22c7d6b8ea21c 58916 web optional cacti_1.2.22+ds1-2.debian.tar.xz