Subject: [Pkg-cacti-maint] Bug#692362: /usr/share/cacti/site/scripts/ping.pl not working

From: Adam <[email-masked]>
Date: Mon, 05 Nov 2012 12:43:48 +0100

Package: cacti
Version: 0.8.7g-1+squeeze1
Severity: normal
Tags: patch

Script /usr/share/cacti/site/scripts/ping.pl is not working with iputils-ping version 3:20100418-3.
Script parses output from ping command but ping output has changed.

Patch bellow fixes that problem:

--- ping.pl.org 2012-11-05 11:52:35.000000000 +0100
+++ ping.pl     2012-11-05 11:52:49.000000000 +0100
@@ -4,7 +4,7 @@
 $host = $ARGV[0];
 $host =~ s/tcp:/$1/gis;
 
-open(PROCESS, "ping -c 1 $host | grep icmp_seq | grep time |");
+open(PROCESS, "ping -c 1 $host | grep icmp_req | grep time |");
 $ping = <PROCESS>;
 close(PROCESS);
 $ping =~ m/(.*time=)(.*) (ms|usec)/;

-- System Information:
Debian Release: 6.0.6
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'proposed-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=pl_PL.UTF-8, LC_CTYPE=pl_PL.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  apache2-mpm-prefork [h 2.2.16-6+squeeze8 Apache HTTP Server - traditional n
ii  dbconfig-common        1.8.46+squeeze.0  common framework for packaging dat
ii  debconf [debconf-2.0]  1.5.36.1          Debian configuration management sy
ii  libapache2-mod-php5    5.3.3-7+squeeze14 server-side, HTML-embedded scripti
ii  libphp-adodb           5.10-1            The ADOdb database abstraction lay
ii  lighttpd [httpd]       1.4.28-2+squeeze1 A fast webserver with minimal memo
ii  mysql-client-5.1 [virt 5.1.63-0+squeeze1 MySQL database client binaries
ii  php5                   5.3.3-7+squeeze14 server-side, HTML-embedded scripti
ii  php5-cli               5.3.3-7+squeeze14 command-line interpreter for the p
ii  php5-mysql             5.3.3-7+squeeze14 MySQL module for php5
ii  php5-snmp              5.3.3-7+squeeze14 SNMP module for php5
ii  rrdtool                1.4.3-1           time-series data storage and displ
ii  snmp                   5.4.3~dfsg-2      SNMP (Simple Network Management Pr
ii  ucf                    3.0025+nmu1       Update Configuration File: preserv

Versions of packages cacti recommends:
ii  iputils-ping           3:20100418-3      Tools to test the reachability of 
ii  logrotate              3.7.8-6           Log rotation utility
ii  mysql-server           5.1.63-0+squeeze1 MySQL database server (metapackage
ii  mysql-server-5.1 [mysq 5.1.63-0+squeeze1 MySQL database server binaries and

Versions of packages cacti suggests:
pn  php5-ldap                     <none>     (no description available)

-- Configuration Files:
/etc/cron.d/cacti changed [not included]

-- debconf information excluded

-- debsums errors found:
debsums: changed file /usr/share/cacti/site/scripts/ping.pl (from cacti package)

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 05 Nov 2012 19:51:07 +0000

Your message dated Mon, 05 Nov 2012 20:47:26 +0100
with message-id <[email-masked]>
and subject line Re: [Pkg-cacti-maint] Bug#692362: /usr/share/cacti/site/scripts/ping.pl not working
has caused the Debian Bug report #692362,
regarding /usr/share/cacti/site/scripts/ping.pl not working
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
692362: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=692362
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: /usr/share/cacti/site/scripts/ping.pl not working
From: Adam <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Mon, 05 Nov 2012 12:43:48 +0100

Package: cacti

 

-- System Information:
Debian Release: 6.0.6

-- Configuration Files:

-- debsums errors found:

Subject: Re: [Pkg-cacti-maint] Bug#692362: /usr/share/cacti/site/scripts/ping.pl not working
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 05 Nov 2012 20:47:26 +0100

fixed -1 0.8.7i-1
thanks

Thanks for reporting this issue. The issue was fixed in the 0.8.7h
version of Cacti. I don't think the severity of this bug warrants an
update in squeeze, so I am closing it with the proper information.

FYI, the cacti fix is:
open(PROCESS, "ping -c 1 $host | grep 'icmp_[s|r]eq' | grep time |");

Paul

On 05-11-12 12:43, Adam wrote:
> _______________________________________________
> Pkg-cacti-maint mailing list
> [email-masked]
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-cacti-maint
>