Subject: [Pkg-cacti-maint] Bug#653863: cacti: Syntax error in cacti/site/include/global.php

From: Gilles Mocellin <[email-masked]>
Date: Sat, 31 Dec 2011 18:36:13 +0100

Package: cacti
Version: 0.8.7i-1
Severity: grave
Tags: patch
Justification: renders package unusable

Dear Maintainer,
There is a syntax error in /usr/share/cacti/site/include/global.php, line 190 :
lacks a semicolon at end of line.

-- System Information:
Debian Release: 6.0
  APT prefers unstable
  APT policy: (600, 'unstable'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  apache2                                  2.2.21-5
ii  apache2-mpm-prefork [httpd]              2.2.21-5
ii  dbconfig-common                          1.8.47
ii  debconf [debconf-2.0]                    1.5.41
ii  libapache2-mod-php5                      5.3.8.0-1+b1
ii  libphp-adodb                             5.12-1
ii  mysql-client-5.1 [virtual-mysql-client]  5.1.58-1
ii  php5                                     5.3.8.0-1
ii  php5-cli                                 5.3.8.0-1+b1
ii  php5-mysql                               5.3.8.0-1+b1
ii  php5-snmp                                5.3.8.0-1+b1
ii  rrdtool                                  1.4.3-3.1+b3
ii  snmp                                     5.4.3~dfsg-2.4
ii  ucf                                      3.0025+nmu2

Versions of packages cacti recommends:
ii  iputils-ping                     3:20101006-1+b1
ii  logrotate                        3.8.1-1
ii  mysql-server                     5.1.58-1
ii  mysql-server-5.1 [mysql-server]  5.1.58-1

Versions of packages cacti suggests:
pn  php5-ldap  <none>

-- debconf information excluded

-- debsums errors found:
debsums: changed file /usr/share/cacti/site/include/global.php (from cacti package)

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 02 Jan 2012 10:05:29 +0000

Your message dated Mon, 02 Jan 2012 10:02:11 +0000
with message-id <[email-masked]>
and subject line Bug#653863: fixed in cacti 0.8.7i-2
has caused the Debian Bug report #653863,
regarding cacti: Syntax error in cacti/site/include/global.php
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
653863: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=653863
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: Syntax error in cacti/site/include/global.php
From: Gilles Mocellin <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 31 Dec 2011 18:36:13 +0100

Package: cacti
Version: 0.8.7i-1
Severity: grave
Tags: patch

Dear Maintainer,

-- System Information:
Debian Release: 6.0
  APT prefers unstable

-- debsums errors found:

Subject: Bug#653863: fixed in cacti 0.8.7i-2
From: Mahyuddin Susanto <[email-masked]>
To: [email-masked]
Date: Mon, 02 Jan 2012 10:02:11 +0000

Source: cacti
Source-Version: 0.8.7i-2

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive:

cacti_0.8.7i-2.debian.tar.gz
  to main/c/cacti/cacti_0.8.7i-2.debian.tar.gz
cacti_0.8.7i-2.dsc
  to main/c/cacti/cacti_0.8.7i-2.dsc
cacti_0.8.7i-2_all.deb
  to main/c/cacti/cacti_0.8.7i-2_all.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mahyuddin Susanto <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Mon, 02 Jan 2012 14:11:15 +0700
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.7i-2
Distribution: unstable
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Mahyuddin Susanto <[email-masked]>
Description: 
 cacti      - Frontend to rrdtool for monitoring systems and services
Closes: 653863
Changes: 
 cacti (0.8.7i-2) unstable; urgency=low
 .
   * Cherry-pick upstream patches
     - debian/patches/10_settings_checkbox.patch
   * debian/patches/05_no-adodb.patch: Updates, add semicolon at line 190.
     (Closes: #653863)
   * Updated last changelog to mention security bug.
Checksums-Sha1: 
 c014c66f890c1a923e2a4ecb8012dc296169128d 1907 cacti_0.8.7i-2.dsc
 643aeacc7ec02ea74a938a48f5ffa17834adc0d2 41511 cacti_0.8.7i-2.debian.tar.gz
 799ea4de0de471849418f0c7c5f2738a8adfb04c 2100862 cacti_0.8.7i-2_all.deb
Checksums-Sha256: 
 9f12ef6a763de2e8b1c570244c6d1a89896020b181bd64297b3b72e003c05396 1907 cacti_0.8.7i-2.dsc
 0463868777cdc37e5136b2ae39c5148932233512986238725a202b1b797a87b7 41511 cacti_0.8.7i-2.debian.tar.gz
 13ab013a76febd314cbf6e670c11692ce6dc462820b674f8baa3fb7a7b99c2b2 2100862 cacti_0.8.7i-2_all.deb
Files: 
 91f066d7e8b07443dcaa95096c548b80 1907 web extra cacti_0.8.7i-2.dsc
 6f09c8f695e00de47905e9452d52226f 41511 web extra cacti_0.8.7i-2.debian.tar.gz
 552d47d4b2d6632274f1abd6f6e4e34f 2100862 web extra cacti_0.8.7i-2_all.deb