Subject: [Pkg-cacti-maint] Bug#702690: cacti: Multilevel tree doesn't work with jstree in 0.8.8a+dfsg-3

From: Martin List-Petersen <[email-masked]>
Date: Wed, 04 Jan 2017 14:57:29 +0000

Package: cacti
Version: 0.8.8b+dfsg-8+deb8u6
Followup-For: Bug #702690

As above, this bug still exists in 0.8.8b+dfsg-8+deb8u6 on jessie 8.6.

javascript-common is installed correctly and enabled in apache2.

I have confirmed, that the files are accessible in the browser.

No plugins are installed in cacti. This is a vanilla clean install.

Firefox Debug reports:
ReferenceError: findObj is not defined[Learn More]  graph_view.php:109:4
	<anonymous> [redacted]cacti/graph_view.php:109:4

and:
TypeError: this.data.html_data.original_container_html.find(...).andSelf is
not a function[Learn More]  jquery.jstree.js:4010:4
	.__init
[redacted]cacti/include/js/jquery/jquery.jstree.js:4010:4
	$.fn.jstree/</<
[redacted]cacti/include/js/jquery/jquery.jstree.js:160:99
	.each [redacted]javascript/jquery/jquery.js:368:10
	$.fn.jstree/<
[redacted]cacti/include/js/jquery/jquery.jstree.js:160:5
	.each [redacted]javascript/jquery/jquery.js:368:10
	jQuery.prototype.each
[redacted]javascript/jquery/jquery.js:157:10
	$.fn.jstree
[redacted]cacti/include/js/jquery/jquery.jstree.js:123:4
	<anonymous> [redacted]cacti/graph_view.php:83:2
	resolve/</mightThrow
[redacted]javascript/jquery/jquery.js:3570:21
	resolve/</process<
[redacted]javascript/jquery/jquery.js:3638:12

/M

-- System Information:
Debian Release: 8.6
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu3+deb8u1
ii  debconf [debconf-2.0]                    1.5.56
ii  libapache2-mod-php5                      5.6.29+dfsg-0+deb8u1
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.53-0+deb8u1
ii  perl                                     5.20.2-3+deb8u6
ii  php5                                     5.6.29+dfsg-0+deb8u1
ii  php5-cli                                 5.6.29+dfsg-0+deb8u1
ii  php5-mysql                               5.6.29+dfsg-0+deb8u1
ii  php5-snmp                                5.6.29+dfsg-0+deb8u1
ii  rrdtool                                  1.4.8-1.2
ii  snmp                                     5.7.2.1+dfsg-1
ii  ucf                                      3.0030

Versions of packages cacti recommends:
ii  apache2 [httpd]      2.4.10-10+deb8u7
ii  iputils-ping         3:20121221-5+b2
ii  libjs-jquery         3.1.1-2
ii  libjs-jquery-cookie  10-1
ii  logrotate            3.8.7-1+b1
ii  mysql-server         5.5.53-0+deb8u1

Versions of packages cacti suggests:
pn  moreutils  <none>
pn  php5-ldap  <none>

-- debconf information:
  cacti/upgrade-error: abort
  cacti/remote/host:
  cacti/mysql/method: unix socket
  cacti/dbconfig-upgrade: true
* cacti/webserver: apache2
  cacti/database-type: mysql
  cacti/internal/reconfiguring: false
  cacti/install-error: abort
  cacti/remote/port:
  cacti/passwords-do-not-match:
  cacti/mysql/admin-user: root
  cacti/db/app-user: cacti
  cacti/internal/skip-preseed: false
  cacti/upgrade-backup: true
  cacti/db/dbname: cacti
  cacti/remote/newhost:
  cacti/dbconfig-remove:
  cacti/dbconfig-reinstall: false
  cacti/purge: false
  cacti/remove-error: abort
* cacti/dbconfig-install: true
  cacti/missing-db-package-error: abort

---

From: Paul Gevers <[email-masked]>
Date: Fri, 27 Jan 2017 21:55:09 +0100

Hi Martin,

> Versions of packages cacti recommends:

This version of jquery is NOT from stable. You are mixing untested
combinations and that is not supported.

If it doesn't work, try using the normal version found in jessie.

Paul