Subject: [Pkg-cacti-maint] Bug#793401: cacti: loadavg_multi.pl is not returning values

From: Daniel Bareiro <[email-masked]>
Date: Thu, 23 Jul 2015 12:38:04 -0300

Package: cacti
Version: 0.8.8b+dfsg-8+deb8u2
Severity: normal

Dear mantainer,

I had the problem mentioned by Stephan Seitz in archived bug #704057,
but the applied patch doesn't work in my environment.

# /usr/share/cacti/site/scripts/loadavg_multi.pl
1min: 5min: 10min:ws1:~#

The change I had applied to solve this problem was:

open(PROCESS, "env LC_ALL=C uptime |");

# /usr/share/cacti/site/scripts/loadavg_multi.pl
1min:0.15 5min:0.24 10min:0.30ws1:~#

I have this problem for several months even in Wheezy. Since no one has
reported it, I hope this information is useful.

Locale information:

# locale
LANG=es_AR.UTF-8
LANGUAGE=
LC_CTYPE="es_AR.UTF-8"
LC_NUMERIC="es_AR.UTF-8"
LC_TIME="es_AR.UTF-8"
LC_COLLATE="es_AR.UTF-8"
LC_MONETARY="es_AR.UTF-8"
LC_MESSAGES="es_AR.UTF-8"
LC_PAPER="es_AR.UTF-8"
LC_NAME="es_AR.UTF-8"
LC_ADDRESS="es_AR.UTF-8"
LC_TELEPHONE="es_AR.UTF-8"
LC_MEASUREMENT="es_AR.UTF-8"
LC_IDENTIFICATION="es_AR.UTF-8"
LC_ALL=es_AR.UTF-8

Please, check it out in Jessie.

Thanks.

Best regards,
Daniel

-- System Information:
Debian Release: 8.1
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=es_AR.UTF-8, LC_CTYPE=es_AR.UTF-8 (charmap=UTF-8) (ignored:
LC_ALL set to es_AR.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu3
ii  debconf [debconf-2.0]                    1.5.56
ii  libapache2-mod-php5                      5.6.9+dfsg-0+deb8u1
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.44-0+deb8u1
ii  perl                                     5.20.2-3+deb8u1
ii  php5                                     5.6.9+dfsg-0+deb8u1
ii  php5-cli                                 5.6.9+dfsg-0+deb8u1
ii  php5-mysql                               5.6.9+dfsg-0+deb8u1
ii  php5-snmp                                5.6.9+dfsg-0+deb8u1
ii  rrdtool                                  1.4.8-1.2
ii  snmp                                     5.7.2.1+dfsg-1
ii  ucf                                      3.0030

Versions of packages cacti recommends:
ii  apache2 [httpd]              2.4.10-10
ii  apache2-mpm-prefork [httpd]  2.4.10-10
ii  iputils-ping                 3:20121221-5+b2
ii  libjs-jquery                 1.7.2+dfsg-3.2
ii  libjs-jquery-cookie          10-1
ii  logrotate                    3.8.7-1+b1
ii  mysql-server                 5.5.44-0+deb8u1

Versions of packages cacti suggests:
pn  moreutils  <none>
pn  php5-ldap  <none>

-- debconf information:
* cacti/dbconfig-remove:
  cacti/remote/port:
  cacti/missing-db-package-error: abort
* cacti/dbconfig-install: true
  cacti/database-type: mysql
  cacti/db/app-user: cacti
  cacti/internal/reconfiguring: false
  cacti/internal/skip-preseed: false
  cacti/db/dbname: cacti
  cacti/purge: false
  cacti/dbconfig-reinstall: false
  cacti/install-error: abort
  cacti/remove-error: abort
  cacti/upgrade-error: abort
  cacti/remote/newhost:
  cacti/mysql/method: unix socket
  cacti/passwords-do-not-match:
* cacti/webserver: apache2
  cacti/upgrade-backup: true
  cacti/remote/host:
  cacti/mysql/admin-user: root
  cacti/dbconfig-upgrade: true

-- 
Ing. Daniel Bareiro - GNU/Linux registered user #188.598
Proudly running Debian GNU/Linux with uptime:
12:31:08 up 10 days, 20:39, 14 users,  load average: 1,57, 1,35, 1,32

---

From: Paul Gevers <[email-masked]>
Date: Tue, 28 Jul 2015 21:07:34 +0200

Control: tags -1 moreinfo

> Version: 0.8.8b+dfsg-8+deb8u2

My fix was in version 0.8.8a+dfsg-6.

> reported it, I hope this information is useful.

But that was not part of Wheezy. Your configuration didn't tell how you
installed that 0.8.8b version. Can you help me here?

> open(PROCESS, "env LC_ALL=C uptime |");

So I understand correctly that LANG=C doens't work and LC_ALL=C does?
Also the upstream report mentions that LC_ALL should be better, but not why.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Tue, 28 Jul 2015 19:27:06 +0000

Processing control commands:

> tags -1 moreinfo
Bug #793401 [cacti] cacti: loadavg_multi.pl is not returning values
Added tag(s) moreinfo.

-- 
793401: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=793401
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Daniel Bareiro <[email-masked]>
Date: Tue, 28 Jul 2015 18:54:24 -0300

El martes 28 de julio del 2015 a las 21:07:34 +0200,

> On 23-07-15 17:38, Daniel Bareiro wrote:

Hi, Paul.

Thanks for replying this bug report.

> installed that 0.8.8b version. Can you help me here?

Sorry for the confusion. What I meant is that I had this problem with
the latest version available on Wheezy (in fact, when I discovered in
Wheezy the problem, searching on Internet I found the bug #704057 ---
the solution there was not helpful but LC_ALL=C worked for me) and with
the current version of Jessie (0.8.8b + dfsg-8 + deb8u2).

In other words, this bug would be present in stable and oldstable.

> So I understand correctly that LANG=C doens't work and LC_ALL=C does?

Yes, that's right.

> Also the upstream report mentions that LC_ALL should be better, but not why.

Maybe it has to do with the particular configuration of locales. Since
from that time until now it seems that no one reported any problems
after application of that patch (perhaps because they did not have this
problem), I thought it might be useful.

If there is something else I can help with, please let me know.

Thanks for your reply.

Best regards,
Daniel
-- 
Ing. Daniel Bareiro - GNU/Linux registered user #188.598
Proudly running Debian GNU/Linux with uptime:
18:20:10 up 16 days,  2:28, 18 users,  load average: 1,18, 1,17, 1,14

---

From: Paul Gevers <[email-masked]>
Date: Fri, 31 Jul 2015 17:17:36 +0200

Looking again...

> LC_ALL=es_AR.UTF-8

Why do you have LC_ALL set? That overrules all the other changes. I
believe it is not meant to be set like that generally, only for
overloading for specific cases.

I may be wrong...

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 03 Aug 2015 18:21:08 +0000

Your message dated Mon, 03 Aug 2015 18:18:49 +0000
with message-id <[email-masked]>
and subject line Bug#793401: fixed in cacti 0.8.8f+ds1-2
has caused the Debian Bug report #793401,
regarding cacti: loadavg_multi.pl is not returning values
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti: loadavg_multi.pl is not returning values
From: Daniel Bareiro <[email-masked]>
To: [email-masked]
Date: Thu, 23 Jul 2015 12:38:04 -0300

Package: cacti

Dear mantainer,

Locale information:

# locale
LANG=es_AR.UTF-8
LANGUAGE=
LC_CTYPE="es_AR.UTF-8"
LC_NUMERIC="es_AR.UTF-8"
LC_TIME="es_AR.UTF-8"
LC_COLLATE="es_AR.UTF-8"

Thanks.

Best regards,
Daniel

-- System Information:
Debian Release: 8.1

-- debconf information:
* cacti/dbconfig-remove:
  cacti/remote/port:

Subject: Bug#793401: fixed in cacti 0.8.8f+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 03 Aug 2015 18:18:49 +0000

Source: cacti
Source-Version: 0.8.8f+ds1-2

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Mon, 03 Aug 2015 19:58:53 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8f+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 783416 793401
Changes:
 cacti (0.8.8f+ds1-2) unstable; urgency=medium
 .
   * Update loadavg_multi_locale_friendly.patch (Closes: #793401)
   * Add missing manual.css (Closes: #783416)
   * Fix d/rules override_dh_*configure target (Wasn't ever run,
     althought that wasn't too bad until now)
Checksums-Sha1:
 1a2ba4b3b308d2f5b10a972a3c156283d71d8f1a 1591 cacti_0.8.8f+ds1-2.dsc
 a096e23b1cd454f3844aca726c93cb1215f3e650 46156 cacti_0.8.8f+ds1-2.debian.tar.xz
 c4e8c1640327949e25551fdf4beb4f4250cf0e9f 1992498 cacti_0.8.8f+ds1-2_all.deb
Checksums-Sha256:
 625fbc475679fe4ef5ef22ac6f7b2c0fc1de9688cbbfbe56f04869bc11f79e70 1591 cacti_0.8.8f+ds1-2.dsc
 9a6e3c87f6754228dbd8421f47c40d4f1460b96ff20274455808f5ed625bcc39 46156 cacti_0.8.8f+ds1-2.debian.tar.xz
 b7d60080f5bf02b5f4290e000ec19ae63991290eafd2b65edbe0e1545f329644 1992498 cacti_0.8.8f+ds1-2_all.deb
Files:
 3e49fb915c0e5a169bf901eef4fc35ee 1591 web extra cacti_0.8.8f+ds1-2.dsc
 a531b18e66d8c58bc2f8dfac0cc59c4b 46156 web extra cacti_0.8.8f+ds1-2.debian.tar.xz
 0512296afd73d18f58ef133962e9159b 1992498 web extra cacti_0.8.8f+ds1-2_all.deb

---

From: Daniel Bareiro <[email-masked]>
Date: Sun, 09 Aug 2015 13:49:28 -0300

Hi, Paul. Sorry for the delay in replying.

> overloading for specific cases.

I could confirm that with LC_ALL empty, the applied patch on #704057
works for me. I think this (having LC_ALL configured) is a legacy
configuration I've used in a while and that has spread in every update
of Debian stable I've done. Do you think this is not recommended? If so,
why?

I see you've closed the ticket. In what state has remained?

Thanks for your time.

Best regards,
Daniel

---

From: Paul Gevers <[email-masked]>
Date: Sun, 09 Aug 2015 21:39:03 +0200

Hi Daniel

> of Debian stable I've done. Do you think this is not recommended? If so,

Because it overrules all other settings, making them completely useless,
so it can't be recommended to do that by default. See for example the
example in "man 1 locale".

> I see you've closed the ticket. In what state has remained?

As the message that closed the bug says: I updated the patch (to use
LC_ALL).

Paul

---

From: Daniel Bareiro <[email-masked]>
Date: Sun, 09 Aug 2015 20:14:41 -0300

Hi, Paul.

> example in "man 1 locale".

Thanks for the observation.

> As the message that closed the bug says: I updated the patch (to use

Yes, I saw:

----------------------------------------------------------------------
Changes:
----------------------------------------------------------------------

I guess if there is a patch, then it contains the changes we talked
about in this thread :-) I tried to see the content of this patch but I
didn't found a way to do it. Just for curiosity, can you tell me where I
can see the contents of the patches that apply to each package (based on
the open/closed issues)?

I appreciate your dedication and time.

Best regards,
Daniel