Subject: [Pkg-cacti-maint] Bug#903238: cacti: Please run autopkgtest against default-mysql-server instead of a specific implementation

From: Steve Langasek <[email-masked]>
Date: Sat, 07 Jul 2018 22:18:16 -0700

Package: cacti
Version: 1.1.38+ds1-1
Severity: minor
Tags: patch
User: [email-masked]
Usertags: origin-ubuntu cosmic ubuntu-patch

Dear Paul,

In Ubuntu, I've adjusted the autopkgtest for cacti to test against
default-mysql-server instead of mariadb-server.  The reason for this is that
mariadb-server is not the default implementation of mysql-server in Ubuntu,
and mariadb-server was recently buggy on arm64 so not only was it useful to
run the autopkgtest against the mysql-server that we use, it was also useful
to not block against mariadb-server.  Similarly, since you recently dropped
the autopkgtest to test against mysql-server in Debian due to it being
absent from testing, I think it makes sense to only test against the default
mysql implementation in Debian.

Please consider the attached patch for inclusion in Debian.
-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                   https://www.debian.org/
[email-masked]                                     [email-masked]
diff -Nru cacti-1.1.38+ds1/debian/tests/control cacti-1.1.38+ds1/debian/tests/control
--- cacti-1.1.38+ds1/debian/tests/control	2018-04-18 02:11:55.000000000 -0700
+++ cacti-1.1.38+ds1/debian/tests/control	2018-07-06 15:40:22.000000000 -0700
@@ -1,3 +1,3 @@
 Tests: check-all-pages
-Depends: mariadb-server, @, wget, apache2
+Depends: default-mysql-server, @, wget, apache2
 Restrictions: needs-root, allow-stderr, isolation-container

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Sun, 28 Oct 2018 16:09:15 +0000

Your message dated Sun, 28 Oct 2018 16:04:13 +0000
with message-id <[email-masked]>
and subject line Bug#903238: fixed in cacti 1.2.0~beta2+ds1-1
has caused the Debian Bug report #903238,
regarding cacti: Please run autopkgtest against default-mysql-server instead of a specific implementation
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
903238: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=903238
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: Please run autopkgtest against default-mysql-server instead of a specific implementation
From: Steve Langasek <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 07 Jul 2018 22:18:16 -0700

Package: cacti
Version: 1.1.38+ds1-1
Severity: minor
Tags: patch

Dear Paul,

Subject: Bug#903238: fixed in cacti 1.2.0~beta2+ds1-1
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sun, 28 Oct 2018 16:04:13 +0000

Source: cacti
Source-Version: 1.2.0~beta2+ds1-1

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 28 Oct 2018 16:00:51 +0100
Source: cacti
Binary: cacti
Architecture: source
Version: 1.2.0~beta2+ds1-1
Distribution: experimental
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 561339 903238
Changes:
 cacti (1.2.0~beta2+ds1-1) experimental; urgency=medium
 .
   * New upstream release 1.2.0-beta1
   * CVE-2009-4112: remote authenticated administrators can gain
     privileges; circumvented via optional whitelisting (Closes: #561339)
   * Refresh patches
   * Drop most of
     enable-system-jqueryui-by-putting-cacti-changes-in-main.css.patch
   * Bump Standards to 4.2.1
   * Bump debhelper compat level
   * [tests] Add mysql-server test back but with
     skip-not-installable. Debian has mariadb-server as
     default-mysql-server so we definitely want to test that. Ubuntu has
     mysql-server, so we also want to test that, but that isn't in
     testing. (Closes: #903238)
   * Drop recursive chown from postins (thanks lintian)
   * Add perl-path.patch to make sh-bang in perl scripts compliant with
     policy (thanks lintian)
   * Add font-awesome-path.patch as the path to the css is slightly
     different in the system version
   * Add fix-update-for-beta-versions.patch to ensure updating works
   * Adapt documentation building as upstream reworked it completely
Checksums-Sha1:
 2c0a9d7841c3448a4b2b5259eeaa929dd8eccfe6 2152 cacti_1.2.0~beta2+ds1-1.dsc
 ab6fbdd7a857da97e278f1d89e65a0d55275cba0 4161168 cacti_1.2.0~beta2+ds1.orig-docs-source.tar.gz
 aa448ec41b5517b85bbe05eec4beb63722da3ae6 4185048 cacti_1.2.0~beta2+ds1.orig.tar.gz
 99cd7edf3304c48dd4ae0be84f616ace23375c6b 52920 cacti_1.2.0~beta2+ds1-1.debian.tar.xz
Checksums-Sha256:
 60676a146e80eae62588ddcd906f86f51a1457968ceb959fe5a6c2aeb9616100 2152 cacti_1.2.0~beta2+ds1-1.dsc
 54e2c07d72b51f8a63a2da516783cceda5997d0f571a61a9f002190127d2cc89 4161168 cacti_1.2.0~beta2+ds1.orig-docs-source.tar.gz
 938e32b8a40caf369dc365c01281a51d2f927241eb1fb4db850f03828cae8847 4185048 cacti_1.2.0~beta2+ds1.orig.tar.gz
 581673d9c075f8ed46cc3894b26b8e25a4ac7b8dab78ef1fb1a753883ff88732 52920 cacti_1.2.0~beta2+ds1-1.debian.tar.xz
Files:
 ed51ae07d31cf9f18b91bd280ee9d235 2152 web optional cacti_1.2.0~beta2+ds1-1.dsc
 30e4988930d401b24693fa8ba862de73 4161168 web optional cacti_1.2.0~beta2+ds1.orig-docs-source.tar.gz
 c92c523912624d7c14b2b2e1ddf3b7c7 4185048 web optional cacti_1.2.0~beta2+ds1.orig.tar.gz
 7f1441859db6079547fac87a506f6778 52920 web optional cacti_1.2.0~beta2+ds1-1.debian.tar.xz

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Thu, 27 Dec 2018 20:45:10 +0000

Your message dated Thu, 27 Dec 2018 20:40:39 +0000
with message-id <[email-masked]>
and subject line Bug#903238: fixed in cacti 1.1.38+ds1-2
has caused the Debian Bug report #903238,
regarding cacti: Please run autopkgtest against default-mysql-server instead of a specific implementation
to be marked as done.

Package: cacti
Version: 1.1.38+ds1-1
Severity: minor
Tags: patch

Dear Paul,

Subject: Bug#903238: fixed in cacti 1.1.38+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Thu, 27 Dec 2018 20:40:39 +0000

Source: cacti
Source-Version: 1.1.38+ds1-2

Format: 1.8
Date: Thu, 27 Dec 2018 20:33:59 +0100
Source: cacti
Binary: cacti
Architecture: source
Version: 1.1.38+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 903238
Changes:
 cacti (1.1.38+ds1-2) unstable; urgency=medium
 .
   * [tests] Adapt for MariaDB 10.3 which triggers a new message in the
     log that doesn't seem to result in different output otherwise
   * [tests] Add mysql-server test back but with
     skip-not-installable. Debian has mariadb-server as
     default-mysql-server so we definitely want to test that. Ubuntu has
     mysql-server, so we also want to test that, but that isn't in
     testing. (Closes: #903238)
Checksums-Sha1:
 d5e86ecc37a29f6aee2ad62afefe4c5a08adcc23 2130 cacti_1.1.38+ds1-2.dsc
 4b0bc55bcad378ba692cf58b64c258d0d06fdc71 51980 cacti_1.1.38+ds1-2.debian.tar.xz
Checksums-Sha256:
 f240884ff87356cc585578da0191af95d12979de10432ec9649fced06f6f1e47 2130 cacti_1.1.38+ds1-2.dsc
 3b4c60c969ae8ec18939dc8481c03c9e2bccc9781fc2c0edeba8efce433a7b96 51980 cacti_1.1.38+ds1-2.debian.tar.xz
Files:
 1cc2162b2cb55a97cbaa2a57ba2b8039 2130 web optional cacti_1.1.38+ds1-2.dsc
 89e8192665129b32a1c22b9fd92f5d07 51980 web optional cacti_1.1.38+ds1-2.debian.tar.xz