Subject: [Pkg-cacti-maint] Bug#694159: cacti: poller reports php strict standards errors when using ping to check if device is up

From: Paul Gevers <[email-masked]>
Date: Sat, 24 Nov 2012 13:36:50 +0100

Package: cacti
Version: 0.8.8a-3
Severity: normal
Tags: upstream

If the "Downed Device Detection" is set to ping, the poller-error.log is filled
with lines like:

Nov 18 10:35:01 PHP Strict Standards:  Only variables should be passed by reference in /usr/share/cacti/site/lib/ping.php on line 382

- -- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.46
ii  libapache2-mod-php5                      5.4.4-9
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.28+dfsg-1
ii  perl                                     5.14.2-15
ii  php5-cli                                 5.4.4-9
ii  php5-mysql                               5.4.4-9
ii  php5-snmp                                5.4.4-9
ii  rrdtool                                  1.4.7-2
ii  snmp                                     5.4.3~dfsg-2.5
ii  ucf                                      3.0025+nmu3

Versions of packages cacti recommends:
ii  apache2-mpm-prefork [httpd]  2.2.22-12
ii  iputils-ping                 3:20101006-1+b1
ii  logrotate                    3.8.1-4
ii  mysql-server                 5.5.28+dfsg-1

Versions of packages cacti suggests:
ii  moreutils  0.47
pn  php5-ldap  <none>

- -- debconf information:
  cacti/db/app-user: cacti
  cacti/mysql/admin-user: root
  cacti/upgrade-backup: true
  cacti/install-error: abort
* cacti/webserver: apache2
  cacti/internal/reconfiguring: false
  cacti/mysql/method: unix socket
  cacti/remote/host:
  cacti/upgrade-error: abort
  cacti/dbconfig-upgrade: true
  cacti/internal/skip-preseed: false
  cacti/remote/newhost:
  cacti/purge: false
  cacti/passwords-do-not-match:
  cacti/dbconfig-remove:
* cacti/dbconfig-install: true
  cacti/missing-db-package-error: abort
  cacti/database-type: mysql
  cacti/remove-error: abort
  cacti/db/dbname: cacti
  cacti/remote/port:
  cacti/dbconfig-reinstall: false

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 05 May 2013 15:06:17 +0000

Your message dated Sun, 05 May 2013 15:03:18 +0000
with message-id <[email-masked]>
and subject line Bug#694159: fixed in cacti 0.8.8a+dfsg-6
has caused the Debian Bug report #694159,
regarding cacti: poller reports php strict standards errors when using ping to check if device is up
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
694159: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=694159
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: poller reports php strict standards errors when using ping to check if device is up
From: Paul Gevers <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 24 Nov 2012 13:36:50 +0100

Package: cacti
Version: 0.8.8a-3
Severity: normal
Tags: upstream

- -- System Information:

Subject: Bug#694159: fixed in cacti 0.8.8a+dfsg-6
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sun, 05 May 2013 15:03:18 +0000

Source: cacti
Source-Version: 0.8.8a+dfsg-6

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 05 May 2013 16:41:13 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8a+dfsg-6
Distribution: unstable
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - web interface for graphing of monitoring systems
Closes: 694159 704057
Changes: 
 cacti (0.8.8a+dfsg-6) unstable; urgency=low
 .
   * Improve maintenance scripts
     - Prepare cacti configuration for Apache2.4 according to
       http://wiki.debian.org/Apache/PackagingFor24
     - Improve cacti.config to fix dpkg-reconfigure behavior for httpd's.
     - Restart lighttpd if needed (LP: #1132415)
     - Remove obsolete (Sarge) preinst code
   * Fix the lighttpd config template for absolute path (see LP: #1132415)
   * Lintian triggered improvements:
     - Update watch file for +dfsg in the version
     - Add dependency on mysql-client (next to virtual-mysql-client)
   * Bug fixes:
     - Add patch loadavg_multi_locale_friendly.patch to allow uptime script to
       work independent of the local locale (Closes: #704057)
     - Add patch fix_php_strict_warning_in_ping.patch to fix php 5.4 warnings
       (Closes: #694159)
     - Add patch poller_cache_rebuild_on_install.patch to start filling the
       auto-generated graphs upon installation (Upstream: 2229)
   * Move configuration files away from /usr/share/doc/cacti (policy 12.3)
   * Remove obsolete RM-Upload-Allowed from d/control
   * Revisited README.Debian
Checksums-Sha1: 
 389e1d50753490d70e06e94382614df875da4fa1 1632 cacti_0.8.8a+dfsg-6.dsc
 1ae8facae85dfac047a83d1301e7576a67441e5f 108338 cacti_0.8.8a+dfsg-6.debian.tar.gz
 aa912ae77b323e93c66af1852c1430a5a0326f06 2141078 cacti_0.8.8a+dfsg-6_all.deb
Checksums-Sha256: 
 9f944dd824663944910a707b912d0733aef009e24c670813df0256e5adac3102 1632 cacti_0.8.8a+dfsg-6.dsc
 b3a6e845f4109432e252695a63d23e488474e8cec2dbfbc1daec72cc7c4759e9 108338 cacti_0.8.8a+dfsg-6.debian.tar.gz
 8253aae9cac0534b204c5d632c723310e818352bb9cfcd8a2d6db8106abab355 2141078 cacti_0.8.8a+dfsg-6_all.deb
Files: 
 a9fddebc007f1980a57d4bc293ef534f 1632 web extra cacti_0.8.8a+dfsg-6.dsc
 45e3a8bc9003a6366d10060ef299e391 108338 web extra cacti_0.8.8a+dfsg-6.debian.tar.gz
 54036350d01baf525b20521848da066f 2141078 web extra cacti_0.8.8a+dfsg-6_all.deb