Subject: [Pkg-cacti-maint] Bug#929482: cacti: After apt-get install cacti, the installation stated something old version DB(?) and does not proceed.

From: "ISHIKAWA,chiaki" <[email-masked]>
Date: Fri, 24 May 2019 20:00:39 +0900

Package: cacti
Version: 1.2.2+ds1-2
Severity: normal
Tags: a11y d-i

Dear Maintainer,

*** Reporter, please consider answering these questions, where 
appropriate ***

    * What led up to the situation?

      apt-get install cacti

      which I performed a few hours ago.

    * What exactly did you do (or not do) that was effective (or
      ineffective)?

      After the installation, the cacti installer stated the following 
error message and won't proceed.

Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf
Replacing config file /etc/dbconfig-common/cacti.conf with new version
Replacing config file /etc/cacti/debian.php with new version
checking privileges on database cacti for cacti@localhost: user creation 
needed.
granting access to database cacti for cacti@localhost: success.
verifying access for cacti@localhost: success.
dbconfig-common: dumping mysql database cacti to 
/var/tmp/cacti.cacti.2019-05-24-18.09.mysql.gISAIk.
database does not exist.
dbconfig-common: dropping old mysql database cacti.
dropping database cacti: database does not exist.
creating database cacti: success.
verifying database cacti exists: success.
populating database via administrative sql...  done.
populating database via sql...  done.
dbconfig-common: flushing administrative password
Running cli/upgrade_database.php as part of package update...
You are attempting to install cacti 1.2.2 onto a 0.6.x database.
To continue, you must create a new database, import 'cacti.sql' into it,
and    update 'include/config.php' to point to the new database.

    I tried a few things. But the installer repeated stated that
    You are attempting to install cacti 1.2.2 onto a 0.6.x database.
    ...
    even if
    -  I removed the package (get-apt remove cacti)
    and RECREATE the database cacti on the fly during the installation.
       At this stage http://MYHOST/cacti/ returns an error message to
       the tune of
       make sure php data  module is installed property,
       database is created, etc.

    - Or create a database 'cactinew', and edited config.php (in this
      case, and run dpkg-reconfigure cacti, the web response changes to
      Not Found

      The requested URL /cacti/ was not found on this server.
      Apache/2.4.38 (Debian) Server at 192.168.0.30 Port 80

      This I think is the failure of cacti package. It seems to miss a
      post-inst file or something.
      See the log snippet below.

         I created a database ('root' user), and I modified the
         following files to accommodate the user and database names.
         vi /etc/cacti/debian.php
         vi /usr/share/cacti/site/include/config.php

        Note the error during dpkg-reconfigure cacti: the log says
        dbconfig-generate-include: not found

         root@ip030:/var/lib/mysql# mysql -u root cacti3 < 
/usr/share/doc/cacti/cacti.sql
         root@ip030:/var/lib/mysql# !vi
         vi /etc/cacti/debian.php
         root@ip030:/var/lib/mysql# vi /etc/cacti/debian.php
         root@ip030:/var/lib/mysql# /usr/sbin/dpkg-reconfigure cacti
         Determining localhost credentials from /etc/mysql/debian.cnf: 
succeeded.
         dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf
         Replacing config file /etc/dbconfig-common/cacti.conf with new 
version
  ***   /var/lib/dpkg/info/cacti.postinst: 677: 
/var/lib/dpkg/info/cacti.postinst: dbconfig-generate-include: not found
         dbconfig-common: flushing administrative password
         Running cli/upgrade_database.php as part of package update...
         You are attempting to install cacti 1.2.2 onto a 0.6.x database.
         To continue, you must create a new database, import 'cacti.sql' 
into it,
         and    update 'include/config.php' to point to the new database.

         I cannot get out of this cycle.

    * What was the outcome of this action?

Failed installation of cacti.

          * What outcome did you expect instead?

         I expected the URL https://HOST/cacti to return cacti 
installation page.

-- System Information:
Debian Release: 10.0
   APT prefers stable-updates
   APT policy: (500, 'stable-updates'), (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/6 CPU cores)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8), 
LANGUAGE=ja_JP.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cacti depends on:
ii  dbconfig-common                           2.0.11
ii  dbconfig-mysql                            2.0.11
ii  debconf [debconf-2.0]                     1.5.71
ii  fonts-dejavu-core                         2.37-1
ii  fonts-dejavu-extra                        2.37-1
ii  fonts-fork-awesome                        1.1.5+ds1-2
ii  javascript-common                         11
ii  libapache2-mod-php                        2:7.3+69
ii  libapache2-mod-php7.3 [libapache2-mod-ph  7.3.4-2
ii  libjs-c3                                  0.4.11+dfsg-2
ii  libjs-chart.js                            2.7.3+dfsg-3
ii  libjs-d3                                  3.5.17-2
ii  libjs-jquery                              3.3.1~dfsg-3
ii  libjs-jquery-colorpicker                  1.2.17-1
ii  libjs-jquery-cookie                       12-1.1
ii  libjs-jquery-hotkeys 0~20130707+git2d51e3a9+dfsg-2
ii  libjs-jquery-jstree                       3.3.7+dfsg1-1
ii  libjs-jquery-metadata                     12-1.1
ii  libjs-jquery-tablesorter                  1:2.31.1+dfsg1-1
ii  libjs-jquery-timepicker                   1.2-1
ii  libjs-jquery-ui                           1.12.1+dfsg-5
ii  libjs-jquery-ui-theme-smoothness          1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-south-street        1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-ui-darkness         1.12.1+dfsg-1
ii  libjs-jquery-ui-touch-punch 0.0~git20141218.2.4bc0091+dfsg1-2
ii  libphp-phpmailer                          6.0.6-0.1
ii  perl                                      5.28.1-6
ii  php-cli                                   2:7.3+69
ii  php-gd                                    2:7.3+69
ii  php-ldap                                  2:7.3+69
ii  php-mbstring                              2:7.3+69
ii  php-mysql                                 2:7.3+69
ii  php-php-gettext                           1.0.12-0.1
ii  php-phpseclib                             2.0.14-1
ii  php-snmp                                  2:7.3+69
ii  php-twig                                  2.6.2-2
ii  php-xml                                   2:7.3+69
ii  php7.3-cli [php-cli]                      7.3.4-2
ii  php7.3-gd [php-gd]                        7.3.4-2
ii  php7.3-json [php-json]                    7.3.4-2
ii  php7.3-ldap [php-ldap]                    7.3.4-2
ii  php7.3-mbstring [php-mbstring]            7.3.4-2
ii  php7.3-snmp [php-snmp]                    7.3.4-2
ii  php7.3-xml [php-xml]                      7.3.4-2
ii  rrdtool                                   1.7.1-1
ii  snmp                                      5.7.3+dfsg-5
ii  ucf                                       3.0038+nmu1

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.38-3
ii  default-mysql-server                        1.0.5
ii  iputils-ping                                3:20180629-2
ii  logrotate                                   3.14.0-4
ii  mariadb-server-10.3 [virtual-mysql-server]  1:10.3.14-1
ii  php-gmp                                     2:7.3+69
ii  php7.3-gmp [php-gmp]                        7.3.4-2

Versions of packages cacti suggests:
pn  cacti-spine  <none>
pn  moreutils    <none>
pn  snmpd        <none>

-- debconf information:
   cacti/mysql/method: Unix socket
   cacti/missing-db-package-error: abort
   cacti/remote/host: localhost
   cacti/upgrade-backup: true
   cacti/database-type: mysql
   cacti/dbconfig-upgrade: true
   cacti/db/dbname: cacti
   cacti/db/app-user: cacti@localhost
* cacti/remove-error: ignore
   cacti/passwords-do-not-match:
* cacti/dbconfig-remove: true
   cacti/remote/newhost:
   cacti/upgrade-error: abort
* cacti/dbconfig-install: true
   cacti/internal/reconfiguring: false
   cacti/purge: false
* cacti/webserver: None
* cacti/dbconfig-reinstall: true
   cacti/remote/port:
   cacti/install-error: retry
   cacti/internal/skip-preseed: false
* cacti/mysql/admin-user: root

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Sat, 25 May 2019 08:21:06 +0000

Processing control commands:

> tags -1 moreinfo
Bug #929482 [cacti] cacti: After apt-get install cacti, the installation stated something old version DB(?) and does not proceed.
Added tag(s) moreinfo.

-- 
929482: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929482
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Paul Gevers <[email-masked]>
Date: Sat, 25 May 2019 10:18:06 +0200

Control: tags -1 moreinfo

Hi ISHIKAWA,

Thanks for reporting issues you encounter.

On 24-05-2019 13:00, ISHIKAWA,chiaki wrote:

dbconfig-generate-include is part of dbconfig-common. Can you check that
you have a file
/usr/sbin/dbconfig-generate-include?

Are you by any chance running a usr-merged setup?

Paul

---

From: "ISHIKAWA,chiaki" <[email-masked]>
Date: Wed, 5 Jun 2019 01:15:46 +0900

> Are you by any chance running a usr-merged setup?

Hi,

Sorry I missed reading this earlier.

I checked and I did have dbconfi-geneate-include:

> env LANG=C ls -l /usr/sbin/db*
> -rwxr-xr-x 1 root root 12663 Dec 13 18:32 
> /usr/sbin/dbconfig-generate-include
> -rwxr-xr-x 1 root root  5707 Dec 13 18:32 /usr/sbin/dbconfig-load-include
>

 > Are you by any chance running a usr-merged setup?

I was not sure what you mean by "usr-merged".

I searched and came up with this web page.

https://wiki.debian.org/UsrMerge

usr-merged: I don't think so...

env LANG=C ls -ld /bin /sbin /lib
drwxr-xr-x  2 root root  4096 May 10 10:18 /bin
drwxr-xr-x 19 root root  4096 May 20 06:20 /lib
drwxr-xr-x  2 root root 12288 May 10 10:18 /sbin

I checked that /bin and /usr/sbin, /lib and /usr/lib and /sbin and 
/usr/sbin contained
different number of files under them.

TIA

---

From: "ISHIKAWA,chiaki" <[email-masked]>
Date: Wed, 5 Jun 2019 10:59:20 +0900

This is not a strictly speaking bug report.

But I noticed that when I try to access the mail archive of 
pkg-cacti-maint via the web interface,
my norton anti-virus's safe browser feature shuts the access off 
initially stating
that the web site is a dangerous site, etc.

What on earth is going on? I checked that Norton anti-virus regard the 
mail archive due to the
following two infected attachments in the archive.
It would be great if someone can remove the said
mails so that Norton no longer regards the archive access dangerous.

        Threat Report

small-warning
Viruses
Threats found: *2*
Here is a complete list: (for more information about a specific threat, 
click on the Threat Name below)

Threat Name:
JS.Nemucod!g1 
<http://www.symantec.com/avcenter/cgi-bin/virauto.cgi?vid=36982>
Location:
https://alioth-lists.debian.net/pipermail/pkg-salt-team/attachments/20150615/3ed58d65/attachment.zip 

Threat Name:
Direct Link To JS.Nemucod!g1 
<http://www.symantec.com/avcenter/cgi-bin/virauto.cgi?vid=36982>
Location:
http://alioth-lists.debian.net/pipermail/pkg-salt-team/attachments/20150615/3ed58d65/attachment.zip 

Just FYI.

On 2019/06/05 1:27, Debian Bug Tracking System wrote:
> Thank you for the additional information you have supplied regarding
> this Bug report.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>   Cacti Maintainer <[email-masked]>
>
> If you wish to submit further information on this problem, please
> send it to [email-masked].
>
> Please do not send mail to [email-masked] unless you wish
> to report a problem with the Bug-tracking system.
>

---

From: Paul Gevers <[email-masked]>
Date: Thu, 5 Jan 2023 11:43:07 +0100

Control: tag -1 wontfix

Hi,

Sorry for the late follow up.

>     -  I removed the package (get-apt remove cacti)

I would probably have worked if you had *purge*d cacti instead of 
removal. There's a question to remove the old database and all traces. 
If you would have done that, I'm convinced a fresh install would have 
worked fine.

I think really the problem in this bug report is that you had an extreme 
old cacti database on this system. Upgrading from before 0.8 isn't 
supported upstream, so neither can Debian cacti packages.

Paul

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Thu, 05 Jan 2023 10:45:05 +0000

Processing control commands:

> tag -1 wontfix
Added tag(s) wontfix.

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Wed, 29 Jan 2025 19:27:02 +0000

Your message dated Wed, 29 Jan 2025 20:22:34 +0100
with message-id <[email-masked]>
and subject line Re: cacti: After apt-get install cacti, the installation stated something old version DB(?) and does not proceed.
has caused the Debian Bug report #929482,
regarding cacti: After apt-get install cacti, the installation stated something old version DB(?) and does not proceed.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti: After apt-get install cacti, the installation stated something old version DB(?) and does not proceed.
From: "ISHIKAWA,chiaki" <[email-masked]>
To: "To: Debian Bug Tracking System" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Date: Fri, 24 May 2019 20:00:39 +0900

Package: cacti
Version: 1.2.2+ds1-2
Severity: normal
Tags: a11y d-i

Dear Maintainer,

      apt-get install cacti

-- System Information:
Debian Release: 10.0

-- debconf information:

Subject: Re: cacti: After apt-get install cacti, the installation stated something old version DB(?) and does not proceed.
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Wed, 29 Jan 2025 20:22:34 +0100

Hi,

> supported upstream, so neither can Debian cacti packages.
And instead of keeping this bug open, lets close it as it's not actionable.

Paul