Subject: [Pkg-cacti-maint] Bug#929323: cacti-spine: results_buffer size limits reporting capabilities

From: Anthony Bible <[email-masked]>
Date: Tue, 21 May 2019 10:02:39 -0600

Package: cacti-spine
Version: 1.1.37-2~bpo9+1
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
	We have several services being checked that return more than 1024 bytes (with_resluts_buffer limit of cacti-spine). This makes it so information doesn't get catalouged by cacti.  
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
	We use several different scripts, two of which  is a vanrish check: https://github.com/glensc/cacti-template-varnish and percona https://www.percona.com/doc/percona-monitoring-plugins/LATEST/cacti/creating-graphs.html. I assume there are many more packages that require a results_buffer more than 1024 bytes
   * What was the outcome of this action?
   * What outcome did you expect instead?
	The poller should reliably store information more than 1024 bytes. I believe the solution is to increase the default compile option of the with_results_buffer to at least 2048 bytes as services grow to return more data.

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: 9.9
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-6-amd64 (SMP w/16 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cacti-spine depends on:
ii  cacti                  1.1.38+ds1-1~bpo9+1
ii  dbconfig-no-thanks     2.0.11~bpo9+1
ii  debconf [debconf-2.0]  1.5.61
ii  libc6                  2.24-11+deb9u4
ii  libcap2                1:2.25-1
ii  libmariadbclient18     10.1.38-0+deb9u1
ii  libsnmp30              5.7.3+dfsg-1.7+deb9u1
ii  ucf                    3.0036

Versions of packages cacti-spine recommends:
ii  libcap2-bin  1:2.25-1

Versions of packages cacti-spine suggests:
ii  snmp-mibs-downloader  1.1+nmu1

-- no debconf information

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Thu, 23 May 2019 18:27:04 +0000

Processing control commands:

> forwarded -1 https://github.com/Cacti/spine/issues/94
Bug #929323 [cacti-spine] cacti-spine: results_buffer size limits reporting capabilities
Set Bug forwarded-to-address to 'https://github.com/Cacti/spine/issues/94'.

-- 
929323: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929323
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Paul Gevers <[email-masked]>
Date: Thu, 23 May 2019 20:23:24 +0200

Control: forwarded -1 https://github.com/Cacti/spine/issues/94

Hi Anthony

On 21-05-2019 18:02, Anthony Bible wrote:
> We have several services being checked that return more than 1024
> bytes (with_resluts_buffer limit of cacti-spine). This makes it so
> information doesn't get catalouged by cacti.
Thanks for your report. I have forwarded it to the upstream issue tracker.

Paul

---

From: Anthony Bible <[email-masked]>
Date: Mon, 23 Sep 2019 12:18:46 -0600

Paul,
I've noticed the upstream included a fix
(https://github.com/Cacti/spine/issues/94) and was wondering if you
might release this fix?

-- 
Anthony Bible

Inetz Jr. Systems Administrator

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 23 Sep 2019 20:39:04 +0000

Your message dated Mon, 23 Sep 2019 20:37:56 +0000
with message-id <[email-masked]>
and subject line Bug#929323: fixed in cacti-spine 1.2.6-1
has caused the Debian Bug report #929323,
regarding cacti-spine: results_buffer size limits reporting capabilities
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti-spine: results_buffer size limits reporting capabilities
From: Anthony Bible <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Tue, 21 May 2019 10:02:39 -0600

Package: cacti-spine
Version: 1.1.37-2~bpo9+1
Severity: normal

Dear Maintainer,

-- System Information:
Debian Release: 9.9

Subject: Bug#929323: fixed in cacti-spine 1.2.6-1
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 23 Sep 2019 20:37:56 +0000

Source: cacti-spine
Source-Version: 1.2.6-1

We believe that the bug you reported is fixed in the latest version of
cacti-spine, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti-spine package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Mon, 23 Sep 2019 20:37:59 +0200
Source: cacti-spine
Architecture: source
Version: 1.2.6-1
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Closes: 929323
Changes:
 cacti-spine (1.2.6-1) unstable; urgency=medium
 .
   * New upstream version 1.2.6
     - Increase default 'results_buffer' size to 2048 (Closes: #929323)
   * Update d/copyright
   * Bump debhelper compat level via BD on debhelper-compat
   * Bump standards
Checksums-Sha1:
 7d4a5866969cb09f2674aab6be7f4781ce3676e1 1805 cacti-spine_1.2.6-1.dsc
 1ec470199edc2bf9307e266be9bbf818d11a77ee 106592 cacti-spine_1.2.6.orig.tar.gz
 21fa0629b55ed41004b119231a8c65c7fb256ffe 14488 cacti-spine_1.2.6-1.debian.tar.xz
Checksums-Sha256:
 4ede7736296ec72a405aa4546f63ff8cd80398005477dc1100c3d46c9609ddfd 1805 cacti-spine_1.2.6-1.dsc
 e7f9403cf185d1bed10b53d8ef61322f9ad4af9ec67021d154e47f85da99af62 106592 cacti-spine_1.2.6.orig.tar.gz
 bfab10e8f757d4056c2b38f9b400d28642f4c293e11b542044445062f2fd12c6 14488 cacti-spine_1.2.6-1.debian.tar.xz
Files:
 0309be45b1db0f7de1bc25dd483bfabd 1805 web optional cacti-spine_1.2.6-1.dsc
 ba3e8723fa9b8f0b5db6dddb03b33a17 106592 web optional cacti-spine_1.2.6.orig.tar.gz
 4c99d8c62052e0afca66bb7608662615 14488 web optional cacti-spine_1.2.6-1.debian.tar.xz