Subject: [Pkg-cacti-maint] Bug#861853: cacti defaults to the wrong rrdtool (and the current rrdtool version isn't even available)

From: Paul Gevers <[email-masked]>
Date: Thu, 04 May 2017 21:11:33 +0200

Package: cacti
Version: 0.8.8h+ds1-9
Severity: normal

After a fresh install of cacti, the rrdtool version recorded is 1.0.x. This
should have been 1.6.x (which isn't available) and failing that at least the
highest available version.

- -- System Information:
Debian Release: 9.0
  APT prefers testing-debug
  APT policy: (500, 'testing-debug'), (500, 'testing'), (200, 'experimental'), (200, 'testing'), (50, 'experimental'), (50, 'testing'), (1, 'experimental')
Architecture: amd64
 (x86_64)

Kernel: Linux 4.9.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cacti depends on:
ii  dbconfig-mysql                              2.0.8
ii  debconf [debconf-2.0]                       1.5.60
ii  javascript-common                           11
ii  libapache2-mod-php                          1:7.0+49
ii  libapache2-mod-php7.0 [libapache2-mod-php]  7.0.16-3
ii  libjs-jquery                                3.1.1-2
ii  libjs-jquery-cookie                         11-3
ii  libjs-jquery-jstree                         3.3.3+dfsg1-1
ii  libjs-jquery-ui                             1.12.1+dfsg-4
ii  libjs-jquery-ui-theme-ui-lightness          1.12.1+dfsg-1
ii  libphp-adodb                                5.20.9-1
pn  perl:any                                    <none>
ii  php-cli                                     1:7.0+49
ii  php-mbstring                                1:7.0+49
ii  php-mysql                                   1:7.0+49
ii  php-snmp                                    1:7.0+49
ii  php-xml                                     1:7.0+49
ii  php7.0-cli [php-cli]                        7.0.16-3
ii  php7.0-mbstring [php-mbstring]              7.0.16-3
ii  php7.0-mysql [php-mysqlnd]                  7.0.16-3
ii  php7.0-snmp [php-snmp]                      7.0.16-3
ii  php7.0-xml [php-xml]                        7.0.16-3
ii  rrdtool                                     1.6.0-1+b2
ii  snmp                                        5.7.3+dfsg-1.7
ii  ucf                                         3.0036

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.25-3
ii  iputils-ping                                3:20161105-1
ii  logrotate                                   3.11.0-0.1
ii  mariadb-server-10.1 [virtual-mysql-server]  10.1.22-3

Versions of packages cacti suggests:
ii  moreutils  0.60-1
pn  php-ldap   <none>

- -- debconf information:
  cacti/missing-db-package-error: abort
  cacti/dbconfig-reinstall: false
  cacti/internal/reconfiguring: false
  cacti/dbconfig-remove: true
  cacti/dbconfig-upgrade: true
  cacti/upgrade-error: abort
  cacti/purge: false
  cacti/internal/skip-preseed: false
* cacti/mysql/admin-user: root
  cacti/database-type: mysql
  cacti/remote/host: localhost
  cacti/upgrade-backup: true
  cacti/mysql/method: Unix socket
  cacti/install-error: abort
  cacti/remove-error: abort
  cacti/remote/newhost:
  cacti/passwords-do-not-match:
  cacti/db/dbname: cacti
* cacti/webserver: apache2
  cacti/remote/port:
* cacti/dbconfig-install: true
  cacti/db/app-user: cacti@localhost

---

From: [email-masked] (Debian Bug Tracking System)
Date: Wed, 16 Aug 2017 14:39:03 +0000

Your message dated Wed, 16 Aug 2017 16:22:18 +0200
with message-id <[email-masked]>
and subject line Re: cacti defaults to the wrong rrdtool (and the current rrdtool version isn't even available)
has caused the Debian Bug report #861853,
regarding cacti defaults to the wrong rrdtool (and the current rrdtool version isn't even available)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
861853: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=861853
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti defaults to the wrong rrdtool (and the current rrdtool version isn't even available)
From: Paul Gevers <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Thu, 04 May 2017 21:11:33 +0200

Package: cacti
Version: 0.8.8h+ds1-9
Severity: normal

- -- System Information:
Debian Release: 9.0

Subject: Re: cacti defaults to the wrong rrdtool (and the current rrdtool version isn't even available)
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Wed, 16 Aug 2017 16:22:18 +0200

Version: 1.1.13+ds-1

> highest available version.

Not sure when it got fixed, but at least in 1.1.13+ds-1 that I just
inspected, that isn't the case anymore (albeit on stretch).

Paul