Subject: [Pkg-cacti-maint] Bug#707010: cacti: unowned files after purge (policy 6.8, 10.8): /etc/apache2/conf-available/cacti.conf, /etc/cacti/debian.php, /etc/lighttpd/conf-available/20-cacti.conf

From: Andreas Beckmann <[email-masked]>
Date: Mon, 06 May 2013 22:35:37 +0200

Package: cacti
Version: 0.8.8a+dfsg-6
Severity: important
User: [email-masked]
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package left unowned files on
the system after purge, which is a violation of policy 6.8 (or 10.8):

http://www.debian.org/doc/debian-policy/ch-maintainerscripts.html#s-removedetails

Filing this as important as having a piuparts clean archive is a release
goal since lenny.

>From the attached log (scroll to the bottom...):

1m3.2s ERROR: FAIL: Package purging left files on system:
  /etc/apache2/conf-available/	 owned by: cacti
  /etc/apache2/conf-available/cacti.conf	 not owned
  /etc/cacti/	 owned by: cacti
  /etc/cacti/debian.php	 not owned
  /etc/lighttpd/	 owned by: cacti
  /etc/lighttpd/conf-available/	 owned by: cacti
  /etc/lighttpd/conf-available/20-cacti.conf	 not owned

cheers,

Andreas

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 18 May 2013 12:36:16 +0000

Your message dated Sat, 18 May 2013 12:32:46 +0000
with message-id <[email-masked]>
and subject line Bug#707010: fixed in cacti 0.8.8a+dfsg-7
has caused the Debian Bug report #707010,
regarding cacti: unowned files after purge (policy 6.8, 10.8): /etc/apache2/conf-available/cacti.conf, /etc/cacti/debian.php, /etc/lighttpd/conf-available/20-cacti.conf
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
707010: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=707010
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: unowned files after purge (policy 6.8, 10.8): /etc/apache2/conf-available/cacti.conf, /etc/cacti/debian.php, /etc/lighttpd/conf-available/20-cacti.conf
From: Andreas Beckmann <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Mon, 06 May 2013 22:35:37 +0200

Package: cacti
Version: 0.8.8a+dfsg-6
Severity: important

Hi,

cheers,

Andreas

Subject: Bug#707010: fixed in cacti 0.8.8a+dfsg-7
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sat, 18 May 2013 12:32:46 +0000

Source: cacti
Source-Version: 0.8.8a+dfsg-7

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sat, 18 May 2013 12:14:02 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8a+dfsg-7
Distribution: unstable
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - web interface for graphing of monitoring systems
Closes: 707010 708001
Changes: 
 cacti (0.8.8a+dfsg-7) unstable; urgency=low
 .
   * Fix typo in cacti.postrm which prevented proper purging (Closes: #707010)
   * Update use_jquery_for_debian.patch to not load jquery-cookie if it is
     not installed on the system (Closes: #708001)
Checksums-Sha1: 
 3679d0d9093cc81a97d47db818674017b903f1c3 1632 cacti_0.8.8a+dfsg-7.dsc
 88e0f23c233222e54634a93cd625d2972bcc50db 108513 cacti_0.8.8a+dfsg-7.debian.tar.gz
 b7a577a3515a773f762d309f688e3ad2c532daa8 2141346 cacti_0.8.8a+dfsg-7_all.deb
Checksums-Sha256: 
 324dadf0ea26229e3db15c47072773d0392d37a004dfbd6156e0d991100e1dc0 1632 cacti_0.8.8a+dfsg-7.dsc
 add269fa6633f7ac14323abac3525d4ba64f1fbed8a0e1a98c4b32c90253b125 108513 cacti_0.8.8a+dfsg-7.debian.tar.gz
 baa21be7b798c641eff66729f73231c5cdd3b7b72a06eba1b870b38039c5034e 2141346 cacti_0.8.8a+dfsg-7_all.deb
Files: 
 295ae2c12271cc366d4596f4359bfa35 1632 web extra cacti_0.8.8a+dfsg-7.dsc
 ff0d317f71c31e02ec6612501f9515d6 108513 web extra cacti_0.8.8a+dfsg-7.debian.tar.gz
 0318d57975a9563ec44c85f9d3f622b2 2141346 web extra cacti_0.8.8a+dfsg-7_all.deb