Subject: [Pkg-cacti-maint] Bug#709015: cacti-spine: FTBFS with multiarch net-snmp

From: Colin Watson <[email-masked]>
Date: Mon, 20 May 2013 11:40:18 +0100

Package: cacti-spine
Version: 0.8.8a-1
Severity: serious
Tags: patch
User: [email-masked]
Usertags: origin-ubuntu ubuntu-patch saucy

cacti-spine fails to build with the multiarch net-snmp in unstable as
follows:

  /bin/bash ./libtool --tag=CC   --mode=link i486-linux-gnu-gcc  -I/usr/include/net-snmp -I/usr/include/net-snmp/.. -I/usr/include/mysql -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security  -L -Wl,-z,relro -o spine sql.o spine.o util.o snmp.o locks.o poller.o nft_popen.o php.o ping.o keywords.o error.o  -lnetsnmp -lmysqlclient_r -lmysqlclient_r -lcrypto -lz -lpthread -lm
  libtool: link: require no space between `-L' and `-Wl,-z,relro'
  make[1]: *** [spine] Error 1

This is because configure fails to figure out SNMP_LIBDIR.  Since it's
unnecessary to pass an explicit -L flag for something already on the
system library path, the simplest fix is to do what's already done for
MYSQL_LIB_DIR above and just not bother if it's empty.

  * Don't add -L option for SNMP_LIBDIR if it's empty.

diff -Nru cacti-spine-0.8.8a/debian/patches/04-snmp-libdir.patch cacti-spine-0.8.8a/debian/patches/04-snmp-libdir.patch
--- cacti-spine-0.8.8a/debian/patches/04-snmp-libdir.patch	1970-01-01 01:00:00.000000000 +0100
+++ cacti-spine-0.8.8a/debian/patches/04-snmp-libdir.patch	2013-05-20 11:35:38.000000000 +0100
@@ -0,0 +1,20 @@
+Description: Don't add -L option for SNMP_LIBDIR if it's empty
+Author: Colin Watson <[email-masked]>
+Forwarded: no
+Last-Update: 2013-05-20
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -303,7 +303,9 @@
+   fi
+ fi
+ 
+-LDFLAGS="-L$SNMP_LIBDIR $LDFLAGS"
++if test -n "$SNMP_LIBDIR"; then
++  LDFLAGS="-L$SNMP_LIBDIR $LDFLAGS"
++fi
+ CFLAGS="-I$SNMP_INCDIR -I$SNMP_INCDIR/.. $CFLAGS"
+ 
+ # Net/UCD-SNMP includes v3 support and insists on crypto unless compiled --without-openssl
diff -Nru cacti-spine-0.8.8a/debian/patches/series cacti-spine-0.8.8a/debian/patches/series
--- cacti-spine-0.8.8a/debian/patches/series	2012-06-25 18:05:24.000000000 +0100
+++ cacti-spine-0.8.8a/debian/patches/series	2013-05-20 11:33:51.000000000 +0100
@@ -1 +1,2 @@
 03-config-dir.patch
+04-snmp-libdir.patch

Thanks,

-- 
Colin Watson                                       [[email-masked]]

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 20 May 2013 16:30:49 +0000

Your message dated Mon, 20 May 2013 16:17:52 +0000
with message-id <[email-masked]>
and subject line Bug#709015: fixed in cacti-spine 0.8.8a-2
has caused the Debian Bug report #709015,
regarding cacti-spine: FTBFS with multiarch net-snmp
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
709015: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709015
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti-spine: FTBFS with multiarch net-snmp
From: Colin Watson <[email-masked]>
To: [email-masked]
Date: Mon, 20 May 2013 11:40:18 +0100

Package: cacti-spine
Version: 0.8.8a-1
Severity: serious
Tags: patch

Thanks,

Subject: Bug#709015: fixed in cacti-spine 0.8.8a-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 20 May 2013 16:17:52 +0000

Source: cacti-spine
Source-Version: 0.8.8a-2

We believe that the bug you reported is fixed in the latest version of
cacti-spine, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti-spine package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Mon, 20 May 2013 16:30:28 +0200
Source: cacti-spine
Binary: cacti-spine
Architecture: source amd64
Version: 0.8.8a-2
Distribution: unstable
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti-spine - Multi-Threading poller for cacti
Closes: 709015
Changes: 
 cacti-spine (0.8.8a-2) unstable; urgency=low
 .
   * Add 04-snmp-libdir.patch to not add -L option for SNMP_LIBDIR if it's empty.
     Thanks Colin Watson (Closes: #709015)
Checksums-Sha1: 
 6a58c1aa4c152240a6ba313ea6313217f7474041 1732 cacti-spine_0.8.8a-2.dsc
 971b0b06ead0c68ecdf50b7f415033d1bffa3809 17004 cacti-spine_0.8.8a-2.debian.tar.gz
 2a84344bcaccc9046204d11906e8a7f8ad29778a 64504 cacti-spine_0.8.8a-2_amd64.deb
Checksums-Sha256: 
 b22cf0c39a99b1b40afc70f1fbba3921ff87a1d3a65609b2f6674f3227e96113 1732 cacti-spine_0.8.8a-2.dsc
 1ae9cdb298951f539b2f6c501e71257fd5751253551ea06b63fe5449ee39cf19 17004 cacti-spine_0.8.8a-2.debian.tar.gz
 cdb86c30c16eb364a641cc56114efd041ae253d008ea5d50caa0384f4aeed01c 64504 cacti-spine_0.8.8a-2_amd64.deb
Files: 
 b8f39e7151f8af2269d706528d59d9b2 1732 web extra cacti-spine_0.8.8a-2.dsc
 c24b5d235703221b3dc01ed6f144a734 17004 web extra cacti-spine_0.8.8a-2.debian.tar.gz
 328b899cbf674df4b33bd09bc4031637 64504 web extra cacti-spine_0.8.8a-2_amd64.deb