Subject: [Pkg-cacti-maint] Bug#916814: cacti: [1.2.0 Beta 4] Spike Kill not working (missing file)

From: "jay.slovak" <[email-masked]>
Date: Wed, 19 Dec 2018 00:27:07 +0100

Package: cacti
Version: 1.2.0~beta4+ds1-1
Severity: normal

Dear Maintainer,

Spike Kill functionality is not working. Clicking on dry run generates an error message "Could not open input file: /usr/share/cacti/site/cli/removespikes.php".

Problem was reported upstream, but they have suggested this is a packaging bug https://github.com/Cacti/cacti/issues/2218

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.16.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cacti depends on:
ii  dbconfig-common                           2.0.11
ii  dbconfig-mysql                            2.0.11
ii  debconf [debconf-2.0]                     1.5.69
ii  fonts-dejavu-core                         2.37-1
ii  fonts-dejavu-extra                        2.37-1
ii  fonts-font-awesome                        5.0.10+really4.7.0~dfsg-1
ii  javascript-common                         11
ii  libapache2-mod-php                        2:7.3+68
ii  libapache2-mod-php7.3 [libapache2-mod-ph  7.3.0-1
ii  libjs-c3                                  0.4.11+dfsg-2
ii  libjs-chartjs                             1.0.2-1
ii  libjs-d3                                  3.5.17-2
ii  libjs-jquery                              3.2.1-1
ii  libjs-jquery-colorpicker                  1.2.17-1
ii  libjs-jquery-cookie                       12-1.1
ii  libjs-jquery-hotkeys                      0~20130707+git2d51e3a9+dfsg-2
ii  libjs-jquery-jstree                       3.3.7+dfsg1-1
ii  libjs-jquery-metadata                     12-1.1
ii  libjs-jquery-tablesorter                  1:2.31.1+dfsg1-1
ii  libjs-jquery-timepicker                   1.2-1
ii  libjs-jquery-ui                           1.12.1+dfsg-5
ii  libjs-jquery-ui-theme-smoothness          1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-south-street        1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-ui-darkness         1.12.1+dfsg-1
ii  libjs-jquery-ui-touch-punch               0.0~git20141218.2.4bc0091+dfsg1-2
ii  libphp-phpmailer                          5.2.14+dfsg-2.4
ii  perl                                      5.28.1-3
ii  php-gd                                    2:7.3+68
ii  php-ldap                                  2:7.3+68
ii  php-mbstring                              2:7.3+68
ii  php-mysql                                 2:7.3+68
ii  php-php-gettext                           1.0.12-0.1
ii  php-phpseclib                             2.0.12-1
ii  php-snmp                                  2:7.3+68
ii  php-twig                                  2.5.0-1
ii  php-xml                                   2:7.3+68
ii  php7.3-cli [php-cli]                      7.3.0-1
ii  php7.3-gd [php-gd]                        7.3.0-1
ii  php7.3-json [php-json]                    7.3.0-1
ii  php7.3-ldap [php-ldap]                    7.3.0-1
ii  php7.3-mbstring [php-mbstring]            7.3.0-1
ii  php7.3-snmp [php-snmp]                    7.3.0-1
ii  php7.3-xml [php-xml]                      7.3.0-1
ii  rrdtool                                   1.7.0-1+b3
ii  snmp                                      5.7.3+dfsg-4+b1
ii  ucf                                       3.0038

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.37-1
ii  default-mysql-server                        1.0.4
ii  iputils-ping                                3:20180629-2
ii  logrotate                                   3.14.0-4
ii  mariadb-server-10.1 [virtual-mysql-server]  1:10.1.37-3
ii  php-gmp                                     2:7.3+68
ii  php7.3-gmp [php-gmp]                        7.3.0-1

Versions of packages cacti suggests:
pn  cacti-spine  <none>
pn  moreutils    <none>
pn  snmpd        <none>

-- debconf information excluded

---

From: "jay.slovak" <[email-masked]>
Date: Wed, 23 Jan 2019 15:05:31 +0100

Package: cacti
Version: 1.2.0~beta4+ds1-1
Followup-For: Bug #916814

Dear Maintainer,

The issue was solved upstream, can we have the package updated with latest upstream release?

Thanks!

-- System Information:

Kernel: Linux 4.19.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cacti depends on:
ii  dbconfig-common                           2.0.11
ii  dbconfig-mysql                            2.0.11
ii  debconf [debconf-2.0]                     1.5.70
ii  fonts-dejavu-core                         2.37-1
ii  fonts-dejavu-extra                        2.37-1
ii  fonts-font-awesome                        5.0.10+really4.7.0~dfsg-1
ii  javascript-common                         11
ii  libapache2-mod-php                        2:7.3+69
ii  libapache2-mod-php7.3 [libapache2-mod-ph  7.3.1-1
ii  libjs-c3                                  0.4.11+dfsg-2
ii  libjs-chartjs                             1.0.2-1
ii  libjs-d3                                  3.5.17-2
ii  libjs-jquery                              3.2.1-1
ii  libjs-jquery-colorpicker                  1.2.17-1
ii  libjs-jquery-cookie                       12-1.1
ii  libjs-jquery-hotkeys                      0~20130707+git2d51e3a9+dfsg-2
ii  libjs-jquery-jstree                       3.3.7+dfsg1-1
ii  libjs-jquery-metadata                     12-1.1
ii  libjs-jquery-tablesorter                  1:2.31.1+dfsg1-1
ii  libjs-jquery-timepicker                   1.2-1
ii  libjs-jquery-ui                           1.12.1+dfsg-5
ii  libjs-jquery-ui-theme-smoothness          1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-south-street        1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-ui-darkness         1.12.1+dfsg-1
ii  libjs-jquery-ui-touch-punch               0.0~git20141218.2.4bc0091+dfsg1-2
ii  libphp-phpmailer                          5.2.14+dfsg-2.4
ii  perl                                      5.28.1-3
ii  php-gd                                    2:7.3+69
ii  php-ldap                                  2:7.3+69
ii  php-mbstring                              2:7.3+69
ii  php-mysql                                 2:7.3+69
ii  php-php-gettext                           1.0.12-0.1
ii  php-phpseclib                             2.0.13-1
ii  php-snmp                                  2:7.3+69
ii  php-twig                                  2.6.2-1
ii  php-xml                                   2:7.3+69
ii  php7.3-cli [php-cli]                      7.3.1-1
ii  php7.3-gd [php-gd]                        7.3.1-1
ii  php7.3-json [php-json]                    7.3.1-1
ii  php7.3-ldap [php-ldap]                    7.3.1-1
ii  php7.3-mbstring [php-mbstring]            7.3.1-1
ii  php7.3-snmp [php-snmp]                    7.3.1-1
ii  php7.3-xml [php-xml]                      7.3.1-1
ii  rrdtool                                   1.7.0-1+b3
ii  snmp                                      5.7.3+dfsg-5
ii  ucf                                       3.0038+nmu1

ii  php-gmp                                     2:7.3+69
ii  php7.3-gmp [php-gmp]                        7.3.1-1

---

From: Paul Gevers <[email-masked]>
Date: Wed, 23 Jan 2019 19:15:42 +0100

Hi

> The issue was solved upstream, can we have the package updated with latest upstream release?

I am waiting for libphp-phpmailer to land from DELAYED into unstable to
fix bug 905254. The packaging is prepared.

Paul

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 28 Jan 2019 20:54:08 +0000

Your message dated Mon, 28 Jan 2019 20:51:38 +0000
with message-id <[email-masked]>
and subject line Bug#916814: fixed in cacti 1.2.1+ds1-1
has caused the Debian Bug report #916814,
regarding cacti: [1.2.0 Beta 4] Spike Kill not working (missing file)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
916814: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916814
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: [1.2.0 Beta 4] Spike Kill not working (missing file)
From: "jay.slovak" <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Wed, 19 Dec 2018 00:27:07 +0100

Package: cacti

Dear Maintainer,

-- System Information:

Subject: Bug#916814: fixed in cacti 1.2.1+ds1-1
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 28 Jan 2019 20:51:38 +0000

Source: cacti
Source-Version: 1.2.1+ds1-1

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 27 Jan 2019 21:22:59 +0100
Source: cacti
Binary: cacti
Architecture: source
Version: 1.2.1+ds1-1
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 916814
Changes:
 cacti (1.2.1+ds1-1) unstable; urgency=medium
 .
   * New upstream release 1.2.1
     - spikekiller is now a class (Closes: #916814)
   * Upload to unstable
   * Bump dependency on libphp-phpmailer
   * Bump Standards (no changes)
   * Declare R³: binary-targets (Thanks lintian)
Checksums-Sha1:
 6b196f964595954a134da09897200fba22d4215b 2106 cacti_1.2.1+ds1-1.dsc
 bfa75f5a9e0a824a94cb5590f1abf2df06f2b2b1 12751582 cacti_1.2.1+ds1.orig-docs-source.tar.gz
 2b573e25de6a61f68ff3bfb801a3c1d694d57be3 3692120 cacti_1.2.1+ds1.orig.tar.xz
 7a9f57744769cea7fe1aaa08b7bb9128728bc11d 52196 cacti_1.2.1+ds1-1.debian.tar.xz
Checksums-Sha256:
 51bb4c2a9446c731a3d1ca0fba5cd8cfc92795847477b6cab53335525a9fe72a 2106 cacti_1.2.1+ds1-1.dsc
 59a62389fab7da6ed7bdef7c02cf8bd72a234e13e7e411ee6507b6f91a43af9a 12751582 cacti_1.2.1+ds1.orig-docs-source.tar.gz
 7cd7d5cef034146126bcc43ddb5ce75ca3c83d174f79c1b9d20d92c324063acf 3692120 cacti_1.2.1+ds1.orig.tar.xz
 e93c68d64c2bfee4054e06fd701a75a1d1da790bfcb6938b00ff7ce749ad77d3 52196 cacti_1.2.1+ds1-1.debian.tar.xz
Files:
 d90b404ea31c49d005c8a8b96f8a8515 2106 web optional cacti_1.2.1+ds1-1.dsc
 c954bccf52d164da4ac71bce0227921c 12751582 web optional cacti_1.2.1+ds1.orig-docs-source.tar.gz
 705ffbf212664040e3140268ed9ffed6 3692120 web optional cacti_1.2.1+ds1.orig.tar.xz
 eb29a52e472fd7b4d008c75aa4992a5e 52196 web optional cacti_1.2.1+ds1-1.debian.tar.xz