Subject: [Pkg-cacti-maint] Bug#1028141: cacti: new install shows error 500 on browser

From: Bruno Meirelles <[email-masked]>
Date: Sat, 7 Jan 2023 14:43:08 -0300

Subject: cacti: new install shows error 500 on browser
Package: cacti
Version: 1.2.23+ds1-1
Severity: normal

Dear Maintainer,

I'm trying to install on debian bookworm
I'm installing using APT
the browser shows error 500
my apache is 2.4.54 and my php is 8.1.12

this appears in the apache log:

[Sat Jan 07 14:07:12.322217 2023] [php:error] [pid 55502] [client 
192.168.254.100:57408] PHP Fatal error: Uncaught Error: Class 
"PhpMyAdmin\MoTranslator\Cache\InMemoryCache" not found in 
/usr/share/php/PhpMyAdmin/MoTranslator/Translator.php:115\nStack 
trace:\n#0 /usr/share/cacti/site/include/global_languages.php(312): 
PhpMyAdmin\MoTranslator\Translator->__construct()\n#1 
/usr/share/cacti/site/include/global_languages.php(254): 
load_gettext_motranslator()\n#2 
/usr/share/cacti/site/include/global.php(527): include_once('...')\n#3 
/usr/share/cacti/site/include/auth.php(27): require_once('...')\n#4 
/usr/share/cacti/site/index.php(25): include('...')\n#5 {main}\n thrown 
in /usr/share/php/PhpMyAdmin/MoTranslator/Translator.php on line 115
[Sat Jan 07 14:07:12.322446 2023] [php:warn] [pid 55502] [client 
192.168.254.100:57408] PHP Warning: Trying to access array offset on 
value of type null in /usr/share/cacti/site/lib/functions.php on line 5866
[Sat Jan 07 14:07:12.326601 2023] [php:warn] [pid 55502] [client 
192.168.254.100:57408] PHP Warning: Trying to access array offset on 
value of type null in /usr/share/cacti/site/lib/functions.php on line 
5931I'm trying to install on debian bookworm

-- System Information:
Debian Release: bookworm/sid
   APT prefers testing
   APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 6.0.0-6-amd64 (SMP w/4 CPU threads; PREEMPT)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=pt_BR.UTF-8, LC_CTYPE=pt_BR.UTF-8 (charmap=UTF-8), 
LANGUAGE=pt_BR:pt:en
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cacti depends on:
ii  dbconfig-common                     2.0.22
ii  dbconfig-mysql                      2.0.22
ii  debconf [debconf-2.0]               1.5.81
ii  fonts-dejavu-core                   2.37-2
ii  fonts-dejavu-extra                  2.37-2
ii  fonts-fork-awesome                  1.2.0+ds1-1
ii  javascript-common                   11+nmu1
ii  libapache2-mod-php                  2:8.1+92+nmu1
ii  libapache2-mod-php8.1 [php-json]    8.1.12-1+b1
ii  libjs-chart.js                      3.9.1+~0.2.1-2
ii  libjs-jquery                        3.6.1+dfsg+~3.5.14-1
ii  libjs-jquery-colorpicker            1.2.20-4
ii  libjs-jquery-cookie                 12-4
ii  libjs-jquery-hotkeys 0~20130707+git2d51e3a9+dfsg-2.1
ii  libjs-jquery-jstree                 3.3.12+dfsg1-2
ii  libjs-jquery-metadata               12-4
ii  libjs-jquery-tablesorter            1:2.31.3+dfsg1-3
ii  libjs-jquery-timepicker             1.6.3-3
ii  libjs-jquery-ui                     1.13.2+dfsg-1
ii  libjs-jquery-ui-theme-smoothness    1.12.1+dfsg-1.1
ii  libjs-jquery-ui-theme-south-street  1.12.1+dfsg-1.1
ii  libjs-jquery-ui-theme-ui-darkness   1.12.1+dfsg-1.1
ii  libjs-jquery-ui-touch-punch 0.0~git20141218.2.4bc0091+dfsg1-4.1
ii  libphp-phpmailer                    6.6.3-1
ii  node-d3                             5.16.0-10
ii  node-ua-parser-js                   0.8.1+ds+~0.7.36-2
ii  perl                                5.36.0-6
pn  php-cli                             <none>
ii  php-gd                              2:8.1+92+nmu1
ii  php-gmp                             2:8.1+92+nmu1
ii  php-json                            2:8.1+92+nmu1
ii  php-ldap                            2:8.1+92+nmu1
ii  php-mbstring                        2:8.1+92+nmu1
ii  php-mysql                           2:8.1+92+nmu1
ii  php-phpmyadmin-motranslator         5.3.0-1
ii  php-phpseclib                       2.0.41-1
ii  php-snmp                            2:8.1+92+nmu1
ii  php-twig                            3.5.0-1
ii  php-xml                             2:8.1+92+nmu1
ii  php8.1-cli [php-json]               8.1.12-1+b1
ii  php8.1-gd [php-gd]                  8.1.12-1+b1
ii  php8.1-gmp [php-gmp]                8.1.12-1+b1
ii  php8.1-ldap [php-ldap]              8.1.12-1+b1
ii  php8.1-mbstring [php-mbstring]      8.1.12-1+b1
ii  php8.1-snmp [php-snmp]              8.1.12-1+b1
ii  php8.1-xml [php-xml]                8.1.12-1+b1
ii  rrdtool                             1.7.2-4+b7
ii  snmp                                5.9.3+dfsg-1+b2
ii  ucf                                 3.0043

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.54-5
ii  default-mysql-server                        1.0.8
ii  iputils-ping                                3:20221126-1
ii  logrotate                                   3.21.0-1
ii  mariadb-server-10.6 [virtual-mysql-server]  1:10.6.11-1

Versions of packages cacti suggests:
pn  cacti-spine  <none>
pn  moreutils    <none>
ii  snmpd        5.9.3+dfsg-1+b2

-- debconf-show failed

---

From: Bruno Meirelles <[email-masked]>
Date: Sat, 7 Jan 2023 15:26:02 -0300

I tested it in an English language virtual machine browser and it works. 
the error appears on a Brazilian Portuguese computer. computer with 
other languages should give error too

---

From: Paul Gevers <[email-masked]>
Date: Thu, 12 Jan 2023 15:25:58 +0100

Dear php-phpmyadmin-motranslator maintainers,

I recently received bug report 1028141 against my package cacti, see 
below. cacti is depending on php-phpmyadmin-motranslator to enable 
translations of the website and the reporter triggers (via his browser 
settings) the site to activate it. However, that currently is severely 
broken in unstable and testing. (I created a test case, and that passes 
on stable, so I think this is a regression). Upstream has been quite 
helpful (see https://github.com/Cacti/cacti/issues/5147), but this isn't 
their problem, because they vendor a different platform for 
translations. The problem is either in php-phpmyadmin-motranslator or in 
the way the Debian cacti package uses it. Can you help me figure out how 
to fix this?

> 5931I'm trying to install on debian bookworm

Paul

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Thu, 19 Jan 2023 10:39:03 +0000

Your message dated Thu, 19 Jan 2023 10:34:35 +0000
with message-id <[email-masked]>
and subject line Bug#1028141: fixed in cacti 1.2.23+ds1-2
has caused the Debian Bug report #1028141,
regarding cacti: new install shows error 500 on browser
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
1028141: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1028141
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: new install shows error 500 on browser
From: Bruno Meirelles <[email-masked]>
To: [email-masked]
Date: Sat, 7 Jan 2023 14:43:08 -0300

Dear Maintainer,

-- System Information:

-- debconf-show failed

Subject: Bug#1028141: fixed in cacti 1.2.23+ds1-2
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Thu, 19 Jan 2023 10:34:35 +0000

Source: cacti
Source-Version: 1.2.23+ds1-2
Done: Paul Gevers <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Thu, 19 Jan 2023 10:30:29 +0100
Source: cacti
Architecture: source
Version: 1.2.23+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Closes: 1028141 1028764
Changes:
 cacti (1.2.23+ds1-2) unstable; urgency=medium
 .
   * d/rules: fix for new 'file' behavior (Closes: #1028764)
   * Adapt for changes in php-phpmyadmin-motranslator (Closes: #1028141)
   * d/rules: don't compress CHANGELOG symlink
   * tests: several improvement + re-add my own old check-all-pages
Checksums-Sha1:
 c899490dcfe791e43eaf45e271a7b3010ed4b3f5 2239 cacti_1.2.23+ds1-2.dsc
 78a80966aeb6a0bba6d01a17a48e3c9f9eba1c73 59744 cacti_1.2.23+ds1-2.debian.tar.xz
Checksums-Sha256:
 171c174043d54ab5a919be28759201133e4e10648933408dd03435a7e3f46031 2239 cacti_1.2.23+ds1-2.dsc
 1d6a8c1e709a988b7ddbaaff7effcaab47a77afc052f46b62094f947ebff277e 59744 cacti_1.2.23+ds1-2.debian.tar.xz
Files:
 7138b354efe00651e97de1b5db9e7704 2239 web optional cacti_1.2.23+ds1-2.dsc
 bcbe43d723e813e9b35a0d07cb192394 59744 web optional cacti_1.2.23+ds1-2.debian.tar.xz