Subject: [Pkg-cacti-maint] Bug#882356: cacti: fails to install properly

From: Paul Gevers <[email-masked]>
Date: Tue, 21 Nov 2017 20:02:38 +0100

Package: cacti
Version: 1.1.28+ds1-1
Severity: serious
Tags: upstream
Justification: fails to install

cacti 1.1.28+ds-1 fails to install without errors as can be seen in the
autopkgtest¹:
populating database via sql...  error encountered populating database:
mysql said: ERROR 1227 (42000) at line 6: Access denied; you need (at least one of) the SUPER privilege(s) for this operation

I believe the issue is that Version 1.1.28 of cacti upstream includes a commit²
that adds the following sql command to the generation script:
SET GLOBAL sql_mode = 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION';

Let's block migration until the solution has been found.

Paul

¹ https://ci.debian.net/data/autopkgtest/unstable/amd64/c/cacti/20171121_034951/log.gz
² https://github.com/Cacti/cacti/commit/bf6f5c3a71b7a31d0224136dd4d60ee79928bf1f

- -- System Information:
Debian Release: buster/sid
  APT prefers testing-debug
  APT policy: (500, 'testing-debug'), (500, 'testing'), (200, 'testing'), (50, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.13.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cacti depends on:
ii  dbconfig-common                           2.0.9
ii  dbconfig-mysql                            2.0.9
ii  debconf [debconf-2.0]                     1.5.65
ii  fonts-dejavu-core                         2.37-1
ii  fonts-dejavu-extra                        2.37-1
ii  fonts-font-awesome                        4.7.0~dfsg-3
ii  javascript-common                         11
ii  libapache2-mod-php                        1:7.0+56
ii  libapache2-mod-php7.0 [libapache2-mod-ph  7.0.25-1
ii  libjs-c3                                  0.4.11+dfsg-2
ii  libjs-chartjs                             1.0.2-1
ii  libjs-d3                                  3.5.17-2
ii  libjs-jquery                              3.2.1-1
ii  libjs-jquery-colorpicker                  1.2.13-2
ii  libjs-jquery-cookie                       12-1
ii  libjs-jquery-hotkeys                      0~20130707+git2d51e3a9+dfsg-2
ii  libjs-jquery-jstree                       3.3.4+dfsg1-2
ii  libjs-jquery-metadata                     12-1
ii  libjs-jquery-tablesorter                  1:2.29.0+dfsg1-1
ii  libjs-jquery-timepicker                   1.2-1
ii  libjs-jquery-ui                           1.12.1+dfsg-5
ii  libjs-jquery-ui-theme-smoothness          1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-south-street        1.12.1+dfsg-1
ii  libjs-jquery-ui-theme-ui-darkness         1.12.1+dfsg-1
ii  libjs-jquery-ui-touch-punch               0.0~git20141218.2.4bc0091+dfsg1-1
ii  libphp-phpmailer                          5.2.14+dfsg-2.3
ii  perl                                      5.26.1-2
ii  php-cli                                   1:7.0+56
ii  php-gd                                    1:7.0+56
ii  php-json                                  1:7.0+56
ii  php-ldap                                  1:7.0+56
ii  php-mbstring                              1:7.0+56
ii  php-mysql                                 1:7.0+56
ii  php-php-gettext                           1.0.12-0.1
ii  php-phpseclib                             2.0.7-1
ii  php-snmp                                  1:7.0+56
ii  php-twig                                  1.24.0-2
ii  php-xml                                   1:7.0+56
ii  php7.0-cli [php-cli]                      7.0.25-1
ii  php7.0-gd [php-gd]                        7.0.25-1
ii  php7.0-json [php-json]                    7.0.25-1
ii  php7.0-ldap [php-ldap]                    7.0.25-1
ii  php7.0-mbstring [php-mbstring]            7.0.25-1
ii  php7.0-mysql [php-mysqlnd]                7.0.25-1
ii  php7.0-snmp [php-snmp]                    7.0.25-1
ii  php7.0-xml [php-xml]                      7.0.25-1
ii  rrdtool                                   1.6.0-1+b4
ii  snmp                                      5.7.3+dfsg-1.7+b2
ii  ucf                                       3.0036

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.29-1
ii  iputils-ping                                3:20161105-1
ii  logrotate                                   3.11.0-0.1
ii  mariadb-server-10.1 [virtual-mysql-server]  10.1.26-1
ii  php-gmp                                     1:7.0+56
ii  php7.0-gmp [php-gmp]                        7.0.25-1

Versions of packages cacti suggests:
pn  cacti-spine  <none>
ii  moreutils    0.60-1
ii  snmpd        5.7.3+dfsg-1.7+b2

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 24 Nov 2017 10:21:10 +0000

Your message dated Fri, 24 Nov 2017 10:19:36 +0000
with message-id <[email-masked]>
and subject line Bug#882356: fixed in cacti 1.1.28+ds1-2
has caused the Debian Bug report #882356,
regarding cacti: fails to install properly
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
882356: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=882356
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: fails to install properly
From: Paul Gevers <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Tue, 21 Nov 2017 20:02:38 +0100

Package: cacti
Version: 1.1.28+ds1-1
Severity: serious
Tags: upstream

Paul

- -- System Information:

Subject: Bug#882356: fixed in cacti 1.1.28+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Fri, 24 Nov 2017 10:19:36 +0000

Source: cacti
Source-Version: 1.1.28+ds1-2

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Fri, 24 Nov 2017 11:07:11 +0100
Source: cacti
Binary: cacti
Architecture: source
Version: 1.1.28+ds1-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 882356
Changes:
 cacti (1.1.28+ds1-2) unstable; urgency=medium
 .
   * Add remove-global-mysql-command.patch (Closes: #882356)
Checksums-Sha1:
 1f097672c584f0823de3800be07704162f72d3a3 2134 cacti_1.1.28+ds1-2.dsc
 1580e7f12846346fd29ac176b3414255bca054bd 51336 cacti_1.1.28+ds1-2.debian.tar.xz
Checksums-Sha256:
 968b630164b08f5ad7c934f445dea44b2f89497c8b1dd7160d4df1bb83614a2e 2134 cacti_1.1.28+ds1-2.dsc
 4b44b65bb776e6d65be091f8b32fff7bcccd9fc3a4593da9f8a285aa05b1a133 51336 cacti_1.1.28+ds1-2.debian.tar.xz
Files:
 04aa0fd8089a74c16587ea6eae38562b 2134 web optional cacti_1.1.28+ds1-2.dsc
 4b5586a41c957190d60a6129d1f8bac7 51336 web optional cacti_1.1.28+ds1-2.debian.tar.xz