Subject: [Pkg-cacti-maint] Bug#720517: cacti: Owner/group reset on upgrade

From: Romain Coltel <[email-masked]>
Date: Fri, 23 Aug 2013 00:07:01 +0200

Package: cacti
Version: 0.8.8a+dfsg-5+deb7u1
Severity: normal

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these lines ***

The recent DSA about cacti arose a problem of owner/group being reset to
the defaults (root/www-data). My configuration (using PHP-FPM with a
specific group for cacti) needs /etc/cacti/debian.php to be
group-assigned as "cacti" and not the default "www-data", but after
upgrading, I found the group to be "www-data" again.
This bug has already been filed as 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=309194 in the past.

In the same idea, the directory /var/log/cacti/ also has its owner/group
being reset even if cacti has to write in there.

When upgrading, could it be possible not to change the owner/group?

Thanks,
Romain

-- System Information:
Debian Release: 7.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.8.13-xxxx-grs-ipv6-64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.49
ii  libapache2-mod-fcgid                     1:2.3.6-1.2
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.31+dfsg-0+wheezy1
ii  perl                                     5.14.2-21
ii  php5-cgi                                 5.4.4-14+deb7u3
ii  php5-cli                                 5.4.4-14+deb7u3
ii  php5-mysql                               5.4.4-14+deb7u3
ii  php5-snmp                                5.4.4-14+deb7u3
ii  rrdtool                                  1.4.7-2
ii  snmp                                     5.4.3~dfsg-2.7
ii  ucf                                      3.0025+nmu3

Versions of packages cacti recommends:
ii  apache2                      2.2.22-13
ii  apache2-mpm-prefork [httpd]  2.2.22-13
ii  iputils-ping                 3:20101006-1+b1
ii  libjs-jquery                 1.7.2+dfsg-1
ii  libjs-jquery-cookie          6-1
ii  logrotate                    3.8.1-4
ii  mysql-server                 5.5.31+dfsg-0+wheezy1
ii  nginx                        1.2.1-2.2+wheezy1
ii  nginx-full [nginx]           1.2.1-2.2+wheezy1

Versions of packages cacti suggests:
pn  moreutils  <none>
pn  php5-ldap  <none>

-- Configuration Files:
/etc/cron.d/cacti changed [not included]
/etc/logrotate.d/cacti changed [not included]

-- debconf information excluded

---

From: Paul Gevers <[email-masked]>
Date: Sat, 24 Aug 2013 20:12:00 +0200

Control: clone -1 -2
Control: close -2 0.8.8a+dfsg-6
Control: retitle -2 cacti must not change ownership of /var/log/cacti
Control: reassign -1 dbconfig-common 1.8.47+nmu1
Control: retitle -1 dbconfig-common must not change ownership of files
Control: severity -1 serious
Control: severity -2 serious

> upgrading, I found the group to be "www-data" again.

The /etc/cacti/debian.php file is managed by dbconfig-common, so
reassigning there.

> being reset even if cacti has to write in there.

This has been fixed in version 0.8.8a+dfsg-6.

> When upgrading, could it be possible not to change the owner/group?

It MUST NOT change the settings according to the debian policy 10.7.3,
so this should not have been a request, but an order ;).

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 24 Aug 2013 18:15:18 +0000

Processing control commands:

> clone -1 -2
Bug #720517 [cacti] cacti: Owner/group reset on upgrade
Bug 720517 cloned as bug 720715
> close -2 0.8.8a+dfsg-6
Bug #720715 [cacti] cacti: Owner/group reset on upgrade
Marked as fixed in versions cacti/0.8.8a+dfsg-6.
Bug #720715 [cacti] cacti: Owner/group reset on upgrade
Marked Bug as done
> retitle -2 cacti must not change ownership of /var/log/cacti
Bug #720715 {Done: Paul Gevers <[email-masked]>} [cacti] cacti: Owner/group reset on upgrade
Changed Bug title to 'cacti must not change ownership of /var/log/cacti' from 'cacti: Owner/group reset on upgrade'
> reassign -1 dbconfig-common 1.8.47+nmu1
Bug #720517 [cacti] cacti: Owner/group reset on upgrade
Bug reassigned from package 'cacti' to 'dbconfig-common'.
No longer marked as found in versions cacti/0.8.8a+dfsg-5+deb7u1.
Ignoring request to alter fixed versions of bug #720517 to the same values previously set
Bug #720517 [dbconfig-common] cacti: Owner/group reset on upgrade
Marked as found in versions dbconfig-common/1.8.47+nmu1.
> retitle -1 dbconfig-common must not change ownership of files
Bug #720517 [dbconfig-common] cacti: Owner/group reset on upgrade
Changed Bug title to 'dbconfig-common must not change ownership of files' from 'cacti: Owner/group reset on upgrade'
> severity -1 serious
Bug #720517 [dbconfig-common] dbconfig-common must not change ownership of files
Severity set to 'serious' from 'normal'
> severity -2 serious
Bug #720715 {Done: Paul Gevers <[email-masked]>} [cacti] cacti must not change ownership of /var/log/cacti
Severity set to 'serious' from 'normal'

-- 
720517: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=720517
720715: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=720715
Debian Bug Tracking System
Contact [email-masked] with problems