Subject: [Pkg-cacti-maint] Bug#743727: cacti: Updating cacti to 0.8.8b+dfsg-4 returns error

From: Sebastian Mares <[email-masked]>
Date: Sat, 05 Apr 2014 18:10:20 +0200

Package: cacti
Version: 0.8.8b+dfsg-4
Severity: important

Dear Maintainer,

I attempted to update my cacti installation from 0.8.8b+dfsg-3 to 0.8.8b+dfsg-4
using apt-get upgrade and the installation failed with the subprocess returning
error code 2 in cacti --configure.

Cheers,
Sebastian

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.13-1-686-pae (SMP w/1 CPU core)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.52
ii  libphp-adodb                             5.15-1
ii  mysql-client                             5.5.35+dfsg-2
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.35+dfsg-2
ii  perl                                     5.18.2-2+b1
ii  php5                                     5.5.10+dfsg-1
ii  php5-cli                                 5.5.10+dfsg-1
ii  php5-mysql                               5.5.10+dfsg-1
ii  php5-snmp                                5.5.10+dfsg-1
ii  rrdtool                                  1.4.7-2.1
ii  snmp                                     5.7.2~dfsg-8.1+b1
ii  ucf                                      3.0027+nmu1

Versions of packages cacti recommends:
ii  iputils-ping         3:20121221-5
ii  libjs-jquery         1.7.2+dfsg-3
ii  libjs-jquery-cookie  9-1
ii  lighttpd [httpd]     1.4.35-1
ii  logrotate            3.8.7-1
ii  mysql-server         5.5.35+dfsg-2

Versions of packages cacti suggests:
pn  moreutils  <none>
pn  php5-ldap  <none>

-- debconf information:
  cacti/internal/skip-preseed: false
  cacti/passwords-do-not-match:
  cacti/dbconfig-remove:
  cacti/remove-error: abort
  cacti/db/dbname: cacti
  cacti/mysql/admin-user: root
  cacti/missing-db-package-error: abort
  cacti/dbconfig-reinstall: false
* cacti/webserver: lighttpd
  cacti/remote/host:
  cacti/remote/newhost:
  cacti/mysql/method: unix socket
  cacti/install-error: abort
  cacti/internal/reconfiguring: false
  cacti/upgrade-backup: true
  cacti/database-type: mysql
  cacti/purge: false
* cacti/dbconfig-install: true
  cacti/remote/port:
  cacti/db/app-user: cacti
  cacti/dbconfig-upgrade: true
  cacti/upgrade-error: abort

---

From: Paul Gevers <[email-masked]>
Date: Sat, 05 Apr 2014 20:23:23 +0200

Control: tags -1 moreinfo

> error code 2 in cacti --configure.

Hi Sebastian,

Thanks for reporting. However, I didn't change anything to the
configuration of cacti. Can you please try to find more log information.
Just your remark above is very limited to go on.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 05 Apr 2014 18:27:06 +0000

Processing control commands:

> tags -1 moreinfo
Bug #743727 [cacti] cacti: Updating cacti to 0.8.8b+dfsg-4 returns error
Added tag(s) moreinfo.

-- 
743727: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743727
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Sebastian Mares <[email-masked]>
Date: Sun, 6 Apr 2014 00:54:39 +0200

Hi! Not sure where to look as dpkg.log doesn't have more than

Setting up cacti (0.8.8b+dfsg-4) ...
dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf
dbconfig-common: flushing administrative password
Running cli/upgrade_database.php as part of package update...
Your Cacti is already up to date.
already enabled
Run /etc/init.d/lighttpd force-reload to enable changes
dpkg: error processing package cacti (--configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
cacti
E: Sub-process /usr/bin/dpkg returned an error code (1)

:(

Cheers
Sebastian

---

From: Paul Gevers <[email-masked]>
Date: Sun, 06 Apr 2014 09:25:12 +0200

Control: tags -1 - moreinfo
Control: retitle -1 cacti: possibly erroneous postinst for lighttpd

On 06-04-14 00:54, Sebastian Mares wrote:> Hi! Not sure where to look as
dpkg.log doesn't have more than
> Your Cacti is already up to date.

Success ^^^^
Problem vvvv

> E: Sub-process /usr/bin/dpkg returned an error code (1)

Well, this is definitely more than the previous message.

At least is tells us what all succeeded...

This looks like a bug in the lighttpd configuration, which may be
related to the changes in 0.8.8b+dfsg-3. I will investigate. Would you
be willing to share your /etc/lighttpd/lighttpd.conf and the the
contents of /etc/lighttpd/conf-enabled? Did you make any changes to
those? Was cacti running successfully before the upgrade?

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 06 Apr 2014 07:33:13 +0000

Processing control commands:

> tags -1 - moreinfo
Removed tag(s) moreinfo.
> retitle -1 cacti: possibly erroneous postinst for lighttpd
Bug #743727 [cacti] cacti: Updating cacti to 0.8.8b+dfsg-4 returns error
Changed Bug title to 'cacti: possibly erroneous postinst for lighttpd' from 'cacti: Updating cacti to 0.8.8b+dfsg-4 returns error'

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 06 Apr 2014 13:39:12 +0000

Processing control commands:

> tags -1 confirmed
Bug #743727 [cacti] cacti: possibly erroneous postinst for lighttpd
Added tag(s) confirmed.
> tags -1 pending
Bug #743727 [cacti] cacti: possibly erroneous postinst for lighttpd
Added tag(s) pending.
> severity -1 serious
Bug #743727 [cacti] cacti: possibly erroneous postinst for lighttpd
Severity set to 'serious' from 'important'

---

From: Paul Gevers <[email-masked]>
Date: Sun, 06 Apr 2014 15:34:24 +0200

Control: tags -1 confirmed
Control: tags -1 pending
Control: severity -1 serious

I just reproduced the issue. It is so trivial that I should have caught
that by mere testing with lighttpd instead of only apache2.

lighty-enable-mod returns non-zero if the module is already enabled,
triggering dpkg/apt to believe the configuration failed.

Raising the severity to prevent the package to migrate to jessie where
it might cause more people to run into this bug. Working on the proper
solution and will upload soon.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 06 Apr 2014 18:21:13 +0000

Your message dated Sun, 06 Apr 2014 18:18:31 +0000
with message-id <[email-masked]>
and subject line Bug#743727: fixed in cacti 0.8.8b+dfsg-5
has caused the Debian Bug report #743727,
regarding cacti: possibly erroneous postinst for lighttpd
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti: Updating cacti to 0.8.8b+dfsg-4 returns error
From: Sebastian Mares <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 05 Apr 2014 18:10:20 +0200

Package: cacti
Version: 0.8.8b+dfsg-4
Severity: important

Dear Maintainer,

Cheers,
Sebastian

-- System Information:

-- debconf information:

Subject: Bug#743727: fixed in cacti 0.8.8b+dfsg-5
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sun, 06 Apr 2014 18:18:31 +0000

Source: cacti
Source-Version: 0.8.8b+dfsg-5

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 06 Apr 2014 19:59:12 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8b+dfsg-5
Distribution: unstable
Urgency: high
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - web interface for graphing of monitoring systems
Closes: 743727
Changes: 
 cacti (0.8.8b+dfsg-5) unstable; urgency=high
 .
   * Fix postinst for lighttpd setups which fail on update due to
     lighty-enable-mod exiting with non-zero if config is already loaded
     (Closes: 743727)
Checksums-Sha1: 
 bcab2653f476430bd7b56934f8d49e4b53103576 1647 cacti_0.8.8b+dfsg-5.dsc
 0a804299b09b331ad1df7d2e16b8f7bb91c433ef 96340 cacti_0.8.8b+dfsg-5.debian.tar.xz
 5bd2802abebce8baac57cb7f3acbca09321f6970 1886550 cacti_0.8.8b+dfsg-5_all.deb
Checksums-Sha256: 
 cafc453367a0e172495652aaa7e75725e8217bf829119c172c46a3f1a4764654 1647 cacti_0.8.8b+dfsg-5.dsc
 48d8a3b51d303ba92f98078a92313cd6b68377aee8be1b605f48a01394aff534 96340 cacti_0.8.8b+dfsg-5.debian.tar.xz
 0974973ceb4e991e3a46bad2a0d5fd28c024957d9a372d4261a09fa4be9edc51 1886550 cacti_0.8.8b+dfsg-5_all.deb
Files: 
 5e24e713f2f6e56ee3ead0287c372103 1647 web extra cacti_0.8.8b+dfsg-5.dsc
 10f0ba6e9dec2bd38b0709a02dd128f4 96340 web extra cacti_0.8.8b+dfsg-5.debian.tar.xz
 3fddd2097072a9b98dc7fa35b4ce5613 1886550 web extra cacti_0.8.8b+dfsg-5_all.deb