Subject: [Pkg-cacti-maint] Bug#679980: cacti: license issue in include/treeview

From: Paul Gevers <[email-masked]>
Date: Mon, 02 Jul 2012 21:33:04 +0200

Package: cacti
Version: 0.8.4-1
Justification: Policy 2.2.1
Severity: serious

I spotted a license issue in cacti. The files in question are in the
include/treeview folder, i.e. ftiens4.js and ftiens4_export.js, and I am
sure the same issue is related to the icons in that folder. The
license for these files is not included in the project. A link [0] to
the web-site of the treeview project is provided in the headers of these
files. On the web-site a link can be found to what I believe are the two
possible licenses for this source.  When asked, debian-legal recommended
[1] notifying (cacti) upstream (I did that over one month ago [2]) and
one of three steps:

1) if cacti may work without the non-free files (possibly with
reduced functionality), those files should be dropped entirely

2) if cacti cannot work without those files, appropriate DFSG-free
and GPL-compatible replacements should be found (or clean-room
developed)

3) Gubusoft should be contacted and persuaded to re-license those
files under GPLv2-compatible terms

ad 3) After waiting for the cacti project to take action here, I asked
the treeview project several days ago to re-license the treeview files,
but I got no response yet, and I don't expect any.

ad 2) I am investigating the possibility to use other javascript source
code projects that have similar functionality, but with a DFSG-free
license. So far this seems hopeful, so I think this is the best solution
possible.

ad 1) The least attractive alternative would be to strip cacti from this
functionality, which works for small cacti sites, but is likely a
serious hit in usability for most large cacti sites.

I propose the following: discuss with the release team to replace cacti
in both stable and testing with a DFSG-free cacti. Either (preferred by
me) with alternative 2, or if that fails or comes too late with
alternative 1.

Paul

[0] http://www.treeview.net/
[1] http://lists.debian.org/debian-legal/2012/05/msg00020.html
[2] http://bugs.cacti.net/view.php?id=2228

---

From: Paul Gevers <[email-masked]>
Date: Tue, 03 Jul 2012 23:59:02 +0200

> [2] http://bugs.cacti.net/view.php?id=2228

Cacti upstream promises this to happen (hopefully this week).

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Wed, 12 Dec 2012 20:51:11 +0000

Your message dated Wed, 12 Dec 2012 20:47:58 +0000
with message-id <[email-masked]>
and subject line Bug#679980: fixed in cacti 0.8.8a+dfsg-1
has caused the Debian Bug report #679980,
regarding cacti: license issue in include/treeview
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
679980: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679980
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: license issue in include/treeview
From: Paul Gevers <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Mon, 02 Jul 2012 21:33:04 +0200

Package: cacti
Version: 0.8.4-1

Paul

Subject: Bug#679980: fixed in cacti 0.8.8a+dfsg-1
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Wed, 12 Dec 2012 20:47:58 +0000

Source: cacti
Source-Version: 0.8.8a+dfsg-1

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Mon, 10 Dec 2012 22:48:48 +0100
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8a+dfsg-1
Distribution: experimental
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - web interface for graphing of monitoring systems
Closes: 679980 681558
Changes: 
 cacti (0.8.8a+dfsg-1) experimental; urgency=low
 .
   * Removed non-dfsg-free treeview code from the upstream source (Closes:
     #679980)
   * Add jquery.jstree.js and four jstree theme files to the package to replace
     the treeview functionality
   * Update d/copyright to reflect above changes
   * Add patches to use the jstree code
     - replace_treeview_by_jquery.jstree.patch
     - use_jquery_for_debian.patch
   * Add libjs-jquery and libjs-jquery-cookie to recommends as they are needed by
     jstree.
   * Remove the logic to install plugins in /usr/local/share/cacti/plugins as the
     implementation of chdir in php resolves symlinks (Closes: #681558).
     - Update README.Debian and add NEWS.Debian and README.Plugins
     - Update d/cacti.links and d/cacti.install
   * Update my e-mail address to [email-masked]
Checksums-Sha1: 
 07304fb4232540a9c89597e4c85b614f77bcba93 1655 cacti_0.8.8a+dfsg-1.dsc
 4345484327a663043f2c25cc14da763ed0b10bce 2262792 cacti_0.8.8a+dfsg.orig.tar.gz
 b396ff92e4f9899ba7527c3b832a2081df9510d2 103912 cacti_0.8.8a+dfsg-1.debian.tar.gz
 677ea65d1e3e5295c7532037b9f4add7305d4a4e 2140206 cacti_0.8.8a+dfsg-1_all.deb
Checksums-Sha256: 
 aa0973e9eac2df20806c37a02beb1e4a9c6b0e6bd1640879c12fd88ea73c7355 1655 cacti_0.8.8a+dfsg-1.dsc
 18575e99b5be11edb150a5a20a8a63f8cbf50be0adb0c4892db3be68ca1fcf74 2262792 cacti_0.8.8a+dfsg.orig.tar.gz
 ffccba8f93e39a64415519abcb5c6b6dbf64351e11b29a67d6dc8147c87e4179 103912 cacti_0.8.8a+dfsg-1.debian.tar.gz
 3f34a88a99612d7564b39ae84890e5ba0595a764b0c5268856225e357d567a58 2140206 cacti_0.8.8a+dfsg-1_all.deb
Files: 
 d8d96b7987bde9ded720b6bb85dfdfae 1655 web extra cacti_0.8.8a+dfsg-1.dsc
 45ef51a85ee91bf9212478cc4af1c5de 2262792 web extra cacti_0.8.8a+dfsg.orig.tar.gz
 6ff80e36a17c6b5244c25164fd731e33 103912 web extra cacti_0.8.8a+dfsg-1.debian.tar.gz
 0bcc3519239ac5fbda9bbaecd7e8e829 2140206 web extra cacti_0.8.8a+dfsg-1_all.deb