Subject: [Pkg-cacti-maint] Bug#744067: cacti: Cacti should support php5-mysqlnd as alternative to php5-mysql

From: Sebastian Mares <[email-masked]>
Date: Wed, 09 Apr 2014 19:38:01 +0200

Package: cacti
Version: 0.8.8b+dfsg-5
Severity: wishlist

Dear Maintainer,

currently, cacti insists on php5-mysql to be installed even
if the server has php5-mysqlnd.

Would be nice if cacti could make php5-mysqlnd an alternative.

Cheers
Sebastian

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.13-1-686-pae (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.52
ii  libphp-adodb                             5.15-1
ii  mysql-client                             5.5.35+dfsg-2
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.35+dfsg-2
ii  perl                                     5.18.2-2+b1
ii  php5                                     5.5.11+dfsg-2
ii  php5-cli                                 5.5.11+dfsg-2
ii  php5-mysql                               5.5.11+dfsg-2
ii  php5-snmp                                5.5.11+dfsg-2
ii  rrdtool                                  1.4.7-2.1
ii  snmp                                     5.7.2~dfsg-8.1+b1
ii  ucf                                      3.0027+nmu1

Versions of packages cacti recommends:
ii  iputils-ping         3:20121221-5
ii  libjs-jquery         1.7.2+dfsg-3
ii  libjs-jquery-cookie  9-1
ii  lighttpd [httpd]     1.4.35-2
ii  logrotate            3.8.7-1
ii  mysql-server         5.5.35+dfsg-2

Versions of packages cacti suggests:
pn  moreutils  <none>
pn  php5-ldap  <none>

-- debconf information:
  cacti/dbconfig-reinstall: false
  cacti/dbconfig-remove:
  cacti/db/app-user: cacti
  cacti/database-type: mysql
  cacti/missing-db-package-error: abort
  cacti/upgrade-error: abort
  cacti/remove-error: abort
  cacti/remote/newhost:
  cacti/mysql/admin-user: root
  cacti/mysql/method: unix socket
* cacti/webserver: lighttpd
  cacti/purge: false
  cacti/remote/host:
* cacti/dbconfig-install: true
  cacti/internal/skip-preseed: false
  cacti/dbconfig-upgrade: true
  cacti/db/dbname: cacti
  cacti/upgrade-backup: true
  cacti/passwords-do-not-match:
  cacti/remote/port:
  cacti/internal/reconfiguring: false
  cacti/install-error: abort

---

From: [email-masked] (Debian Bug Tracking System)
Date: Wed, 25 Jun 2014 21:36:14 +0000

Your message dated Wed, 25 Jun 2014 21:34:24 +0000
with message-id <[email-masked]>
and subject line Bug#744067: fixed in cacti 0.8.8b+dfsg-6
has caused the Debian Bug report #744067,
regarding cacti: Cacti should support php5-mysqlnd as alternative to php5-mysql
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
744067: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=744067
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: Cacti should support php5-mysqlnd as alternative to php5-mysql
From: Sebastian Mares <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Wed, 09 Apr 2014 19:38:01 +0200

Package: cacti
Version: 0.8.8b+dfsg-5
Severity: wishlist

Dear Maintainer,

Cheers
Sebastian

-- System Information:

-- debconf information:

Subject: Bug#744067: fixed in cacti 0.8.8b+dfsg-6
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Wed, 25 Jun 2014 21:34:24 +0000

Source: cacti
Source-Version: 0.8.8b+dfsg-6

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Wed, 25 Jun 2014 22:33:53 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8b+dfsg-6
Distribution: unstable
Urgency: high
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 742768 744067 752573
Changes:
 cacti (0.8.8b+dfsg-6) unstable; urgency=high
 .
   * Add alternative php5-mysql | php5-mysqlnd (Closes: #744067)
   * Security update (Closes: #742768, #752573)
     - CVE-2014-2327 Cross Site Request Forgery Vulnerability
     - CVE-2014-4002 Cross-Site Scripting Vulnerability
Checksums-Sha1:
 cb0087d5f3770dea819440882c268c754ae0f0e3 1655 cacti_0.8.8b+dfsg-6.dsc
 5a34a582d9c8677518a33234a4ad1ac8024ee61a 103284 cacti_0.8.8b+dfsg-6.debian.tar.xz
 7b62b650d11502daed7091fbd7985634bfd59f54 1892594 cacti_0.8.8b+dfsg-6_all.deb
Checksums-Sha256:
 f72c1022c8497784322e9bb3db94bff0f72ddbe2f38acfbc9f894236741a86d4 1655 cacti_0.8.8b+dfsg-6.dsc
 18433ea70e341eff55c005ff1796018f546fa53ed1159e2cd69ec1c9a96168ec 103284 cacti_0.8.8b+dfsg-6.debian.tar.xz
 ab5ab0a70f308814acb5f2fdb3b32e398e47567e005065d9fd3d60748470a7aa 1892594 cacti_0.8.8b+dfsg-6_all.deb
Files:
 0aa31425f144e81ad972e6ec0aff7d9f 1892594 web extra cacti_0.8.8b+dfsg-6_all.deb
 6de034dfcb0d7ecf5e6978bf61d9b45c 1655 web extra cacti_0.8.8b+dfsg-6.dsc
 c06386ec36c90e07234da262dc2136e4 103284 web extra cacti_0.8.8b+dfsg-6.debian.tar.xz