Subject: [Pkg-cacti-maint] Bug#710728: cacti-spine: postinst uses /usr/share/doc content (Policy 12.3): /usr/share/doc/cacti-spine/spine.conf.dbconfig

From: Andreas Beckmann <[email-masked]>
Date: Sat, 01 Jun 2013 23:40:23 +0200

Package: cacti-spine
Version: 0.8.8a-2
Severity: serious
User: [email-masked]
Usertags: piuparts

Hi,

a test with piuparts revealed that your package uses files from
/usr/share/doc in its maintainer scripts which is a violation of
Policy 12.3: "Packages must not require the existence of any files in
/usr/share/doc/ in order to function."
http://www.debian.org/doc/debian-policy/ch-docs.html#s12.3

These files must be moved to /usr/share/$PACKAGE and may be symlinked
from /usr/share/doc/$PACKAGE.

This piuparts test prevents the installation of (most) files into
/usr/share/doc with 'dpkg --path-exclude=...'.

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package cacti-spine.
  (Reading database ... 10783 files and directories currently installed.)
  Unpacking cacti-spine (from .../cacti-spine_0.8.8a-2_amd64.deb) ...
  Setting up cacti-spine (0.8.8a-2) ...
  error: template infile /usr/share/doc/cacti-spine/spine.conf.dbconfig does not exist
  dpkg: error processing cacti-spine (--configure):
   subprocess installed post-installation script returned error exit status 1
  Errors were encountered while processing:
   cacti-spine

Cheers,

Andreas

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 02 Jun 2013 06:39:05 +0000

Processing control commands:

> tag -1 confirmed
Bug #710728 [cacti-spine] cacti-spine: postinst uses /usr/share/doc content (Policy 12.3): /usr/share/doc/cacti-spine/spine.conf.dbconfig
Added tag(s) confirmed.

-- 
710728: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=710728
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Paul Gevers <[email-masked]>
Date: Sun, 02 Jun 2013 08:36:57 +0200

Control: tag -1 confirmed

This very same bug was indeed also in cacti, where I fixed it in one of
the latest uploads. We should apply the same logic in cacti-spine as well.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 02 Jun 2013 18:21:38 +0000

Your message dated Sun, 02 Jun 2013 18:17:58 +0000
with message-id <[email-masked]>
and subject line Bug#710728: fixed in cacti-spine 0.8.8a-3
has caused the Debian Bug report #710728,
regarding cacti-spine: postinst uses /usr/share/doc content (Policy 12.3): /usr/share/doc/cacti-spine/spine.conf.dbconfig
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti-spine: postinst uses /usr/share/doc content (Policy 12.3): /usr/share/doc/cacti-spine/spine.conf.dbconfig
From: Andreas Beckmann <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sat, 01 Jun 2013 23:40:23 +0200

Package: cacti-spine
Version: 0.8.8a-2
Severity: serious

Hi,

Cheers,

Andreas

Subject: Bug#710728: fixed in cacti-spine 0.8.8a-3
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sun, 02 Jun 2013 18:17:58 +0000

Source: cacti-spine
Source-Version: 0.8.8a-3

We believe that the bug you reported is fixed in the latest version of
cacti-spine, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti-spine package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 02 Jun 2013 19:13:43 +0200
Source: cacti-spine
Binary: cacti-spine
Architecture: source amd64
Version: 0.8.8a-3
Distribution: unstable
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti-spine - Multi-Threading poller for cacti
Closes: 710728
Changes: 
 cacti-spine (0.8.8a-3) unstable; urgency=low
 .
   * Change location of spine.conf.* files as Policy 12.3 allows doc to be
     removed (Closes: #710728)
   * Update standards (no changes needed) and update vcs-browser to be canonical
     (thanks lintian)
   * Drop override_dh_installchangelogs as dh DTRT without it
   * Let manpage be installed by cacti-spine.manpages file instead of override in
     rules
   * Remove unnecessary dependencies by linking with --as-needed
   * Remove build dependency on libsnmp9-dev which has not been seen since etch
Checksums-Sha1: 
 1f085bf1308c4d8f22ea4b06dbff7e5c4d3e8ec2 1728 cacti-spine_0.8.8a-3.dsc
 3eecf2d9a0dbbd64f617d15813c2e0f51dc3ec27 17168 cacti-spine_0.8.8a-3.debian.tar.gz
 202d60c303b7dbf88bea497d73c18157bd5a08ad 64888 cacti-spine_0.8.8a-3_amd64.deb
Checksums-Sha256: 
 9886cc319bb7972218a6ddce4a9b55b3078fb2c2883fa02e6c50162ed0ffe9a2 1728 cacti-spine_0.8.8a-3.dsc
 517db9d7cf6e9f93cde70350639a67cc7cc6ada4e6fb322fb57186d004e416ce 17168 cacti-spine_0.8.8a-3.debian.tar.gz
 ca9d8a7f6b22b24a1dd5f0a3948cf3a6c44942a8575cc787b43b55eb68144361 64888 cacti-spine_0.8.8a-3_amd64.deb
Files: 
 00de029774c0878afed9d0ab4d53b512 1728 web extra cacti-spine_0.8.8a-3.dsc
 439a482ad265f3a2a9c37f02ce68fc52 17168 web extra cacti-spine_0.8.8a-3.debian.tar.gz
 b57c983f575e08c5e7f8fd4e815eb019 64888 web extra cacti-spine_0.8.8a-3_amd64.deb