Subject: [Pkg-cacti-maint] Bug#834057: cacti-spine: FTBFS on kfreebsd - missing -lpthread/-pthread?

From: Andreas Beckmann <[email-masked]>
Date: Thu, 11 Aug 2016 18:51:30 +0200

Source: cacti-spine
Version: 0.8.8h-1
Severity: important

Hi,

cacti-spine FTBFS on kfreebsd-any, but older versions built there
successfully:

https://buildd.debian.org/status/fetch.php?pkg=cacti-spine&arch=kfreebsd-i386&ver=0.8.8h-1&stamp=1463617516
https://buildd.debian.org/status/fetch.php?pkg=cacti-spine&arch=kfreebsd-amd64&ver=0.8.8h-1&stamp=1463617329

[...]
/bin/bash ./libtool  --tag=CC   --mode=link x86_64-kfreebsd-gnu-gcc  -I/usr/include/mysql -g -O2 -fstack-protector-strong -Wformat -Werror=format-security  -Wl,-z,relro -Wl,--as-needed -o spine sql.o spine.o util.o snmp.o locks.o poller.o nft_popen.o php.o ping.o keywords.o error.o  -lnetsnmp -lmysqlclient_r
libtool: link: x86_64-kfreebsd-gnu-gcc -I/usr/include/mysql -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z -Wl,relro -Wl,--as-needed -o spine sql.o spine.o util.o snmp.o locks.o poller.o nft_popen.o php.o ping.o keywords.o error.o  -lnetsnmp -lmysqlclient_r
/usr/bin/ld: spine.o: undefined reference to symbol 'pthread_create@@GLIBC_2.3'
//lib/x86_64-kfreebsd-gnu/libpthread.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:462: recipe for target 'spine' failed
make[1]: *** [spine] Error 1

If this is not trivially fixable, please request decrufting
of the outdated binary packages.

Andreas

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 21 Oct 2016 10:27:07 +0000

Your message dated Fri, 21 Oct 2016 10:23:13 +0000
with message-id <[email-masked]>
and subject line Bug#834057: fixed in cacti-spine 0.8.8h-2
has caused the Debian Bug report #834057,
regarding cacti-spine: FTBFS on kfreebsd - missing -lpthread/-pthread?
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
834057: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=834057
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti-spine: FTBFS on kfreebsd - missing -lpthread/-pthread?
From: Andreas Beckmann <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Thu, 11 Aug 2016 18:51:30 +0200

Source: cacti-spine
Version: 0.8.8h-1
Severity: important

Hi,

[...]

Andreas

Subject: Bug#834057: fixed in cacti-spine 0.8.8h-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Fri, 21 Oct 2016 10:23:13 +0000

Source: cacti-spine
Source-Version: 0.8.8h-2

We believe that the bug you reported is fixed in the latest version of
cacti-spine, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti-spine package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Fri, 21 Oct 2016 09:31:26 +0200
Source: cacti-spine
Binary: cacti-spine
Architecture: source
Version: 0.8.8h-2
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti-spine - Multi-Threading poller for cacti
Closes: 825076 834057 841312
Changes:
 cacti-spine (0.8.8h-2) unstable; urgency=medium
 .
   * Link against libmysqlclient instead of libmysqlclient_r (Closes:
     #825076, #841312)
   * Also use upstream LDFLAGS to prevent FTBFS on kfreebsd (Closes:
     #834057)
   * Add fix_typos.patch to fix a typo found by Lintian
   * Raise compat level to 10
   * Build depend on default-libmysqlclient-dev iso libmysqlclient-dev
   * Add lintian-overrides for no-debconf-templates as we use cactis
     templates
Checksums-Sha1:
 de234f84542dc5b10cff2b2530c27ae3556e10de 1686 cacti-spine_0.8.8h-2.dsc
 3f3b5738dbcffcc4ab75c8fba7cb19041a208cc8 15668 cacti-spine_0.8.8h-2.debian.tar.xz
Checksums-Sha256:
 b13bdd5a6435db1d349376ace7f1f9b16126bce826e5ff05937744c3e3f8395e 1686 cacti-spine_0.8.8h-2.dsc
 18b941fcc58b1bb3e00b54206566d2248a7ce3b5d4bfb32bb1f5240d0490e839 15668 cacti-spine_0.8.8h-2.debian.tar.xz
Files:
 ce8319d400bba4c249f92e8f11372491 1686 web extra cacti-spine_0.8.8h-2.dsc
 5b9405f8cc466019771dc88a0f5bca86 15668 web extra cacti-spine_0.8.8h-2.debian.tar.xz