Subject: [Pkg-cacti-maint] Bug#813422: cacti can't be installed on MariaDB server

From: Paul Gevers <[email-masked]>
Date: Mon, 01 Feb 2016 20:32:28 +0100

Package: cacti
Version: 0.8.8f+ds1-4
Severity: important
Tags: upstream

When we tried to install cacti on MariaDB server, we got on error about a key
being too long. Otto (maintainer of MariaDB package) suggested to move to
InnoDB engine.

Need to discuss with upstream.

- -- System Information:
Debian Release: 8.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable'), (60, 'unstable'), (50, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cacti depends on:
ii  dbconfig-mysql                      2.0.0
ii  debconf [debconf-2.0]               1.5.56
ii  libapache2-mod-php5                 5.6.17+dfsg-0+deb8u1
ii  libjs-jquery                        1.11.3+dfsg-4
ii  libjs-jquery-cookie                 10-1
ii  libjs-jquery-ui                     1.10.1+dfsg-1
ii  libjs-jquery-ui-theme-ui-lightness  1.8.24+dfsg-1
ii  libphp-adodb                        5.15-1
ii  perl                                5.20.2-3+deb8u3
ii  php5                                5.6.17+dfsg-0+deb8u1
ii  php5-cli                            5.6.17+dfsg-0+deb8u1
ii  php5-mysql                          5.6.17+dfsg-0+deb8u1
ii  php5-snmp                           5.6.17+dfsg-0+deb8u1
ii  rrdtool                             1.4.8-1.2
ii  snmp                                5.7.3+dfsg-1
ii  ucf                                 3.0030

Versions of packages cacti recommends:
ii  apache2 [httpd]                          2.4.10-10+deb8u4
ii  iputils-ping                             3:20121221-5+b2
ii  logrotate                                3.8.7-1+b1
ii  mysql-server                             5.5.47-0+deb8u1
ii  mysql-server-5.5 [virtual-mysql-server]  5.5.47-0+deb8u1

Versions of packages cacti suggests:
pn  moreutils  <none>
pn  php5-ldap  <none>

- -- debconf information excluded

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 27 Feb 2016 09:00:05 +0000

Your message dated Sat, 27 Feb 2016 09:57:41 +0100
with message-id <[email-masked]>
and subject line Bug#813422: fixed in cacti 0.8.8g+ds1-1
has caused the Debian Bug report #813422,
regarding cacti can't be installed on MariaDB server
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
813422: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=813422
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti can't be installed on MariaDB server
From: Paul Gevers <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Mon, 01 Feb 2016 20:32:28 +0100

Package: cacti
Version: 0.8.8f+ds1-4
Severity: important
Tags: upstream

- -- System Information:
Debian Release: 8.3

Subject: Bug#813422: fixed in cacti 0.8.8g+ds1-1
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sat, 27 Feb 2016 09:57:41 +0100

Source: cacti
Source-Version: 0.8.8g+ds1-1

I forgot to mention this bug number in the changelog.

But it is fixed.

 cacti (0.8.8g+ds1-1) unstable; urgency=medium
 .
   * New upstream release
     - CVE-2016-2313 (closes: #814353)
     - Drop included patches
   * Update d/copyright with new years
   * Enable installation on MariaDB by forcing the collation to latin1
   * Add mariadb-server to list of recommends
   * Update Vcs-* fields to https