Subject: [Pkg-cacti-maint] Bug#833337: cacti: Import_template.php does not work

From: Tino Mo <[email-masked]>
Date: Wed, 03 Aug 2016 10:56:56 +0200

Package: cacti
Version: 0.8.8b+dfsg-8+deb8u4
Severity: normal
Tags: newcomer

Dear Maintainer,

script /usr/share/cacti/cli/import_template.php does not work. 
Output:"PHP Fatal error:  Call to undefined function import_xml_data() in /usr/share/cacti/cli/import_template.php on line 100"
Problem is in line 34. Existing Patch "07_cli-include-path.patch" in the packet does not intervene. 

-- System Information:
Debian Release: 8.5
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 05 Sep 2016 19:33:11 +0000

Your message dated Mon, 5 Sep 2016 21:29:35 +0200
with message-id <[email-masked]>
and subject line Re: cacti: Import_template.php does not work
has caused the Debian Bug report #833337,
regarding cacti: Import_template.php does not work
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
833337: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833337
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: Import_template.php does not work
From: Tino Mo <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Wed, 03 Aug 2016 10:56:56 +0200

Package: cacti

Dear Maintainer,

-- System Information:
Debian Release: 8.5

Subject: Re: cacti: Import_template.php does not work
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 5 Sep 2016 21:29:35 +0200

Version: 0.8.8d+ds1-1

Thanks for reporting this issue. It was fixed in June 2015.

Paul

cacti (0.8.8d+ds1-1) unstable; urgency=high

  * Upload to unstable
  * New upstream release
    - CVE-2015-2665 Cross-site scripting (XSS) vulnerability in Cacti
      before 0.8.8d allows remote attackers to inject arbitrary web script
      or HTML via unspecified vectors.
    - CVE-2015-4342 SQL Injection and Location header injection from cdef id
    - CVE-2015-4454 SQL injection vulnerability in the
      get_hash_graph_template function in lib/functions.php in Cacti before
      0.8.8d allows remote attackers to execute arbitrary SQL commands via
      the graph_template_id parameter to graph_templates.php.
    - Unassigned CVE VN:JVN#78187936 / TN:JPCERT#98968540 Fixed SQL
injection
  * Remove Sean from the list of uploaders. Thanks for all the fish
    (Closes: #773436)
  * Fix d/p/07_cli-include-path.patch (LP: #1433665)
  * Update debian/patches/fix_php_strict_warning_in_ping.patch for partial
    upstream fix
  * Include the virtual alternative for the recommends on mysql-server
    (Closes: #781982)
  * Upstream dropped unused javascripts, remove them from d/copyright
  * Add patch to have upgrade script mention version 0.8.8d i.s.o. 0.8.8c

 -- Paul Gevers <[email-masked]>  Mon, 22 Jun 2015 19:59:13 +0200