Subject: [Pkg-cacti-maint] Bug#736927: cacti poller take his date informaton from php so it needs corect date.timezone

From: bozhan <[email-masked]>
Date: Tue, 28 Jan 2014 16:16:30 +0200

Package: cacti
Version: 0.8.8b+dfsg-3
Severity: normal

Dear Maintainer,

Cacti poller doesn't draw graphs, in Console -> Utilities -> Technical Support 
 time was 2 hours back (UTC)instead of my time zone(EET), 
because cacti needs date.timezone in /etc/php5/cli/php.ini to be
change to correct time zone.
Is it possible to change timezone in ...cli/php.ini on install?

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.12-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.52
ii  libapache2-mod-php5                      5.5.8+dfsg-2
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.33+dfsg-1
ii  perl                                     5.18.2-2
ii  php5                                     5.5.8+dfsg-2
ii  php5-cli                                 5.5.8+dfsg-2
ii  php5-mysql                               5.5.8+dfsg-2
ii  php5-snmp                                5.5.8+dfsg-2
ii  rrdtool                                  1.4.7-2+b1
ii  snmp                                     5.7.2~dfsg-8.1+b1
ii  ucf                                      3.0027+nmu1

Versions of packages cacti recommends:
ii  apache2              2.4.6-3
ii  apache2-bin [httpd]  2.4.6-3
ii  iputils-ping         3:20121221-4
ii  libjs-jquery         1.7.2+dfsg-3
ii  libjs-jquery-cookie  8-2
ii  logrotate            3.8.6-1
ii  mysql-server         5.5.33+dfsg-1

Versions of packages cacti suggests:
ii  moreutils  0.50
ii  php5-ldap  5.5.8+dfsg-2

-- debconf information:
  cacti/mysql/method: unix socket
  cacti/remote/port:
  cacti/mysql/admin-user: root
* cacti/webserver: apache2
  cacti/install-error: retry
  cacti/db/dbname: cacti
  cacti/remote/host:
  cacti/internal/skip-preseed: false
  cacti/missing-db-package-error: abort
  cacti/purge: false
  cacti/passwords-do-not-match:
  cacti/dbconfig-reinstall: false
  cacti/remote/newhost:
  cacti/database-type: mysql
  cacti/db/app-user: cacti
  cacti/upgrade-error: abort
  cacti/internal/reconfiguring: false
  cacti/remove-error: abort
* cacti/dbconfig-install: true
  cacti/upgrade-backup: true
  cacti/dbconfig-remove:
  cacti/dbconfig-upgrade: true

---

From: Paul Gevers <[email-masked]>
Date: Fri, 07 Feb 2014 15:00:50 +0100

Control: reassign -1 php5
Control: merge -1 730771

> Is it possible to change timezone in ...cli/php.ini on install?

The answer is surely, but definitely not by cacti. Looking at the
changelog of the php5 package version 5.5.8+dfsg-3, this seems like it
was a regression in php5 with respect to fall back. Therefore marking
(hopefully) as a duplicate.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 07 Feb 2014 14:03:17 +0000

Processing control commands:

> reassign -1 php5
Bug #736927 [cacti] cacti poller take his date informaton from php so it needs corect date.timezone
Bug reassigned from package 'cacti' to 'php5'.
No longer marked as found in versions cacti/0.8.8b+dfsg-3.
Ignoring request to alter fixed versions of bug #736927 to the same values previously set
> merge -1 730771
Bug #736927 [php5] cacti poller take his date informaton from php so it needs corect date.timezone
Unable to merge bugs because:
done of #730771 is 'Ondřej Surý <[email-masked]>' not ''
package of #730771 is 'php5-cli' not 'php5'
Failed to merge 736927: Did not alter merged bugs
	Debbugs::Control::set_merged('transcript', 'GLOB(0x3233508)', 'requester', 'Paul Gevers <[email-masked]>', 'request_addr', [email-masked]', 'request_msgid', '<[email-masked]>', 'request_subject', ...) called at /usr/local/lib/site_perl/Debbugs/Control/Service.pm line 538
	eval {...} called at /usr/local/lib/site_perl/Debbugs/Control/Service.pm line 537
	Debbugs::Control::Service::control_line('line', 'merge -1 730771', 'clonebugs', 'HASH(0x324aaf8)', 'limit', 'HASH(0x324ad20)', 'common_control_options', 'ARRAY(0x324adf8)', 'errors', ...) called at /usr/lib/debbugs/process line 1039

-- 
730771: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=730771
736927: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=736927
Debian Bug Tracking System
Contact [email-masked] with problems