Subject: [Pkg-cacti-maint] Bug#702690: cacti: Multilevel tree doesn't work with jstree in 0.8.8a+dfsg-3

From: Jan Zalesak <[email-masked]>
Date: Sun, 10 Mar 2013 09:52:32 +0100

Package: cacti
Version: 0.8.8a+dfsg-3
Severity: normal

Hi,
I've found this bug after upgrading from 0.8.8a to 0.8.8a+dfsg-3. My multilevel tree in cacti stopped work.
All nodes in every tree were in it's root. Only tree itself could be expanded/colapsed.

I've done some research and the problem is probably that JSTree expects every subbranch in nested <ul> but
original cacti code generates only one level <ul> for whole tree.

I modified code in way to work for me. I'm providing diff if someone is interested.

-- System Information:
Debian Release: 7.0
  APT prefers testing-updates
  APT policy: (500, 'testing-updates'), (500, 'testing-proposed-updates'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=cs_CZ.UTF-8, LC_CTYPE=cs_CZ.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.49
ii  libapache2-mod-php5                      5.4.4-14
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.28+dfsg-1
ii  perl                                     5.14.2-19
ii  php5-cli                                 5.4.4-14
ii  php5-mysql                               5.4.4-14
ii  php5-snmp                                5.4.4-14
ii  rrdtool                                  1.4.7-2
ii  snmp                                     5.4.3~dfsg-2.7
ii  ucf                                      3.0025+nmu3

Versions of packages cacti recommends:
ii  apache2-mpm-prefork [httpd]  2.2.22-12
ii  iputils-ping                 3:20101006-1+b1
ii  libjs-jquery                 1.7.2+dfsg-1
ii  libjs-jquery-cookie          6-1
ii  logrotate                    3.8.1-4
ii  mysql-server                 5.5.28+dfsg-1

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 01 Apr 2013 07:36:05 +0000

Your message dated Mon, 01 Apr 2013 07:32:35 +0000
with message-id <[email-masked]>
and subject line Bug#702690: fixed in cacti 0.8.8a+dfsg-4
has caused the Debian Bug report #702690,
regarding cacti: Multilevel tree doesn't work with jstree in 0.8.8a+dfsg-3
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
702690: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702690
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: Multilevel tree doesn't work with jstree in 0.8.8a+dfsg-3
From: Jan Zalesak <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Sun, 10 Mar 2013 09:52:32 +0100

Package: cacti
Version: 0.8.8a+dfsg-3
Severity: normal

Hi,

-- System Information:
Debian Release: 7.0

Subject: Bug#702690: fixed in cacti 0.8.8a+dfsg-4
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Mon, 01 Apr 2013 07:32:35 +0000

Source: cacti
Source-Version: 0.8.8a+dfsg-4

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Mon, 01 Apr 2013 08:03:11 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8a+dfsg-4
Distribution: unstable
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - web interface for graphing of monitoring systems
Closes: 702690
Changes: 
 cacti (0.8.8a+dfsg-4) unstable; urgency=low
 .
   * Improve jquery tree patch to show trees multilevel (Closes: #702690)
Checksums-Sha1: 
 49fc58a3a17f2e9517ec3bf51b4496b7bc957b1e 1655 cacti_0.8.8a+dfsg-4.dsc
 977f6c8dc2c631d7f34617be01b7f77851d0a69e 104289 cacti_0.8.8a+dfsg-4.debian.tar.gz
 49dd4081056d1b9a77a28f637eeb6b91112463f4 2140694 cacti_0.8.8a+dfsg-4_all.deb
Checksums-Sha256: 
 03cb53d0eb0ec7c61967f7e0ef7fcfe617d77f2bec50f62f7b39396fd514f292 1655 cacti_0.8.8a+dfsg-4.dsc
 6086c47be42cfb61b606c1d8ea0bdab9f5bb774afcbe9b13ffba45b20e202971 104289 cacti_0.8.8a+dfsg-4.debian.tar.gz
 7c4df0ef6e6d60d5b9b140680c2166f99cd97afcd2940bc500398cca13a76bce 2140694 cacti_0.8.8a+dfsg-4_all.deb
Files: 
 7ada7fa6425f5684a39d9fbc7ece0020 1655 web extra cacti_0.8.8a+dfsg-4.dsc
 627716c4e1521348ffd9398ca7312aa7 104289 web extra cacti_0.8.8a+dfsg-4.debian.tar.gz
 4c430afcb3d02b1a122d3e08919f9a41 2140694 web extra cacti_0.8.8a+dfsg-4_all.deb

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 18 May 2013 12:36:19 +0000

Your message dated Sat, 18 May 2013 12:32:46 +0000
with message-id <[email-masked]>
and subject line Bug#708001: fixed in cacti 0.8.8a+dfsg-7
has caused the Debian Bug report #708001,
regarding Treeview links fail when libjs-jquery is installed but libjs-jquery-cookie is not
to be marked as done.

-- 
708001: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=708001
Debian Bug Tracking System
Contact [email-masked] with problems

Package: cacti
Version: 0.8.8a+dfsg-3
Severity: normal

Hi,

-- System Information:
Debian Release: 7.0

Subject: Bug#708001: fixed in cacti 0.8.8a+dfsg-7
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Sat, 18 May 2013 12:32:46 +0000

Source: cacti
Source-Version: 0.8.8a+dfsg-7

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Format: 1.8
Date: Sat, 18 May 2013 12:14:02 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8a+dfsg-7
Distribution: unstable
Urgency: low
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - web interface for graphing of monitoring systems
Closes: 707010 708001
Changes: 
 cacti (0.8.8a+dfsg-7) unstable; urgency=low
 .
   * Fix typo in cacti.postrm which prevented proper purging (Closes: #707010)
   * Update use_jquery_for_debian.patch to not load jquery-cookie if it is
     not installed on the system (Closes: #708001)
Checksums-Sha1: 
 3679d0d9093cc81a97d47db818674017b903f1c3 1632 cacti_0.8.8a+dfsg-7.dsc
 88e0f23c233222e54634a93cd625d2972bcc50db 108513 cacti_0.8.8a+dfsg-7.debian.tar.gz
 b7a577a3515a773f762d309f688e3ad2c532daa8 2141346 cacti_0.8.8a+dfsg-7_all.deb
Checksums-Sha256: 
 324dadf0ea26229e3db15c47072773d0392d37a004dfbd6156e0d991100e1dc0 1632 cacti_0.8.8a+dfsg-7.dsc
 add269fa6633f7ac14323abac3525d4ba64f1fbed8a0e1a98c4b32c90253b125 108513 cacti_0.8.8a+dfsg-7.debian.tar.gz
 baa21be7b798c641eff66729f73231c5cdd3b7b72a06eba1b870b38039c5034e 2141346 cacti_0.8.8a+dfsg-7_all.deb
Files: 
 295ae2c12271cc366d4596f4359bfa35 1632 web extra cacti_0.8.8a+dfsg-7.dsc
 ff0d317f71c31e02ec6612501f9515d6 108513 web extra cacti_0.8.8a+dfsg-7.debian.tar.gz
 0318d57975a9563ec44c85f9d3f622b2 2141346 web extra cacti_0.8.8a+dfsg-7_all.deb