Subject: [Pkg-cacti-maint] Bug#755032: cacti: After upgrading cacti to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 did not work anymore

From: Harald Moskon <[email-masked]>
Date: Thu, 17 Jul 2014 03:45:32 +0200

Package: cacti
Version: 0.8.8a+dfsg-5+deb7u3
Severity: normal

Dear Maintainer,

After upgrading the package to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 does not work anymore.
When applying Autom8 rules to Devices you receive the Error "Validation Error", this also happens with Debian Jessie
I fixed the problem by downgrading to 0.8.8a+dfsg-5+deb7u2

Regards

-- System Information:
Debian Release: 7.6
  APT prefers stable
  APT policy: (990, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages cacti depends on:
ii  dbconfig-common                          1.8.47+nmu1
ii  debconf [debconf-2.0]                    1.5.49
ii  libapache2-mod-php5                      5.4.4-14+deb7u12
ii  libphp-adodb                             5.15-1
ii  mysql-client-5.5 [virtual-mysql-client]  5.5.37-0+wheezy1
ii  perl                                     5.14.2-21+deb7u1
ii  php5-cli                                 5.4.4-14+deb7u12
ii  php5-mysql                               5.4.4-14+deb7u12
ii  php5-snmp                                5.4.4-14+deb7u12
ii  rrdtool                                  1.4.7-2
ii  snmp                                     5.4.3~dfsg-2.8
ii  ucf                                      3.0025+nmu3

Versions of packages cacti recommends:
ii  apache2-mpm-prefork [httpd]  2.2.22-13+deb7u2
ii  iputils-ping                 3:20101006-1+b1
ii  libjs-jquery                 1.7.2+dfsg-1
ii  libjs-jquery-cookie          6-1
ii  logrotate                    3.8.1-4
ii  mysql-server                 5.5.37-0+wheezy1

Versions of packages cacti suggests:
pn  moreutils  <none>
ii  php5-ldap  5.4.4-14+deb7u12

-- Configuration Files:
/etc/cron.d/cacti changed:
MAILTO=root
*/1 * * * * www-data php --define suhosin.memory_limit=512M /usr/share/cacti/site/poller.php 2>&1 >/dev/null | if [ -f /usr/bin/ts ] ; then ts ; else tee ; fi >> /var/log/cacti/poller-error.log

-- debconf information:
  cacti/app-password-confirm: (password omitted)
  cacti/mysql/admin-pass: (password omitted)
  cacti/password-confirm: (password omitted)
  cacti/mysql/app-pass: (password omitted)
  cacti/db/app-user: cacti
  cacti/mysql/admin-user: root
  cacti/upgrade-backup: true
  cacti/install-error: abort
* cacti/webserver: apache2
  cacti/internal/reconfiguring: false
  cacti/mysql/method: unix socket
  cacti/remote/host:
  cacti/upgrade-error: abort
  cacti/dbconfig-upgrade: true
  cacti/internal/skip-preseed: false
  cacti/remote/newhost:
  cacti/purge: false
  cacti/passwords-do-not-match:
  cacti/dbconfig-remove:
* cacti/dbconfig-install: true
  cacti/missing-db-package-error: abort
  cacti/database-type: mysql
  cacti/remove-error: abort
  cacti/db/dbname: cacti
  cacti/remote/port:
  cacti/dbconfig-reinstall: false
____________________________________________________________________________

AVL List GmbH, Firmensitz: Graz, Firmenbuchnummer: FN 53507M, Landesgericht fuer ZRS Graz

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 18 Jul 2014 15:21:29 +0000

Processing control commands:

> forwarded -1 http://bugs.cacti.net/view.php?id=2458
Bug #755032 [cacti] cacti: After upgrading cacti to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 did not work anymore
Set Bug forwarded-to-address to 'http://bugs.cacti.net/view.php?id=2458'.
> tags -1 upstream
Bug #755032 [cacti] cacti: After upgrading cacti to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 did not work anymore
Added tag(s) upstream.

-- 
755032: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=755032
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (Debian Bug Tracking System)
Date: Thu, 24 Jul 2014 21:21:17 +0000

Your message dated Thu, 24 Jul 2014 21:19:05 +0000
with message-id <[email-masked]>
and subject line Bug#755032: fixed in cacti 0.8.8b+dfsg-7
has caused the Debian Bug report #755032,
regarding cacti: After upgrading cacti to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 did not work anymore
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti: After upgrading cacti to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 did not work anymore
From: Harald Moskon <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Thu, 17 Jul 2014 03:45:32 +0200

Package: cacti

Dear Maintainer,

Regards

-- System Information:
Debian Release: 7.6
  APT prefers stable

-- Configuration Files:

-- debconf information:

Subject: Bug#755032: fixed in cacti 0.8.8b+dfsg-7
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Thu, 24 Jul 2014 21:19:05 +0000

Source: cacti
Source-Version: 0.8.8b+dfsg-7

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Thu, 24 Jul 2014 21:56:48 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8b+dfsg-7
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 755032
Changes:
 cacti (0.8.8b+dfsg-7) unstable; urgency=medium
 .
   * Fix regression caused by fixing CVE-2014-4002 at least plugin autom8
     was unusable (Closes: #755032)
   * Security update
     - CVE-2014-5025 Cross Site Scripting Vulnerability
     - CVE-2014-5026 Cross Site Scripting Vulnerability
     - CVE-2014-5043 Cross Site Scripting Vulnerability
Checksums-Sha1:
 cfc1302b0841c7dc30a03cab28128d8c1b4c795b 1655 cacti_0.8.8b+dfsg-7.dsc
 c4a855f3385ecffa44c8856cd50463b6f7ef1e28 104704 cacti_0.8.8b+dfsg-7.debian.tar.xz
 513a313d7d56ddef2f166b10e7ea01e5827d27b5 1892614 cacti_0.8.8b+dfsg-7_all.deb
Checksums-Sha256:
 054f83c73407b372323540c3a5cb336ac6384f5730802c95a2d11d860261ead0 1655 cacti_0.8.8b+dfsg-7.dsc
 fead9d371918260b8954be523471f9b29b4836c60891b1d8f4588a40f0a55d94 104704 cacti_0.8.8b+dfsg-7.debian.tar.xz
 fa72a1181a06686460a2526d41aa877e0214057f195f8393e40b31ff7ae3763e 1892614 cacti_0.8.8b+dfsg-7_all.deb
Files:
 5c417950ce3230719deaa0ceb2ee7712 1892614 web extra cacti_0.8.8b+dfsg-7_all.deb
 2bc512ba1d4b915f008639510f53b4ba 1655 web extra cacti_0.8.8b+dfsg-7.dsc
 06fd5721851f228d7ab9002dc8208684 104704 web extra cacti_0.8.8b+dfsg-7.debian.tar.xz

---

From: [email-masked] (Debian Bug Tracking System)
Date: Wed, 20 Aug 2014 19:03:24 +0000

Your message dated Wed, 20 Aug 2014 19:02:04 +0000
with message-id <[email-masked]>
and subject line Bug#755032: fixed in cacti 0.8.8a+dfsg-5+deb7u4
has caused the Debian Bug report #755032,
regarding cacti: After upgrading cacti to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 did not work anymore
to be marked as done.

Package: cacti

Dear Maintainer,

Regards

-- System Information:
Debian Release: 7.6
  APT prefers stable

-- Configuration Files:

-- debconf information:

Subject: Bug#755032: fixed in cacti 0.8.8a+dfsg-5+deb7u4
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Wed, 20 Aug 2014 19:02:04 +0000

Source: cacti
Source-Version: 0.8.8a+dfsg-5+deb7u4

Format: 1.8
Date: Mon, 18 Aug 2014 20:29:12 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.8a+dfsg-5+deb7u4
Distribution: wheezy-security
Urgency: high
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - web interface for graphing of monitoring systems
Closes: 755032
Changes: 
 cacti (0.8.8a+dfsg-5+deb7u4) wheezy-security; urgency=high
 .
   * Fix regression caused by fixing CVE-2014-4002 at least plugin autom8
     was unusable (Closes: #755032)
   * Security update
     - CVE-2014-5025 Cross Site Scripting Vulnerability
     - CVE-2014-5026 Cross Site Scripting Vulnerability
     - CVE-2014-5043 Cross Site Scripting Vulnerability
     - CVE-2014-5261 Remote Code Execution
     - CVE-2014-5262 SQL injection
Checksums-Sha1: 
 aba2dfa12596a98fe518a8cc57cfe4e2ecdaf527 1683 cacti_0.8.8a+dfsg-5+deb7u4.dsc
 59f85a6cd4e35232cbf69871fee86801e9516dae 124924 cacti_0.8.8a+dfsg-5+deb7u4.debian.tar.gz
 8bd35354f912e820af88582038530ce9d86b6d24 2147846 cacti_0.8.8a+dfsg-5+deb7u4_all.deb
Checksums-Sha256: 
 a7a9555d27d73df668d2e972c371ef18effd07ab4d4d0acfe73a00268faed377 1683 cacti_0.8.8a+dfsg-5+deb7u4.dsc
 43303d65ed0e6c8127713299989104de0dac1d00c0ef393ca386be8fcb0c479f 124924 cacti_0.8.8a+dfsg-5+deb7u4.debian.tar.gz
 cf8a3bd37840839ba97808b0597fb1fabb076a459e9feda558ef45e624a23b0f 2147846 cacti_0.8.8a+dfsg-5+deb7u4_all.deb
Files: 
 403b5abd51e6dff69eef2126c36605a3 1683 web extra cacti_0.8.8a+dfsg-5+deb7u4.dsc
 c0d63abda1b79487441763de431d93ce 124924 web extra cacti_0.8.8a+dfsg-5+deb7u4.debian.tar.gz
 916906ce2d55b456abd7d672e04fb9b1 2147846 web extra cacti_0.8.8a+dfsg-5+deb7u4_all.deb

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 22 Aug 2014 15:21:05 +0000

Your message dated Fri, 22 Aug 2014 15:19:01 +0000
with message-id <[email-masked]>
and subject line Bug#755032: fixed in cacti 0.8.7g-1+squeeze5
has caused the Debian Bug report #755032,
regarding cacti: After upgrading cacti to 0.8.8a+dfsg-5+deb7u3 the plugin Autom8 did not work anymore
to be marked as done.

Package: cacti

Dear Maintainer,

Regards

-- System Information:
Debian Release: 7.6
  APT prefers stable

-- Configuration Files:

-- debconf information:

Subject: Bug#755032: fixed in cacti 0.8.7g-1+squeeze5
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Fri, 22 Aug 2014 15:19:01 +0000

Source: cacti
Source-Version: 0.8.7g-1+squeeze5

Format: 1.8
Date: Fri, 22 Aug 2014 16:05:04 +0200
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.7g-1+squeeze5
Distribution: squeeze-lts
Urgency: high
Maintainer: Sean Finney <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description: 
 cacti      - Frontend to rrdtool for monitoring systems and services
Closes: 755032
Changes: 
 cacti (0.8.7g-1+squeeze5) squeeze-lts; urgency=high
 .
   * Fix regression caused by fixing CVE-2014-4002 at least plugin autom8
     was unusable (Closes: #755032)
   * Security update
     - CVE-2014-5025 Cross Site Scripting Vulnerability
     - CVE-2014-5026 Cross Site Scripting Vulnerability
     - CVE-2014-5043 Cross Site Scripting Vulnerability
     - CVE-2014-5261 Remote Code Execution
     - CVE-2014-5262 SQL injection
Checksums-Sha1: 
 28d4e14e3b74e0d64cedc6f29af42e6ff91270ff 1443 cacti_0.8.7g-1+squeeze5.dsc
 dd6b0fe66c29445957dd934695b61e76b1611611 61581 cacti_0.8.7g-1+squeeze5.diff.gz
 61df4512038ca78bf18712bc7e300d55620b1c21 2098868 cacti_0.8.7g-1+squeeze5_all.deb
Checksums-Sha256: 
 ec9ecbadbc586ee722bd60e02ea4dc45b466aab88b5bc0f5d070e3f486d4c6e2 1443 cacti_0.8.7g-1+squeeze5.dsc
 2dfa0d1c8a03246cda7e9ea39f4e165d81abb965afbc23e0bae28384dd30c70a 61581 cacti_0.8.7g-1+squeeze5.diff.gz
 fd14caa4370b7c62b665144f6b533b29335c622a4699f9a8f9b97f2111d2b22d 2098868 cacti_0.8.7g-1+squeeze5_all.deb
Files: 
 a0dea55f668dd0eda149ff1523a39640 1443 web extra cacti_0.8.7g-1+squeeze5.dsc
 31a8d811adef6582034b90d1d4198373 61581 web extra cacti_0.8.7g-1+squeeze5.diff.gz
 7462c43f9750c305d66a2a02043b1288 2098868 web extra cacti_0.8.7g-1+squeeze5_all.deb