Subject: [Pkg-cacti-maint] Bug#655298: cacti: maintainer scripts fail to use --debconf-ok

From: [email-masked]
Date: Tue, 10 Jan 2012 01:29:04 -0500

Package: cacti
Version: 0.8.7b-2.1+lenny4
Severity: normal

I've just installed the latest security upgrade for cacti and during the
upgrade, I saw the following warning messages:

dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf
*** WARNING: ucf was run from a maintainer script that uses debconf, but
             the script did not pass --debconf-ok to ucf. The maintainer
             script should be fixed to not stop debconf before calling ucf,
             and pass it this parameter. For now, ucf will revert to using
             old-style, non-debconf prompting. Ugh!

             Please inform the package maintainer about this problem.
Replacing config file /etc/cacti/debian.php with new version
dbconfig-common: flushing administrative password
*** WARNING: ucf was run from a maintainer script that uses debconf, but
             the script did not pass --debconf-ok to ucf. The maintainer
             script should be fixed to not stop debconf before calling ucf,
             and pass it this parameter. For now, ucf will revert to using
             old-style, non-debconf prompting. Ugh!

             Please inform the package maintainer about this problem.

-- System Information:
Debian Release: 5.0.9
  APT prefers oldstable
  APT policy: (500, 'oldstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages cacti depends on:
ii  apache2           2.2.9-10+lenny11       Apache HTTP Server metapackage
ii  apache2-mpm-prefo 2.2.9-10+lenny11       Apache HTTP Server - traditional n
ii  dbconfig-common   1.8.39                 common framework for packaging dat
ii  debconf [debconf- 1.5.24                 Debian configuration management sy
ii  libapache2-mod-ph 5.2.6.dfsg.1-1+lenny13 server-side, HTML-embedded scripti
ii  libphp-adodb      5.05-1                 The ADOdb database abstraction lay
ii  logrotate         3.7.1-5                Log rotation utility
ii  mysql-client-5.0  5.0.51a-24+lenny5      MySQL database client binaries
ii  php5-cli          5.2.6.dfsg.1-1+lenny13 command-line interpreter for the p
ii  php5-mysql        5.2.6.dfsg.1-1+lenny13 MySQL module for php5
ii  php5-snmp         5.2.6.dfsg.1-1+lenny13 SNMP module for php5
ii  rrdtool           1.3.1-4                Time-series data storage and displ
ii  snmp              5.4.1~dfsg-12          SNMP (Simple Network Management Pr
ii  ucf               3.0016                 Update Configuration File: preserv

Versions of packages cacti recommends:
ii  iputils-ping         3:20071127-1+lenny1 Tools to test the reachability of 
ii  mysql-server         5.0.51a-24+lenny5   MySQL database server (metapackage
ii  mysql-server-5.0 [my 5.0.51a-24+lenny5   MySQL database server binaries

cacti suggests no packages.

-- debconf information:
* cacti/db/app-user: cacti
* cacti/mysql/admin-user: root
  cacti/upgrade-backup: true
  cacti/install-error: abort
* cacti/webserver: Apache2
  cacti/internal/reconfiguring: false
* cacti/mysql/method: unix socket
  cacti/remote/host:
  cacti/upgrade-error: abort
  cacti/dbconfig-upgrade: true
  cacti/internal/skip-preseed: false
  cacti/remote/newhost:
  cacti/purge: false
  cacti/passwords-do-not-match:
  cacti/dbconfig-remove:
* cacti/dbconfig-install: true
  cacti/missing-db-package-error: abort
  cacti/database-type: mysql
  cacti/remove-error: abort
* cacti/db/dbname: cacti
  cacti/remote/port:
  cacti/dbconfig-reinstall: false

---

From: Paul Gevers <[email-masked]>
Date: Fri, 20 Jan 2012 22:19:39 +0100

fixed 655298 0.8.7d-1
tags 655298 + wontfix
thanks

> upgrade, I saw the following warning messages:

Thanks for reporting this issue. Unfortunately we don't fix such issues
in the old-stable (or stable) releases of Debian and the issue has been
fixed a long time ago and is not present in the version in Debian Stable.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 20 Jan 2012 21:36:10 +0000

> fixed 655298 0.8.7d-1
Bug #655298 [cacti] cacti: maintainer scripts fail to use --debconf-ok
Bug Marked as fixed in versions cacti/0.8.7d-1.
> tags 655298 + wontfix
Bug #655298 [cacti] cacti: maintainer scripts fail to use --debconf-ok
Added tag(s) wontfix.
> thanks
Stopping processing here.

Please contact me if you need assistance.
-- 
655298: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=655298
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 13 Apr 2013 08:27:08 +0000

Your message dated Sat, 13 Apr 2013 10:23:23 +0200
with message-id <[email-masked]>
and subject line Debian Lenny unsupported, so close cacti bugs only in lenny
has caused the Debian Bug report #364897,
regarding Cacti doen't work with php-cli safemode but doesn't complain
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
364897: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=364897
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Cacti doen't work with php-cli safemode but doesn't complain
From: Birger Brunswiek <[email-masked]>
To: [email-masked]
Date: Wed, 26 Apr 2006 15:41:41 +0200

Package: cacti
Version: 0.8.6c-7sarge3

It seems as if cacti doesn't work out of the box in PHP safe mode. While this is
not that bad, cacti doesn't really tell one that this is actually a problem.
What I saw was only that no data was collected and when I looked further I found
that /usr/share/cacti/site/poller.php is supposed to collect the data. Its
cronfile /etc/cron.d/cacti suppresses any output so I did not saw any problem.
After running /usr/share/cacti/site/poller.php by hand it said:
sh: line 1: /php: No such file or directory
sh: line 1: /rrdtool: No such file or directory

and waited forever. Not terribly informative when it should actually complain
about safemode. I searched the web, found a few people who had the same error
but no solution was presented.

Somehow I came to turning off safemode and everything was fine ever since.

What I'd like to see is just a better error handling for the case where people
have safemode activated.

Subject: Debian Lenny unsupported, so close cacti bugs only in lenny
From: Paul Gevers <[email-masked]>
To: [email-masked], [email-masked], [email-masked]
Date: Sat, 13 Apr 2013 10:23:23 +0200

These particular bugs in cacti only manifests themselves in Debian 5
(lenny) or older which are not supported by Debian anymore. Therefor I
close these bugs.

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 13 Apr 2013 08:27:11 +0000

Your message dated Sat, 13 Apr 2013 10:23:23 +0200
with message-id <[email-masked]>
and subject line Debian Lenny unsupported, so close cacti bugs only in lenny
has caused the Debian Bug report #550238,
regarding cacti: lenny version does not ship with cli scripts installed
to be marked as done.

-- 
550238: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550238
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti: The debian package doesn't include cli scripts available in the orig archive
From: root <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Thu, 08 Oct 2009 17:10:43 +0200

Package: cacti
Version: 0.8.7b-2.1
Severity: normal

Hi,

You can find in the orig file for cacti (in lenny) that there is a cli folder containing 
cli php scripts to manage cacti devices. That's normal since those scripts were added in cacti
0.8.7. These scripts aren't included in the final debian package so the lenny version of cacti 
is lacking a great and usefull feature (I use it to script massive devices adds in my cacti).

It would be great to rebuild cacti with those files included, as it currently is in squeeze.

Regards,

-- System Information:
Debian Release: 5.0.2
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Paul

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sat, 13 Apr 2013 08:27:15 +0000

Your message dated Sat, 13 Apr 2013 10:23:23 +0200
with message-id <[email-masked]>
and subject line Debian Lenny unsupported, so close cacti bugs only in lenny
has caused the Debian Bug report #655298,
regarding cacti: maintainer scripts fail to use --debconf-ok
to be marked as done.

Subject: cacti: maintainer scripts fail to use --debconf-ok
From: [email-masked]
To: Debian Bug Tracking System <[email-masked]>
Date: Tue, 10 Jan 2012 01:29:04 -0500

Package: cacti

-- System Information:
Debian Release: 5.0.9
  APT prefers oldstable

-- debconf information:

Paul