Subject: [Pkg-cacti-maint] Bug#653897: cacti: General update after the debconf review process

From: Christian PERRIER <[email-masked]>
Date: Sun, 12 Feb 2012 08:11:22 +0100

Dear Debian maintainer,

On Thursday, January 05, 2012, I sent you a notification about the beginning of a review
action on debconf templates for cacti.

Then, I sent you a bug report with rewritten templates and announcing
the beginning of the second phase of this action: call for translation
updates.

Translators have been working hard and here is now the result of their efforts.

Please consider using it EVEN if you committed files to your
development tree as long as they were reported.

The attached tarball contains:

- debian/changelog with the list of changes
- debian/control with rewrites of packages' descriptions
- debian/<templates> with all the rewritten templates file(s)
- debian/po/*.po with all PO files (existing ones and new ones)

As said, please use *at least* the PO files as provided here,
preferrably over those sent by translators in their bug reports. All
of them have been checked and reformatted. In some cases, formatting
errors have been corrected.

The patch.rfr file contains a patch for the templates and control
file(s) alone.

Please note that this patch applies to the templates and control
file(s) of your package as of Thursday, January 05, 2012. If your package was updated
in the meantime, I may have updated my reference copy....but I also
may have missed that. This is indeed why I suggested you do not
modified such files while the review process was running,
remember..:-)

It is now safe to upload a new package version with these changes.

Please notify me of your intents with regards to this. 

There is of course no hurry to update your package but feel free to
contact me in case you would need sponsoring or any other action to
fix this.

-- 

--- cacti.old/debian/cacti.templates	2012-01-01 10:28:46.039467059 +0100
+++ cacti/debian/cacti.templates	2012-01-19 08:04:03.138548407 +0100
@@ -1,9 +1,18 @@
+# These templates have been reviewed by the debian-l10n-english
+# team
+#
+# If modifications/additions/rewording are needed, please ask
+# [email-masked] for advice.
+#
+# Even minor modifications require translation updates and such
+# changes should be coordinated with translators and reviewers.
+
 Template: cacti/webserver
 Type: select
 __Choices: Apache2, None
 Default: Apache2
-_Description: Webserver type
- Please select the webserver type for which cacti should be automatically
+_Description: Web server:
+ Please select the web server for which Cacti should be automatically
  configured.
  .
- Select "None" if you would like to configure your webserver by hand.
+ Select "None" if you would like to configure the web server manually.
--- cacti.old/debian/control	2012-01-01 10:28:46.039467059 +0100
+++ cacti/debian/control	2012-01-06 07:02:01.057571865 +0100
@@ -13,15 +13,12 @@
 Depends: apache2 | apache | apache-ssl | apache-perl | httpd, libapache2-mod-php5 | php5, php5-mysql, php5-cli, php5-snmp, virtual-mysql-client, rrdtool, snmp, libphp-adodb (>= 4.50-1), ucf, dbconfig-common (>= 1.8.8), ${misc:Depends}
 Recommends: mysql-server, iputils-ping, logrotate
 Suggests: php5-ldap
-Description: Frontend to rrdtool for monitoring systems and services
- Cacti is a complete frontend to rrdtool, it stores all of the necessary
- information to create graphs and populates them with data in a MySQL
- database.  The frontend is completely PHP driven.  Along with being able
- to maintain Graphs, Data Sources, and Round Robin Archives in a
- database, cacti handles the data gathering also.  There is also SNMP
- support for those used to creating traffic graphs with MRTG.
+Description: web interface for graphing of monitoring systems
+ Cacti is a complete PHP-driven front-end for RRDTool. It stores all of
+ the necessary data source information to create graphs, handles the data
+ gathering, and populates the MySQL database with round-robin archives.
+ It also includes SNMP support for those used to creating traffic graphs
+ with MRTG.
  .
  This package requires a functional MySQL database server on either the
- installation host or remotely accessible system.  If you do not already
- have a database server available, you should also install mysql-server.
- 
+ installation host or a remotely accessible system.
--- cacti.old/debian/changelog	2012-01-01 10:28:46.039467059 +0100
+++ cacti/debian/changelog	2012-02-11 07:52:35.605043167 +0100
@@ -1,3 +1,23 @@
+cacti (0.8.7g-3) UNRELEASED; urgency=low
+
+  * Debconf templates and debian/control reviewed by the debian-l10n-
+    english team as part of the Smith review project. Closes: #653897
+  * [Debconf translation updates]
+  * Spanish; (Javier Fernández-Sanguino).  Closes: #656405
+  * French (Christian Perrier).  Closes: #657280
+  * Polish (Michał Kułach).  Closes: #657294
+  * Danish (Joe Hansen).  Closes: #657339
+  * Dutch; (Jeroen Schot).  Closes: #657468
+  * Swedish (Martin Bagge / brother).  Closes: #657546
+  * Indonesian (Mahyuddin Susanto).  Closes: #657609
+  * Russian (Yuri Kozlov).  Closes: #657705
+  * German (Chris Leick).  Closes: #658396
+  * Czech (Miroslav Kure).  Closes: #658752
+  * Portuguese (Rui Branco).  Closes: #659167
+  * Italian (Beatrice Torracca).  Closes: #659401
+
+ -- Christian Perrier <[email-masked]>  Sun, 01 Jan 2012 15:09:39 +0100
+
 cacti (0.8.7g-2.1) unstable; urgency=low
 
   * Non-maintainer upload.

---

From: Christian PERRIER <[email-masked]>
Date: Tue, 28 Feb 2012 18:55:56 +0100

> development tree as long as they were reported.

Ping? Any chance that an updated cacti package is uploaded in the
upcoming days|weeks?

---

From: Paul Gevers <[email-masked]>
Date: Wed, 29 Feb 2012 20:31:09 +0100

> Ping? Any chance that an updated cacti package is uploaded in the

It's on my todo list to add it to the git tree. If somebody beats me to
it, fine. I can't upload anyway to Debian yet, and I believe Sean is
still struggling with some regression on his system.

Paul

---

From: Christian PERRIER <[email-masked]>
Date: Thu, 1 Mar 2012 07:20:06 +0100

> still struggling with some regression on his system.

I'd be happy to sponsor a prepared upload it that might help
(preferrably one with not too many *other* changes than l10n,
eventually).

---

From: Paul Gevers <[email-masked]>
Date: Sat, 10 Mar 2012 17:44:06 +0100

Hi Christian,

Just so you know, I have included your patch and the missing Basque
translation in our git repository [1], but as one of the commits by Sean
was adding me to the uploaders and setting DMUA, I don't feel it
appropriate to ask you for sponsorship with this set. I hope Sean will
find time soon to upload the current changes. If not, I will create a
package without the DMUA set and see if you can sponsor the upload,
however, with the next upload I do want to fix some issues solved so far.

Paul

[1]
http://anonscm.debian.org/gitweb/?p=pkg-cacti/cacti.git;a=commit;h=765ea5dc7bdff245c9b9e09666bbcf4b442b57b0

---

From: Christian PERRIER <[email-masked]>
Date: Sat, 10 Mar 2012 18:04:47 +0100

> however, with the next upload I do want to fix some issues solved so far.

OK, no problem at all. Thanks for your very precise answer.

---

From: Christian PERRIER <[email-masked]>
Date: Sun, 25 Mar 2012 16:48:08 +0200

> however, with the next upload I do want to fix some issues solved so far.

Any progress? I still can sponsor the upload as cacti is now on the
full top of my radar:

http://i18n.debian.net/debian-l10n/l10n-nmu/nmu_bypackage.html

---

From: Paul Gevers <[email-masked]>
Date: Mon, 26 Mar 2012 22:10:02 +0200

> Any progress? I still can sponsor the upload as cacti is now on the

Hmm, could you tell me how much of the current changes are you
comfortable with [1], i.e. could the upload fix other outstanding bugs?
I still hope that Sean can do an upload, but else I will strip the
current packaging from the things you don't want to sponsor.

@Sean, can you please respond on this issue?

Paul

[1] http://anonscm.debian.org/gitweb/?p=pkg-cacti/cacti.git

---

From: Christian PERRIER <[email-masked]>
Date: Tue, 27 Mar 2012 20:22:10 +0200

> comfortable with [1], i.e. could the upload fix other outstanding bugs?

I'm comfortable with all these changes and ready to upload the package.

Could you please the upload and point me to the .dsc file?

---

From: Paul Gevers <[email-masked]>
Date: Thu, 29 Mar 2012 22:15:06 +0200

> Could you please the upload and point me to the .dsc file?

I uploaded the package to mentors and the .dsc file can be found at [1].
I updated the last change to the debian/rules file to be backward
compatible, but otherwise created the package as it was in the git
repository at the moment you sent your previous e-mail.

The DMUA flag is left IN, as you mentioned in your e-mail that you are
comfortable with all the changes. Please let me know when that was a
mistake.

Paul

[1] http://mentors.debian.net/debian/pool/main/c/cacti/cacti_0.8.7i-3.dsc

---

From: Christian PERRIER <[email-masked]>
Date: Thu, 29 Mar 2012 22:28:20 +0200

> I uploaded the package to mentors and the .dsc file can be found at [1].

I went on an FTNFS when building with pbuilder. I didn't investigate
this, though.

.../...
dh_installchangelogs docs/CHANGELOG
make[1]: Leaving directory `/tmp/buildd/cacti-0.8.7i'
   dh_installexamples
   dh_installman
   dh_installcatalogs
   dh_installcron
   dh_installdebconf
   dh_installemacsen
   dh_installifupdown
   dh_installinfo
   dh_installinit
   dh_installmenu
   dh_installmime
   dh_installmodules
   dh_installlogcheck
   dh_installlogrotate
   dh_installpam
   dh_installppp
   dh_installudev
   dh_installwm
   dh_installxfonts
   dh_installgsettings
   dh_bugfiles
   dh_ucf
   dh_lintian
   dh_gconf
   dh_icons
   dh_perl
   dh_usrlocal
sed: -e expression #1, char 20: extra characters after command
dh_usrlocal: sed '/#DIRS#/ c\\
/usr/local/share 2775 root staff\\
/usr/local/share/cacti 2775 root staff\\
/usr/local/share/cacti/scripts 2775 root staff\\

---

From: Paul Gevers <[email-masked]>
Date: Thu, 29 Mar 2012 22:35:10 +0200

> /usr/local/share/cacti/scripts 2775 root staff\\

Please update your sid environment. This bug was fixed several days ago.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665220

Paul

---

From: Christian PERRIER <[email-masked]>
Date: Thu, 29 Mar 2012 22:42:26 +0200

> Please update your sid environment. This bug was fixed several days ago.

Ah, doh. My sid chroot was using my local mirror and....the mirror is
broken for two weeks because it doesn't fit anymore on the disk where
it is hosted.

Updating my chroot with another mirror and I'll build the package
again. Thanks for the quick answer.