Subject: [Pkg-cacti-maint] Bug#861858: cacti fails to create symlinks when upgrading from jessie to stretch

From: Paul Gevers <[email-masked]>
Date: Thu, 04 May 2017 21:52:59 +0200

Package: cacti
Version: 0.8.8h+ds1-8
Severity: important

Cacti version 0.8.8h+ds1-8 replaced the embedded jstree JavaScript with a
dependency on the (new) libjs-jquery-jstree package. Instead of having the
files in its own directory tree it now provides symlinks to the jstree
package. However, dpkg doesn't convert dirs to links or vice-versa
automatically and cacti didn't take care of it, so upgrading from anywhere
between 0.8.8a+dfsg-1 (inclusive) and 0.8.8h+ds1-8 (exclusive) to 0.8.8h+ds1-8
or later causes loss of the theme files (CSS and figures), preventing the
device tree to collapse. This includes the upgrade from Jessie to Stretch.

The new link is:
/usr/share/cacti/site/include/js/themes -> ../../../../javascript/jstree/themes

Original report found on the cacti forum in a complaint about the Ubuntu
upgrade (no https): http://forums.cacti.net/viewtopic.php?f=21&t=57313

- -- System Information:
Debian Release: 9.0
  APT prefers testing-debug
  APT policy: (500, 'testing-debug'), (500, 'testing'), (200, 'experimental'), (200, 'testing'), (50, 'experimental'), (50, 'testing'), (1, 'experimental')
Architecture: amd64
 (x86_64)

Kernel: Linux 4.9.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cacti depends on:
ii  dbconfig-mysql                              2.0.8
ii  debconf [debconf-2.0]                       1.5.60
ii  javascript-common                           11
ii  libapache2-mod-php                          1:7.0+49
ii  libapache2-mod-php7.0 [libapache2-mod-php]  7.0.16-3
ii  libjs-jquery                                3.1.1-2
ii  libjs-jquery-cookie                         11-3
ii  libjs-jquery-jstree                         3.3.3+dfsg1-1
ii  libjs-jquery-ui                             1.12.1+dfsg-4
ii  libjs-jquery-ui-theme-ui-lightness          1.12.1+dfsg-1
ii  libphp-adodb                                5.20.9-1
pn  perl:any                                    <none>
ii  php-cli                                     1:7.0+49
ii  php-mbstring                                1:7.0+49
ii  php-mysql                                   1:7.0+49
ii  php-snmp                                    1:7.0+49
ii  php-xml                                     1:7.0+49
ii  php7.0-cli [php-cli]                        7.0.16-3
ii  php7.0-mbstring [php-mbstring]              7.0.16-3
ii  php7.0-mysql [php-mysqlnd]                  7.0.16-3
ii  php7.0-snmp [php-snmp]                      7.0.16-3
ii  php7.0-xml [php-xml]                        7.0.16-3
ii  rrdtool                                     1.6.0-1+b2
ii  snmp                                        5.7.3+dfsg-1.7
ii  ucf                                         3.0036

Versions of packages cacti recommends:
ii  apache2 [httpd]                             2.4.25-3
ii  iputils-ping                                3:20161105-1
ii  logrotate                                   3.11.0-0.1
ii  mariadb-server-10.1 [virtual-mysql-server]  10.1.22-3

Versions of packages cacti suggests:
ii  moreutils  0.60-1
pn  php-ldap   <none>

- -- debconf information:
  cacti/mysql/method: Unix socket
  cacti/remote/port:
  cacti/dbconfig-upgrade: true
  cacti/database-type: mysql
  cacti/remove-error: abort
  cacti/purge: false
  cacti/dbconfig-remove: true
* cacti/mysql/admin-user: root
  cacti/remote/host: localhost
  cacti/internal/reconfiguring: false
  cacti/passwords-do-not-match:
  cacti/upgrade-error: abort
  cacti/dbconfig-reinstall: false
* cacti/webserver: apache2
  cacti/db/dbname: cacti
  cacti/install-error: abort
  cacti/upgrade-backup: true
  cacti/missing-db-package-error: abort
  cacti/db/app-user: cacti@localhost
  cacti/internal/skip-preseed: false
  cacti/remote/newhost:
* cacti/dbconfig-install: true

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 05 May 2017 19:36:05 +0000

Your message dated Fri, 05 May 2017 19:33:28 +0000
with message-id <[email-masked]>
and subject line Bug#861858: fixed in cacti 0.8.8h+ds1-10
has caused the Debian Bug report #861858,
regarding cacti fails to create symlinks when upgrading from jessie to stretch
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

-- 
861858: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=861858
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: cacti fails to create symlinks when upgrading from jessie to stretch
From: Paul Gevers <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Thu, 04 May 2017 21:52:59 +0200

Package: cacti
Version: 0.8.8h+ds1-8
Severity: important

The new link is:

- -- System Information:
Debian Release: 9.0

Subject: Bug#861858: fixed in cacti 0.8.8h+ds1-10
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Fri, 05 May 2017 19:33:28 +0000

Source: cacti
Source-Version: 0.8.8h+ds1-10

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Paul Gevers <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Fri, 05 May 2017 13:55:33 +0200
Source: cacti
Binary: cacti
Architecture: source
Version: 0.8.8h+ds1-10
Distribution: unstable
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 861858
Changes:
 cacti (0.8.8h+ds1-10) unstable; urgency=medium
 .
   * Fix upgrades from before 0.8.8h+ds1-8; that version started to ship
     symlinks to directories in libjs-jquery-jstree without making sure
     dpkg handled that properly during upgrades (Closes: #861858)
Checksums-Sha1:
 d1b45dea47deb8995fc2e00cebbe69df07ac8000 1638 cacti_0.8.8h+ds1-10.dsc
 e9c7c6601b0745ec9f5ea164b89e9351b37b5bb3 48860 cacti_0.8.8h+ds1-10.debian.tar.xz
Checksums-Sha256:
 59df1f9e17ec37bb77687aa97ac3c1fd474f5b884e84c673535e5a27bfeab425 1638 cacti_0.8.8h+ds1-10.dsc
 995f3d98410d7cf58ee83ce18705a51744e03857731c85c10467073fca9018b9 48860 cacti_0.8.8h+ds1-10.debian.tar.xz
Files:
 766063066274d1b22a2ecaadc5a9a400 1638 web extra cacti_0.8.8h+ds1-10.dsc
 65edb697b4a6b34a64412642149b58bd 48860 web extra cacti_0.8.8h+ds1-10.debian.tar.xz

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 05 May 2017 19:51:04 +0000

Your message dated Fri, 05 May 2017 19:48:34 +0000
with message-id <[email-masked]>
and subject line Bug#861858: fixed in cacti 1.1.5+ds1-2
has caused the Debian Bug report #861858,
regarding cacti fails to create symlinks when upgrading from jessie to stretch
to be marked as done.

Package: cacti
Version: 0.8.8h+ds1-8
Severity: important

The new link is:

- -- System Information:
Debian Release: 9.0

Subject: Bug#861858: fixed in cacti 1.1.5+ds1-2
From: Paul Gevers <[email-masked]>
To: [email-masked]
Date: Fri, 05 May 2017 19:48:34 +0000

Source: cacti
Source-Version: 1.1.5+ds1-2

Format: 1.8
Date: Fri, 05 May 2017 21:23:09 +0200
Source: cacti
Binary: cacti
Architecture: source
Version: 1.1.5+ds1-2
Distribution: experimental
Urgency: medium
Maintainer: Cacti Maintainer <[email-masked]>
Changed-By: Paul Gevers <[email-masked]>
Description:
 cacti      - web interface for graphing of monitoring systems
Closes: 861858
Changes:
 cacti (1.1.5+ds1-2) experimental; urgency=medium
 .
   * Upload with fix from 0.8.8h+ds1-10:
     Fix upgrades from before 0.8.8h+ds1-8; that version started to ship
     symlinks to directories in libjs-jquery-jstree without making sure
     dpkg handled that properly during upgrades (Closes: #861858)
Checksums-Sha1:
 7f0618c31904ac672b0581ae22baf82554007243 2098 cacti_1.1.5+ds1-2.dsc
 5d657ffc3bc6cacdcea484af7c441b6d37e9ccc9 48568 cacti_1.1.5+ds1-2.debian.tar.xz
Checksums-Sha256:
 d0991779193eeaa190825fa5e2a45b66bf0c642002d40c3aac267e2ee6c76e87 2098 cacti_1.1.5+ds1-2.dsc
 9e54062e07900a37dd823f748e9b1a20eb9354b8bf4066395544280fedb2eb6e 48568 cacti_1.1.5+ds1-2.debian.tar.xz
Files:
 e9d41943e931ae2c6ae9b38e918b5f33 2098 web extra cacti_1.1.5+ds1-2.dsc
 b5dd0a938c882ecce1bbe40170c6d682 48568 web extra cacti_1.1.5+ds1-2.debian.tar.xz