Subject: [Pkg-cacti-maint] Bug#656613: cacti: SNMP - Interface Statistics data query doesn't work after upgrade to 0.8.7b-2.1+lenny4

From: Viridiana Sala <[email-masked]>
Date: Fri, 20 Jan 2012 14:28:27 +0100

Package: cacti
Version: 0.8.7b-2.1+lenny4
Severity: normal

Hello
after upgrading to 0.8.7b-2.1+lenny4  SNMP - Interface Statistics seems to have stopped working.
 
If I try to add the data query (or run it via the "verbose query" link) I get this error:

Fatal error: Cannot use string offset as an array in /usr/share/cacti/site/lib/data_query.php on line 235

and after the error cacti always reports 0 items/0 rows.

My cacti installation worked correctly before the upgrade.

Best Regards

Viridiana

-- System Information:
Debian Release: 5.0.9
  APT prefers oldstable
  APT policy: (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages cacti depends on:
ii  apache2           2.2.9-10+lenny11       Apache HTTP Server metapackage
ii  apache2-mpm-prefo 2.2.9-10+lenny11       Apache HTTP Server - traditional n
ii  dbconfig-common   1.8.39                 common framework for packaging dat
ii  debconf [debconf- 1.5.24                 Debian configuration management sy
ii  libapache2-mod-ph 5.2.6.dfsg.1-1+lenny13 server-side, HTML-embedded scripti
ii  libphp-adodb      5.05-1                 The ADOdb database abstraction lay
ii  logrotate         3.7.1-5                Log rotation utility
ii  mysql-client-5.0  5.0.51a-24+lenny5      MySQL database client binaries
ii  php5-cli          5.2.6.dfsg.1-1+lenny13 command-line interpreter for the p
ii  php5-mysql        5.2.6.dfsg.1-1+lenny13 MySQL module for php5
ii  php5-snmp         5.2.6.dfsg.1-1+lenny13 SNMP module for php5
ii  rrdtool           1.3.1-4                Time-series data storage and displ
ii  snmp              5.4.1~dfsg-12          SNMP (Simple Network Management Pr
ii  ucf               3.0016                 Update Configuration File: preserv

Versions of packages cacti recommends:
ii  iputils-ping         3:20071127-1+lenny1 Tools to test the reachability of 
ii  mysql-server         5.0.51a-24+lenny5   MySQL database server (metapackage
ii  mysql-server-5.0 [my 5.0.51a-24+lenny5   MySQL database server binaries

cacti suggests no packages.

-- debconf information excluded

---

From: Mahyuddin Susanto <[email-masked]>
Date: Fri, 20 Jan 2012 22:44:17 +0700

tag 656613 confirmed
stop

Hello Viridiana Sala,

> My cacti installation worked correctly before the upgrade.

I just confirmed that 0.8.7b-2.1+lenny4 have regression, we still work
on this. Thanks for your cooperations
-- 
[ Mahyuddin Susanto ] - http://udienz.web.id
GPG: 4096R/90B36C5B
Debian Maintainer & Ubuntu Developer

---

From: [email-masked] (Debian Bug Tracking System)
Date: Fri, 20 Jan 2012 15:45:16 +0000

> tag 656613 confirmed
Bug #656613 [cacti] cacti: SNMP - Interface Statistics data query doesn't work after upgrade to 0.8.7b-2.1+lenny4
Added tag(s) confirmed.
> stop
Stopping processing here.

Please contact me if you need assistance.
-- 
656613: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=656613
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (Debian Bug Tracking System)
Date: Sun, 05 Feb 2012 16:06:05 +0000

Your message dated Sun, 05 Feb 2012 16:02:10 +0000
with message-id <[email-masked]>
and subject line Bug#656613: fixed in cacti 0.8.7b-2.1+lenny5
has caused the Debian Bug report #656613,
regarding cacti: SNMP - Interface Statistics data query doesn't work after upgrade to 0.8.7b-2.1+lenny4
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email-masked]
immediately.)

Subject: cacti: SNMP - Interface Statistics data query doesn't work after upgrade to 0.8.7b-2.1+lenny4
From: Viridiana Sala <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Fri, 20 Jan 2012 14:28:27 +0100

Package: cacti

Hello

Best Regards

Viridiana

-- System Information:
Debian Release: 5.0.9
  APT prefers oldstable

Subject: Bug#656613: fixed in cacti 0.8.7b-2.1+lenny5
From: Luk Claes <[email-masked]>
To: [email-masked]
Date: Sun, 05 Feb 2012 16:02:10 +0000

Source: cacti
Source-Version: 0.8.7b-2.1+lenny5

We believe that the bug you reported is fixed in the latest version of
cacti, which is due to be installed in the Debian FTP archive:

cacti_0.8.7b-2.1+lenny5.diff.gz
  to main/c/cacti/cacti_0.8.7b-2.1+lenny5.diff.gz
cacti_0.8.7b-2.1+lenny5.dsc
  to main/c/cacti/cacti_0.8.7b-2.1+lenny5.dsc
cacti_0.8.7b-2.1+lenny5_all.deb
  to main/c/cacti/cacti_0.8.7b-2.1+lenny5_all.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Luk Claes <[email-masked]> (supplier of updated cacti package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sat, 21 Jan 2012 23:41:35 +0100
Source: cacti
Binary: cacti
Architecture: source all
Version: 0.8.7b-2.1+lenny5
Distribution: oldstable
Urgency: low
Maintainer: Sean Finney <[email-masked]>
Changed-By: Luk Claes <[email-masked]>
Description: 
 cacti      - Frontend to rrdtool for monitoring systems and services
Closes: 656613
Changes: 
 cacti (0.8.7b-2.1+lenny5) oldstable; urgency=low
 .
   * lib/snmp.php: Add $max_oids parameter to snmp_walk
     Closes: #656613
Checksums-Sha1: 
 c2cc4ba9ca7365e0495285f92a85656e5b10bfd2 1117 cacti_0.8.7b-2.1+lenny5.dsc
 f6937c34e2dccf12be9847a78ab8fee0299b203f 54421 cacti_0.8.7b-2.1+lenny5.diff.gz
 60cc08592d9fe46d25d623acef41daa7066e3686 1858242 cacti_0.8.7b-2.1+lenny5_all.deb
Checksums-Sha256: 
 320b66048d00b8d34268afdc04a8b75b49ba9c541eaa5d755efc9175185cf21d 1117 cacti_0.8.7b-2.1+lenny5.dsc
 73f4da50231f0a86bf61fee71468f5025c818d7c6ae7e9c2870cba1c0df949c7 54421 cacti_0.8.7b-2.1+lenny5.diff.gz
 6e9470ea6502c02e92f258889f9bcf73820fd08d13a2fc282ce9f0df49536576 1858242 cacti_0.8.7b-2.1+lenny5_all.deb
Files: 
 11dab9ef18e0aca563f8d4efeadb44c0 1117 web extra cacti_0.8.7b-2.1+lenny5.dsc
 dc4c3d997c81933c17a4d83c9fe9e6de 54421 web extra cacti_0.8.7b-2.1+lenny5.diff.gz
 2012a2e6b6da3bb8f1c0b70886d5ca1b 1858242 web extra cacti_0.8.7b-2.1+lenny5_all.deb