[Pkg-chromium-maint] Bug#884887: chromium: rejects access to microphone without prompt

Jeremy Lainé jeremy.laine at m4x.org
Thu Dec 21 00:27:02 UTC 2017

Package: chromium
Version: 63.0.3239.84-1
Severity: normal

When trying to make use of any website which uses getUserMedia(),
including the reference WebRTC app, the request fails with a
NotAllowedError without prompting me at all. The expected behaviour is
for the usual prompt to appear, asking for access to the microphone.

I have checked that the "Block" and "Allow" lists in content settings
are both empty and the default action is "Ask before accessing".
Furthermore, manually adding websites to the "Allow" list makes no
difference, I still get the crossed out microphone icon to the right of
the URL bar indicating access to the microphone was denied.

This really seems to be a UX issue and not a problem accessing the
underlying hardware, as everything works fine if I start Chromium with
the –use-fake-ui-for-media-stream flag.

I have also tried the Google-provided .deb for Chrome (also M63) on the
same machine everything works out of the box, so it really looks like
this issue is specific to the Debian/Chromium build.

Let me know if there are any further tests I can perform to narrow down
the root cause of the issue.

-- System Information:
Debian Release: buster/sid
   APT prefers unstable
   APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.14.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages chromium depends on:
ii  chromium-common      63.0.3239.84-1
ii  libasound2           1.1.3-5
ii  libatk1.0-0          2.26.1-1
ii  libavcodec57         7:3.4.1-1
ii  libavformat57        7:3.4.1-1
ii  libavutil55          7:3.4.1-1
ii  libc6                2.25-5
ii  libcairo2            1.15.8-2
ii  libcups2             2.2.6-3
ii  libdbus-1-3          1.12.2-1
ii  libevent-2.1-6       2.1.8-stable-4
ii  libexpat1            2.2.5-3
ii  libflac8             1.3.2-1
ii  libfontconfig1       2.12.6-0.1
ii  libfreetype6         2.8.1-0.1
ii  libgcc1              1:7.2.0-18
ii  libgdk-pixbuf2.0-0   2.36.11-1
ii  libglib2.0-0         2.54.2-3
ii  libgtk-3-0           3.22.26-2
ii  libharfbuzz0b        1.7.2-1
ii  libicu57             57.1-8
ii  libjpeg62-turbo      1:1.5.2-2+b1
ii  liblcms2-2           2.9-1
ii  libminizip1          1.1-8+b1
ii  libnspr4             2:4.16-1+b1
ii  libnss3              2:3.34-1
ii  libopus0             1.2.1-1
ii  libpango-1.0-0       1.40.13-2
ii  libpangocairo-1.0-0  1.40.13-2
ii  libpng16-16          1.6.34-1
ii  libpulse0            11.1-4
ii  libre2-3             20170101+dfsg-1
ii  libsnappy1v5         1.1.7-1
ii  libstdc++6           7.2.0-18
ii  libvpx4              1.6.1-3
ii  libwebp6             0.6.0-4
ii  libwebpdemux2        0.6.0-4
ii  libwebpmux3          0.6.0-4
ii  libx11-6             2:1.6.4-3
ii  libx11-xcb1          2:1.6.4-3
ii  libxcb1              1.12-1
ii  libxcomposite1       1:0.4.4-2
ii  libxcursor1          1:1.1.15-1
ii  libxdamage1          1:1.1.4-3
ii  libxext6             2:1.3.3-1+b2
ii  libxfixes3           1:5.0.3-1
ii  libxi6               2:1.7.9-1
ii  libxml2              2.9.4+dfsg1-5.2
ii  libxrandr2           2:1.5.1-1
ii  libxrender1          1:0.9.10-1
ii  libxslt1.1           1.1.29-5
ii  libxss1              1:1.2.2-1+b2
ii  libxtst6             2:1.2.3-1
ii  zlib1g               1:1.2.8.dfsg-5

Versions of packages chromium recommends:
ii  fonts-liberation  1:1.07.4-5

Versions of packages chromium suggests:
pn  chromium-driver    <none>
pn  chromium-l10n      <none>
pn  chromium-shell     <none>
pn  chromium-widevine  <none>

-- no debconf information

More information about the Pkg-chromium-maint mailing list