Bug#518021: aptitude fails to purge slime in squeeze

Luca Capello luca at pca.it
Thu Mar 12 23:42:30 UTC 2009

severity 518021 grave
tags 518021 + pending

Hi Mikhail!

On Tue, 03 Mar 2009 16:32:29 +0100, Mikhail Vasil'jev wrote:
> I upgraded Lenny to Squeeze today, and tried to purge slime.
> Removing slime ...
> /var/lib/dpkg/info/slime.prerm: line 24: unregister-common-lisp-source: 
> command not found

This is probably a side-effect of bug #471863 [1]: since cl-swank is no
more a SLIME dependency, the common-lisp-controller package (which
provides unregister-common-lisp-source) is no more present.

FYI, you get the same error if you install slime alone, i.e. without any
recommended package, as you can see at bug #519455 [2].

I fixed this issue in the pkg-common-lisp repository [3].

Thx, bye,
Gismo / Luca

[1] http://bugs.debian.org/471863
[2] http://bugs.debian.org/519455
[3] http://git.debian.org/?p=pkg-common-lisp/slime.git;a=commitdiff;h=2c26704cb354b163eb61633b30998b8d28f5177a
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 314 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/pkg-common-lisp-devel/attachments/20090313/453868ce/attachment.pgp 

More information about the pkg-common-lisp-devel mailing list