Bug#623633: sbcl fails to load asdf on startup

Tsiang Elaine tsiang.elaine at gmail.com
Fri Apr 22 00:01:33 UTC 2011

Package: sbcl
Version: 1:
Severity: grave
Justification: renders package unusable

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (990, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages sbcl depends on:
ii  libc6                         2.11.2-11  Embedded GNU C Library:
Shared lib

Versions of packages sbcl recommends:
ii  binfmt-support                2.0.4      Support for extra binary

Versions of packages sbcl suggests:
ii  sbcl-doc                    1: Documentation for Steel
Bank Commo
ii  sbcl-source                 1: Source code files for SBCL
ii  slime                       1:20100722-1 Superior LISP Interaction
Mode for

-- no debconf information

Same with kernel 2.6.38-2-amd64. I booted into the older 2.6.32-5-amd64
just to make sure.
After upgrading to sbcl Version: 1:, got following in

; loading #P"/usr/share/common-lisp/source/slime/swank-loader.lisp"

debugger invoked on a SB-C::INPUT-ERROR-IN-COMPILE-FILE in thread

"initial thread" RUNNING

  READ failure in COMPILE-FILE:
    SB-INT:SIMPLE-READER-PACKAGE-ERROR at 5611 (line 143, column 52) on

for "file /usr/share/common-lisp/source/slime/

      package "ASDF" not found

Same error in bare sbcl, and must manually load asdf.

The file /usr/lib/common-lisp/bin/sbcl.sh is not there.

I then downgraded sbcl (and cl-asdf, because both were upgraded at same
time), and all works fine as before. I then re-
upgraded both, and got the same error again.

More information about the pkg-common-lisp-devel mailing list