GNU clisp 2.49.90 available for beta-testing

Sébastien Villemot sebastien at
Wed Feb 14 07:29:15 UTC 2018

Dear Bruno,

On Mon, Feb 12, 2018 at 02:40:47AM +0100, Bruno Haible wrote:

> GNU clisp 2.49.90 is released. The download location is

> According to [1], you are packaging clisp for Debian.
> I invite you to give some testing to this beta release.

I uploaded clisp 2.49.90 to Debian experimental. You can see the build status
at the following address:

You can click on the links in the "Status" column to see build logs.

More precisely, the status on release architectures is the following:
- amd64: ok
- arm64: fails to generate lisp image (memory mapping issue)
- armel: lisp image generated, but fails to compile asdf (memory mapping issue)
- armhf: can't run lisp image (PSEUDOCODE_ALIGNMENT is not fulfilled)
- i386: builds and passes tests, but scary messages about memory mappings
- mips: lisp image generated, but fails to compile asdf (memory mapping issue)
- mips64el: fails to generate lisp image (memory mapping issue)
- mipsel: not yet tried (waiting for a build daemon to be available)
- ppc64el: lisp image generated, but fails to compile asdf (segfault)
- s390x: can't run lisp image (segfault)

I did not yet look at the other architectures: they are not a blocker for me,
because they are not officially supported by Debian (though of course it would
be nice to also support them).

The Debian packaging can be seen at:

Note that I tried to introduce as little changes as possible from the source
and build options that you provide. The main differences are the following:

- some build flags are added by Debian by default, related to security
  hardening. I already disabled -fstack-protector-strong which was causing a
  failure on amd64. The following flags are still present:

  -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -fdebug-prefix-map=<BUILDPATH>=. -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security

   I guess the only one likely to cause trouble are -fstack-protector and
   --param=ssp-buffer-size=4, which I can disable if needed

- three patches have been applied: the amd64 one you sent me, one for GNU/Hurd
  and another on HTML doc. See them at:


⢀⣴⠾⠻⢶⣦⠀  Sébastien Villemot
⣾⠁⢠⠒⠀⣿⡁  Debian Developer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <>

More information about the pkg-common-lisp-devel mailing list