[Pkg-cups-devel] Bug#647137: cannot print with upcated cups via usb, ipp or dnssd: print file not accepted

cfr ReesCF at gmail.com
Sun Oct 30 19:58:59 UTC 2011

Package: cups
Version: 1.5.0-8
Severity: important

* What led up to the situation?
I _think_ it is due to an update of cups but since I'm not sure exactly
when I stopped being able to access printers, I cannot be absolutely
positive. Certainly it did work with earlier versions of cups in wheezy
and it fairly comprehensively doesn't work now.

* What exactly did you do (or not do) that was effective (or ineffective)?
I think this question is asking me what I tried to do to resolve the
I tried purging hplip-cups etc. and printing to a non-HP printer without
reinstalling. (I've now reinstalled the stuff for HPs.) 
I've tried deleting and reinstalling printers multiple times. I've tried
installing via the desktop printing setup stuff and via the CUPS web
I've tried printing to an HP via USB (HP P2014). This did work. No
longer. (The first thing which went wrong was it printing pages of
garbage at the end of a job. Now that looks like an idyllic situation -
at least something happened!)
I've tried printing to a networked Dell (2330dn) using dnssd. (I get
three options. I think I've tried them all. I've definitely tried the
one which my mother's eMac uses to print with Squeeze.) I've tried ipp.
I've tried various ways of specifying the host - name, ip address etc.
I've also tried different drivers. I usually just use the generic
postscript driver which was working fine but I also downloaded Dell's
printer-specific ppd file and tried with that. (I used the "Global PPD
specific to the 2330dn for Linux.)
I've also tried deleting /var/cache/cups (following a hint found by
I've also tried having aptitude reinstall cups, cups-bsd etc.
I've confirmed that the Dell, at least, will still print from my
mother's machine running Squeeze with the same generic postscript driver
I had selected.

* What was the outcome of this action?
Nothing I do makes any difference. Every print job fails. The printer
will not accept the file. That's the message. The further errors seem to
vary (possibly depending partly on which wild strategy I'm currently
trying). "cups-ipp-wrong-http-version" seems to be quite a common
complaint, though. (I suspect some of the others are actually due to my
fiddling in ways which likely invalidated my setup in my attempts to try
changing anything and everything.)

* What outcome did you expect instead?
Print prints the file sent to it. That is, cups spools the job, sends it
to the printer, the printer springs to life, things whir, bits of dead
tree have small amounts of black stuff spread over them in appropriate
patterns and a printed page emerges for observers' edification. (I'm a
bit hazy on the details here, I admit.)

I did look through the other bug reports and read many of them but none
seem to be quite the same. But there were 218 so I apologise if I've
overlooked something.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (990, 'testing'), (600, 'unstable')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.39-2-powerpc
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=ANSI_X3.4-1968) (ignored: LC_ALL set to C)
Shell: /bin/sh linked to /bin/dash

Versions of packages cups depends on:
ii  adduser                3.113           
ii  bc                     1.06.95-2       
ii  cups-client            1.5.0-8         
ii  cups-common            1.5.0-8         
ii  cups-ppdc              1.5.0-8         
ii  debconf [debconf-2.0]  1.5.40          
ii  ghostscript            9.04~dfsg-2     
ii  libavahi-client3       0.6.30-5        
ii  libavahi-common3       0.6.30-5        
ii  libc6                  2.13-21         
ii  libcups2               1.5.0-8         
ii  libcupscgi1            1.5.0-8         
ii  libcupsdriver1         1.5.0-8         
ii  libcupsimage2          1.5.0-8         
ii  libcupsmime1           1.5.0-8         
ii  libcupsppdc1           1.5.0-8         
ii  libdbus-1-3            1.4.16-1        
ii  libgcc1                1:4.6.1-15      
ii  libgnutls26            2.12.11-1       
ii  libgssapi-krb5-2       1.9.1+dfsg-1    
ii  libijs-0.35            0.35-8          
ii  libkrb5-3              1.9.1+dfsg-1    
ii  liblcms1               1.19.dfsg-1+b1  
ii  libldap-2.4-2          2.4.25-3        
ii  libpam0g               1.1.3-4         
ii  libpaper1              1.1.24+nmu1     
ii  libpoppler13           0.16.7-2+b1     
ii  libslp1                1.2.1-7.8       
ii  libstdc++6             4.6.1-15        
ii  libusb-0.1-4           2:0.1.12-19     
ii  lsb-base               3.2-28          
ii  poppler-utils          0.16.7-2+b1     
ii  procps                 1:3.2.8-11      
ii  ssl-cert               1.0.28          
ii  ttf-freefont           20100919-1      
ii  zlib1g                 1:

Versions of packages cups recommends:
ii  avahi-daemon            0.6.30-5   
ii  colord                  0.1.11-1   
ii  cups-driver-gutenprint  5.2.7-2    
ii  foomatic-filters        4.0.9-1    
ii  ghostscript-cups        9.04~dfsg-2

Versions of packages cups suggests:
ii  cups-bsd                                   1.5.0-8        
ii  cups-pdf                                   2.6.1-1        
ii  foomatic-db-compressed-ppds [foomatic-db]  20110831-1     
ii  hplip                                      <none>         
ii  smbclient                                  2:3.5.11~dfsg-2
ii  udev                                       172-1          

-- Configuration Files:
/etc/cups/cupsd.conf [Errno 13] Permission denied: u'/etc/cups/cupsd.conf'

-- debconf information:
* cupsys/raw-print: false
* cupsys/backend: ipp, lpd, serial, socket, usb, snmp, dnssd

More information about the Pkg-cups-devel mailing list