[pkg-dhcp-devel] Bug#592361: Bug#592361: libcrypto.so.0.9.8 accessed before /usr is mounted

Andrew Pollock apollock at debian.org
Thu Oct 21 17:16:59 UTC 2010

On Wed, Oct 20, 2010 at 11:01:06PM +0100, Simon McVittie wrote:
> A possible patch follows.
>     S

Dude. Thank you so much for this patch. I've been lacking the time to dive
into this particular bug. Unfortunately, I've been unable to get a
successful build.

./configure: line 5723: syntax error near unexpected token `OPENSSL,'
./configure: line 5723: `		PKG_CHECK_MODULES(OPENSSL, openssl)'
make: *** [patched-ldap/build-stamp] Error 2

on the face of it, it looks like your patch uncomments
PKG_CHECK_MODULES(OPENSSL, [openssl]), which was previously commented out in
the LDAP patch. This seems to be what's angering the build.
I spent a considerable amount of time this evening tweaking patches, until I
got to the point where I essentially had your patches, but with the above
line still commented out. The build still failed. It looked like it couldn't
find the symbols that had previously been found in libcrypto.

I tried a build that omitted the LDAP stuff entirely, and just pulled out
libcrypto, and that worked fine. I'm at a bit of a loss. But I have done the
hard work that I'd been failing to find time to do, so I'll continue poking
at this as time permits.

I have a largish upload pending in the Git repository for this package, I
just want to address this RC bug in that upload. You can see it at
http://git.debian.org/?p=pkg-dhcp/isc-dhcp.git;a=summary if you want to try
any additional patches.

More information about the pkg-dhcp-devel mailing list