[pkg-dhcp-devel] Bug#760170: Reproduced with sysvinit

Michael Gilbert mgilbert at debian.org
Mon Jan 19 08:10:17 UTC 2015

control: found -1 4.1.1-P1-15
control: tag -1 help, confirmed

On Sat, Jan 17, 2015 at 10:01 AM, Neil Williams wrote:
> forcemerge 760170 755834
> thanks
> Reproduced trivially with a sysvinit system:

I decided to spend some time to figure out what exactly regressed from
wheezy, but surprisingly found the issue there as well.  So then I
tried squeeze and found the same thing.  I didn't try going back
further, but I'm guessing it will be the same.  Starting the dhcp
server without some upfront configuration probably never worked.

Historically, I think the expectation was for the user to provide an
appropriate configuration upfront.  The fact that causes the package
to fail to install is rather unusual and sure wrong, but somehow there
were no bug reports even though the problem was present for at least
the past two stable releases???

Have expectations today changed?  What should the server do if the
user hasn't configured it?

Andrew, do you have any historical knowledge about this?

Best wishes,

More information about the pkg-dhcp-devel mailing list