[Pkg-fedora-ds-maintainers] Bug#820820: 389-admin: Registration fails because shared library "libsoftokn3.so" is not installed

Adam Reece adam at svencoop.com
Tue Apr 12 19:31:32 UTC 2016

Package: 389-admin
Version: 1.1.35-2
Severity: important

Dear Maintainer,

   * What led up to the situation?

	Using the directory server registration process, "register-ds-admin". The final part where the configuration gets built fails.

   * What exactly did you do (or not do) that was effective (or

	Tried symlinking to an i386 build of the same library as described in bug report #737214.
	Tried adding library path "/usr/lib/x86_64-linux-gnu/nss" as described in a patch for bug report #737214.

   * What was the outcome of this action?

	Symlink to i386 build: No change, still fails.
	Adding library path: Looks like some of the configuration built, but not all of it. (HTTP server process failed to start because of the same missing library.)

   * What outcome did you expect instead?

	Directory server registration to be completed with the administration tool.

-- System Information:
Debian Release: 8.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages 389-admin depends on:
ii  389-ds-base  
ii  apache2                2.4.10-10+deb8u4
ii  debconf [debconf-2.0]  1.5.56
ii  libadminutil0          1.1.20-1
ii  libapache2-mod-nss     1.0.10-3
ii  libc6                  2.19-18+deb8u4
ii  libds-admin-serv0      1.1.35-2
ii  libicu52               52.1-8+deb8u3
ii  libldap-2.4-2          2.4.40+dfsg-1+deb8u2
ii  libmozilla-ldap-perl   1.5.3-2+b1
ii  libnspr4               2:4.10.7-1+deb8u1
ii  libnspr4-0d            2:4.10.7-1+deb8u1
ii  libnss3                2:3.17.2-1.1+deb8u2
ii  libnss3-1d             2:3.17.2-1.1+deb8u2
ii  libnss3-tools          2:3.17.2-1.1+deb8u2
ii  libsasl2-2             2.1.26.dfsg1-13+deb8u1
ii  multiarch-support      2.19-18+deb8u4

389-admin recommends no packages.

389-admin suggests no packages.

-- Configuration Files:
/etc/dirsrv/admin-serv/console.conf changed:
<IfModule !mpm_winnt.c>
<IfModule !mpm_netware.c>
User dirsrv
Group dirsrv
<IfModule !mpm_netware.c>
PidFile /var/run/dirsrv/admin-serv.pid
HostnameLookups off
CustomLog /var/log/dirsrv/admin-serv/access common
ErrorLog /var/log/dirsrv/admin-serv/error
NSSEngine off
NSSNickname server-cert
NSSCertificateDatabase /etc/dirsrv/admin-serv
NSSCipherSuite +rsa_rc4_128_md5,+rsa_rc4_128_sha,+rsa_3des_sha,-rsa_des_sha,-rsa_rc4_40_md5,-rsa_rc2_40_md5,-rsa_null_md5,-rsa_null_sha,+fips_3des_sha,-fips_des_sha,-fortezza,-fortezza_rc4_128_sha,-fortezza_null,-rsa_des_56_sha,-rsa_rc4_56_sha,+rsa_aes_128_sha,+rsa_aes_256_sha
NSSProtocol SSLv3,TLSv1
NSSVerifyClient none

-- no debconf information
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0xCF9CD88D.asc
Type: application/pgp-keys
Size: 4615 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-fedora-ds-maintainers/attachments/20160412/9707fede/attachment.key>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-fedora-ds-maintainers/attachments/20160412/9707fede/attachment.sig>

More information about the Pkg-fedora-ds-maintainers mailing list