[Pkg-firebird-general] fb2 packages ready for testing

Grzegorz B. Prokopski gadek@debian.org
Sun, 27 Jun 2004 21:54:24 -0400

W li¶cie z nie, 27-06-2004, godz. 21:31, Remco Seesink pisze: 
> > Hi all
> > 
> > http://debian.sente.pl/fb2
> > 
> > There are sources of packages and debs compiled
> > for debian woody.
> > Tomorrow I will compile it on sarge.
> > Please test it and give me a feed back -
> > what in your opinion is lacking to finish them.
> Great! 
> You may want to add this build dependency:
> docbook-to-man
> I just tried compiling on sarge and sid. It fails on both
> in the same way on compiling super with this in the end of the log:
> Which doesn't happen when this:
> ------------------------------------------------------------
> --- firebird2-1.5.0.orig/builds/posix/prefix.linux
> +++ firebird2-1.5.0/builds/posix/prefix.linux
> @@ -22,7 +22,7 @@
>  # -fno-builtin is used because GCC 3.0-3.2.2 had bug with builtins expansion
>  # you may remove it if engine is getting compiled with any other GCC version
> -PROD_FLAGS=-ggdb -O3 -march=i586 -mcpu=i686 -fno-omit-frame-pointer -fno-builti
> +PROD_FLAGS=-ggdb -O3 -march=i486 -mcpu=i486 -fno-omit-frame-pointer -fno-builti
>  DEV_FLAGS=-ggdb -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -p -fPIC -Wall -Wno-switch
>  OS_ServerFiles=inet_server.cpp
> ------------------------------------------------------------
> isn't applied.

OK, let's skip it for now.  We *are* allowed to declare that FB2 debian
packages work only on i686 and up, *if* this is actually impossible/too
hard to compile and run it on older CPUs.  Can you at least try i586? 
We should stick to the lowest working option and document it in
debian/Debian.README (remember that woody and sarge/sid use compilers
from different "ages", so it might work on Woody but not Sarge/SID)

>  Without it it fails on this:
> ------------------------------------------------------------
> # Add here commands to install the package into debian/firebird2.
> ./debian/make_packages.sh
> make: execvp: ./debian/make_packages.sh: Permission denied
> make: *** [install] Error 127
> debuild: fatal error at line 763:
> dpkg-buildpackage failed!
>  make_packages.sh 
> ------------------------------------------------------------
> because make_packages.sh is not set executable? Strange it worked on woody.

This is normal [*] When you unpack the sources, the only executable
in ./debian/ is the "rules" file.  But when you're packaging the stuff,
it's easy to omit/forget to do "chmod +x ./debian/something" i.e. in
clean: target of debian/rules, under the assumption, that if you changed
the executable bit in your copy - it will be preserved.  AFAIR diff
format does not specify execution bits and whole ./debian content is
transported as a diff.gz after all.  This is therefore job of
dpkg-source to set the execution bit after unpacking.



[*] I did it myself too many times ;-)

Grzegorz B. Prokopski      <gadek@debian.org>
Debian GNU/Linux           http://www.debian.org
SableVM - LGPL'ed Java VM  http://www.sablevm.org
Why SableVM ?!?            http://devel.sablevm.org/wiki/Features