Bug#712712: gnash: Doesn't play YouTube's video of RMS singing the Free Software Song (or any other)

Kingsley G. Morse Jr. kingsley at loaner.com
Mon Oct 7 02:08:44 UTC 2013

Hi Gabriele,

Yes, I thought about full-upgraded-ing my system

However, I humbly suggest that even if it worked,
we'd be none the wiser about which dependency
was wrong.

> >> Does it work if you switch to gstreamer media
> >> handler (default is ffmpeg)?
> >
> > Unfortunately, no.
> Does it behave same way?  Do logs report "buffer
> overruns" again?

Yes and yes.


    1.) is that to be expected with gstreamer
        media handler, and

    2.) if not, do you happen to know if there's a
        way to verify that gnash actually uses

> Just to exclude browser, what happens if you run:
> $ gnash -vvv http://www.youtube.com/v/9sJUDx7iEJw?version=2

That's a clever idea.

It elicited new diagnostic info.

A screen shot is attached.

It also performed slightly differently.


    1.) only the gray pre-load/buffering bar
        progressed rightward, and

    2.) the playback window froze on one of the
        first few frames.

Now, if I recall correctly, 

    1.) the round and lighter colored button
        indicating how much of the video has
        played back also moved to the right, and

    2.) the video's playback window was blank.

The new diagnostic info included

    ERROR: Upgrading ffmpeg/libavcodec might fix this issue

so I tried

    $ aptitude install ffmpeg

which upgraded to the following

    libavutil52:i386    9:1.2.4-dmo1
    libopus0            1.1~beta-3
    libx264-138:i386    3:0.138.2356+gita1d3d17-dmo1
    libavcodec54:i386   9:1.2.4-dmo1
    libavformat54:i386  9:1.2.4-dmo1
    libpostproc52:i386  9:1.2.4-dmo1
    libswresample0:i386 9:1.2.4-dmo1
    libswscale2:i386    9:1.2.4-dmo1
    libavfilter3:i386   9:1.2.4-dmo1
    libavdevice54:i386  9:1.2.4-dmo1
    ffmpeg              9:1.2.4-dmo1

The new errors went away, and the same old buggy
behavior and buffer overruns returned.

If you happen to have the time, and are so
inclined, I'd be interested in your current


Time is the fire in which we all burn.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: screen_shot_when_gnash_run_at_command_line.png
Type: image/png
Size: 58681 bytes
Desc: gnash at CLI before upgrading
URL: <http://lists.alioth.debian.org/pipermail/pkg-flash-devel/attachments/20131006/3c9ef503/attachment-0001.png>

More information about the pkg-flash-devel mailing list