[pkg-fso-maint] works, don't know why Re: No USB connection to NEO with Debian

Steffen Moeller steffen_moeller at gmx.de
Tue Feb 3 23:01:31 UTC 2009

Dear Luca, dear Joachim,

to start with the end: I cannot reproduce what I have originally reported for the moment.
My latest symptom is a long delay for the ssh login prompt that seems invariant of the
modules already added and does not go away with subsequent attempts. I cannot recall to
have observed this afternoon when I first reported that is works. Maybe the delay with the
login also disappears soon again. I apologize for the apparent noise.

Some more details on what I tried I have summarised below. I'll summarise my experiences
in a few days again.



Luca Capello wrote:

> On Tue, 03 Feb 2009 19:10:33 +0100, Steffen Moeller wrote:
>> Joachim Breitner wrote:
>>> Am Dienstag, den 03.02.2009, 01:49 +0100 schrieb Steffen Moeller:
>>>> having booted to Debian, the call to
>>>> ifconfig usb0 netmask
>>>> gave me that there was no device found.

I was unclear in my original report. The ifconfig line was executed on the host machine,
the one that is directly connected to the internet. And maybe worse, I have not seen it
for a while. Maybe because I had tried it with the OpenMoko kernel first (to change
seetings in the mounted Debian SD). I'll investigate.

> The ifconfig call should not be needed, because the default
> /etc/network/interfaces on Debian is:
>   # Ethernet/RNDIS gadget (g_ether)
>   # ... or on host side, usbnet and random hwaddr
>   auto usb0
>   iface usb0 inet static
>           address
>           netmask
>           network
>           gateway
>           up echo nameserver >/etc/resolv.conf
> The first non-commented line means that the interface should be
> automatically configured and brought up at boot time.

My first report referred to the host machine, my later report about ifconfig -a referred
to the neo.

> Which kernel do you use?

I executed the install.sh script, chrooted into Debian's root, then installed the openmoko
kernel via apt-get.

That Debian kernel version is 2.6.24-20081103 from Dec 17 2008.

>> This is in Debian
> [...]
>> The ifconfig -a looks just fine. The device usb0 is there.
> Sorry, but in your first mail you wrote that the ifconfic call "gave me
> that there was no device found" and now you said that the usb0 device is
> there :-(

Explained above: first host, second neo.

>> I then added what is in the /etc/modules but not in the Debian one
>> ipc6   # with the typo, this hence cannot be the culprit
>> rfcomm
>> hidp
> None of them are needed for USB networking to work.

I have googled them in the meantime. And am surprised. In one of my last sessions I had
installed ping on the neo (which might also be nice to be installed via the install.sh
script ?) and found that I can ping the host. And (no idea why) the converse from host to
neo also worked. Still, ssh just stalled, while it was immediately up on the other system.
And just by sheer frustration, I tried sshing from the neo to the host, and it worked
immediately. But from the host to the neo, it only go up to

ssh neo -v
OpenSSH_5.1p1 Debian-5, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to neo [] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1

this point. Then I started writing this reply, while I was busy writing this email, all of
a sudden, ssh continued. And with some more reboots down the line, I can confirm, it still
works with none of the modules added.

debug1: Remote protocol version 2.0, remote software version dropbear_0.52
debug1: no match: dropbear_0.52
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: sending SSH2_MSG_KEXDH_INIT
debug1: expecting SSH2_MSG_KEXDH_REPLY
debug1: Host 'neo' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:13
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Next authentication method: password
root at neo's password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = de_DE.UTF-8
Linux debian-gta02 2.6.24-20081103.git7172ec57 #1 PREEMPT Wed Dec 17 18:06:43 UTC 2008 armv4tl

More information about the pkg-fso-maint mailing list