[pkg-fso-maint] [wicd] interim report

gregor herrmann gregoa at debian.org
Fri Feb 20 02:01:14 UTC 2009

On Fri, 20 Feb 2009 02:17:05 +0100, Steffen Moeller wrote:

> this is where I am for implementing Gregor's setup for wicd. My personal hunch is that it
> is not really installable from chroot. 


> Is this possibly a problem with the wicd package? It seems rather uninstallable via chroot:
> Setting up wicd (1.5.9-1) ...
> Reloading system message bus config...Failed to open connection to "system" message bus:
> Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
> invoke-rc.d: initscript dbus, action "force-reload" failed.
> dpkg: error processing wicd (--configure):
>  subprocess post-installation script returned error exit status 1
> Errors were encountered while processing:
>  wicd
> E: Sub-process /usr/bin/dpkg returned an error code (1)

Yup, that's from wicd's postinst:

        if [ -x "/etc/init.d/dbus" ]; then
            if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
                invoke-rc.d dbus force-reload || exit $?
                /etc/init.d/dbus force-reload || exit $?

> A
> major problem seems to me that wicd is started upon its installation, which is likely to
> be a problem to those who are installing via wifi, right? 

I just tried on my desktop, there the daemon is started at the end of

And it brought down my eth0 (wired interface) and restarted it (with
dhcp). Gnarf.

> > A problem might be that after installing wicd it starts the daemon,
> > probably before changing the config, and that would bring usb0 down.
> > Might be worth considering and testing for the installer :)
> The config file of wicd is not existing after the installation, 

It does, if the installation succeeds :)
If I'm not mistaken it's created at the first start of the daemon
which happens in the postinst (if the dbus reload succeeds).

I tried again:
aptitude purge wicd
[fix my networking]
mkdir /etc/wicd
echo "wired_interface =" >> /etc/wicd/manager-settings.conf
aptitude install wicd

Ok, /etc/wicd/manager-settings.conf is not changed. And/but the wicd
daemon is not running either. And can't be started manually

> Are you, Gregor, familiar with discussions around wicd and
> the freerunner on http://wicd.net/punbb/viewtopic.php?id=132 ?

No, thanks for the pointer.

After skimming though the page it doesn't seem relevant; the first
part is about handling the wired interface (which is a bad idea IMO),
and the rest is either about building the stuff or about changes for
dhcp which are not relevant for Debian.
> +case "$WITH_WIFI" in
> + "wicd")
> +       echo " * Installing wicd for wifi setup"
> +       if [ -r "$INST_DIR/etc/wicd/manager-settings.conf" ]; then
> +               echo "The file /etc/wicd/manager-settings.conf is already existing. This
> is not

... a full sentence :)

> +               echo "Please report to pkg-fso-maint at lists.alioth.debian.org."
> +               exit 1
> +       else

                  mkdir -p $INST_DIR/etc/wicd

> +               echo "wired_interface =" >> $INST_DIR/etc/wicd/manager-settings.conf
> +       fi

Anyway, I get the impression that this doesn't lead us anywhere ...


 .''`.   Home: http://info.comodo.priv.at/{,blog/} / GPG Key ID: 0x00F3CFE4
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT, SPI Inc., fellow of FSFE | http://got.to/quote/
   `-    NP: Bob Dylan: I Shall Be Released
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-fso-maint/attachments/20090220/d66d392c/attachment.pgp 

More information about the pkg-fso-maint mailing list