[pkg-fso-maint] Kernel and wifi

gregor herrmann gregoa at debian.org
Sat Feb 28 19:46:13 UTC 2009

On Sat, 28 Feb 2009 16:42:43 +0100, Christian Adams wrote:

> >> If I don't start wicd at boot time the results are:
> >> * lsmod shows ar6000 loaded.
> >> * No kernel oops so far.
> >> * I can start wicd and wicd-client.py later, without getting an oops;
> >>   but (as before) I have no eth0 device?!
> eth0 gets enabled via frameworkd (there is also another way via sysfs  
> i currently don't remember)

Ah, I didn't know that, thanks.
> > - should not this be ath0 or (which I would prefer) wlan0?

With 2.6.24 it's eth0, and I didn't find any hints for another name.

> > - can you check if udev has assigned a persistend ifname to the  
> > device,
> >   please?  Look at
> >     /etc/udev/rules.d/70-persistent-net.rules


# cat /etc/udev/rules.d/70-persistent-net.rules
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:12:cf:8f:08:56", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

> > - on my sid, after `ifconfig eth0 down` eth0 is no more showed by
> >   ifconfig, but it is /proc/net/dev ;-)

It wasn't when I looked yesterday but it is now?!

And I can start wicd manually (I enabled wifi with the icon in
openmoko-panel-plugin before).

> > I do not know, but at least you do not get anymore oops, which is a  
> > good
> > point.

Ack, but working wifi would be nice too :)
> test a)
> 	wicd not installed,
> 	usb-net connected,
> 	reboot
> 	----
> 	ar6000 was loaded automatically
> 	no krnl-oops
> 	eth0 appeared after 'enabling' via frameworkd
> 	ifup eth0 worked
> 	no probs found

Same here, except that I have wicd installed but not started.

But I could produce an oops later by combining manual "ifconfig eth0
down", activating wicd-client, and turning wifi on/off with o-p-p.
(Don't ask me how exactly ...)
> test b)
> 	wicd installed and started on boot
> 	usb-net not connected on boot (but later to easy work)
> 	reboot
> 	----
> 	ar6000 was loaded automatically
> 	no krnl-oops
> 	eth0 appeared after 'enabling' via frameworkd
> 	ifup eth0 worked
> 	eth0 comes up even when manually rmmod ar6000 when enabling via  
> frameworkd

I tried again now with wicd activated but with the usb cable
unplugged. Result: kernel oops, no GSM, no network via usb, o-p-p
doesn't respond, ...

If I boot with the usb cable connected I can at least ssh into the
freerunner and see when the oops happens.

Removing /etc/udev/rules.d/70-persistent-net.rules doesn't help, as
expected the file gets regenerated (with the same contents).

Purging and re-installing wicd (to get a clean config) and unsetting
the wired interface in wicd + manually down/upping usb0 leads to a
working system - if I then disable wifi in o-p-p I get the oops

Setting wifi to inactive in o-p-p doesn't change anything either.

/me is giving up for now and gets some food

 .''`.   Home: http://info.comodo.priv.at/{,blog/} / GPG Key ID: 0x00F3CFE4
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT, SPI Inc., fellow of FSFE | http://got.to/quote/
   `-    NP: Joan Baez: The Boxer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-fso-maint/attachments/20090228/5f56bc36/attachment.pgp 

More information about the pkg-fso-maint mailing list