[pkg-fso-maint] Bug#766114: fso-deviced: uninstallable in i386/amd64/armhf

hikaru hikaru.debian at web.de
Mon Oct 20 22:33:51 UTC 2014

Package: fso-deviced
Version: 0.12.0-2
Severity: grave
Justification: renders package unusable

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

I suspect fso-deviced isn't fit/wasn't properly ported to systemd since it
installed and worked fine before the transition on two of the three systems I
confirmed this bug on (VBOX-VMs running Jessie i386/amd64)

   * What exactly did you do (or not do) that was effective (or

In the afore mentioned VMs and on a Nokia N900 (armhf) I ran
apt-get update && apt-get dist-upgrade
apt-get install fso-deviced

   * What was the outcome of this action?

# apt-get install fso-deviced
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Recommended packages:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/157 kB of archives.
After this operation, 722 kB of additional disk space will be used.
Selecting previously unselected package fso-deviced.
(Reading database ... 60310 files and directories currently installed.)
Preparing to unpack .../fso-deviced_0.12.0-2_i386.deb ...
Unpacking fso-deviced (0.12.0-2) ...
Processing triggers for dbus (1.8.8-2) ...
Processing triggers for man-db ( ...
Setting up fso-deviced (0.12.0-2) ...
Job for fso-deviced.service failed. See 'systemctl status fso-deviced.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript fso-deviced, action "start" failed.
dpkg: error processing package fso-deviced (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
root at debian:/home/branan# systemctl status fso-deviced.service
● fso-deviced.service - LSB: freesmartphone.org device daemon
   Loaded: loaded (/etc/init.d/fso-deviced)
   Active: failed (Result: exit-code) since Tue 2014-10-21 00:21:04 CEST; 5s ago
  Process: 9823 ExecStart=/etc/init.d/fso-deviced start (code=exited, status=1/FAILURE)

Oct 21 00:21:04 debian fso-deviced[9823]: Starting freesmartphone.org device daemon : fso-deviced failed!
Oct 21 00:21:04 debian systemd[1]: fso-deviced.service: control process exited, code=exited status=1
Oct 21 00:21:04 debian systemd[1]: Failed to start LSB: freesmartphone.org device daemon.
Oct 21 00:21:04 debian systemd[1]: Unit fso-deviced.service entered failed state.

   * What outcome did you expect instead?

Successful installation and start of fso-deviced

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.16-2-686-pae (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages fso-deviced depends on:
ii  dbus               1.8.8-2
ii  libasound2         1.0.28-1
ii  libc6              2.19-11
ii  libfso-glib2       2012.07.27.2-2
ii  libfsobasics3      0.12.0-5
ii  libfsoframework3   0.12.0-5
ii  libfsoresource3    0.12.0-5
ii  libgee-0.8-2       0.14.0-3
ii  libglib2.0-0       2.42.0-2
ii  multiarch-support  2.19-11

Versions of packages fso-deviced recommends:
pn  fso-deviced-platform  <none>

fso-deviced suggests no packages.

-- no debconf information

More information about the pkg-fso-maint mailing list