Bug#579628: libgstreamer-plugins-base0.10-0: build dependency on theora should have a version (1.1.1)

Sebastian Dröge slomo at circular-chaos.org
Thu Apr 29 09:42:55 UTC 2010

On Thu, 2010-04-29 at 11:26 +0200, Marc Leeman wrote:
> Package: libgstreamer-plugins-base0.10-0
> Version: 0.10.29-1
> Severity: serious
> Justification: no longer builds from source
> Backporting the latest release to Lenny and noticed that the lenny theora is not enough to compile the package.

It's supposed to be buildable with 1.0 beta3, which is exactly what is
in lenny. What's the error you get?

Snippet from configure.ac:
> dnl *** theora ***
> translit(dnm, m, l) AM_CONDITIONAL(USE_THEORA, true)
> AG_GST_CHECK_FEATURE(THEORA, [Xiph Theora video codec], theora, [
>   dnl theora uses pkg-config version incorrectly, for pkg-config:
>   dnl 1.0 < 1.0RCX < 1.0alphaX < 1.0betaX < 1.0.0
>   dnl theoraenc and theoradec appeared in 1.0beta3
>   AG_GST_PKG_CHECK_MODULES(THEORA, theoradec theoraenc)
> ])

But you're right, the build dependency should be updated to >= 1.0~beta3,
not that this would fix your problem ;)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/pkg-gstreamer-maintainers/attachments/20100429/b938ae93/attachment.pgp>

More information about the Pkg-gstreamer-maintainers mailing list