undefined symbol: lzo1x_decode

Norbert Veber nveber at debian.org
Sun Feb 13 05:31:23 UTC 2011


I'm having a strange problem with totem and vlc not being able to play xvid
files on lenny (oldstable).  Mplayer works fine though.

The problem seems related to this message:

$ totem

(totem:26259): GStreamer-WARNING **: Failed to load plugin
'/usr/lib/gstreamer-0.10/libgstffmpeg.so': /usr/lib/libavcodec.so.51:
undefined symbol: lzo1x_decode
nveber at pyre[616:~]$ dpkg -S /usr/lib/libavcodec.so.51
libavcodec51: /usr/lib/libavcodec.so.51
nveber at pyre[617:~]$ dpkg -s libavcodec51 | grep Vers
Version: 0.svn20080206-18+lenny1

I thought this might be related to having some debian-multimedia.org
packages on my system, so I un-installed them, but still no luck.  I
tried searching for any unofficial packages by using the aptitude
display limit: "!~Aoldstable".  Only some python stuff showed up that I
installed from squeeze.  Is there a known issue in lenny, or how can I
track down what the problem might be?



More information about the pkg-gstreamer-maintainers mailing list