Bug#873343: gstreamer1.0-vaapi: Does not work with Wayland

Tony Houghton h at realh.co.uk
Mon Aug 28 19:16:22 UTC 2017

retitle 873343 Hard crash attempting to use vaapivp8encoder
On Mon, 2017-08-28 at 17:06 +0200, Víctor Jáquez wrote:
> >
> >There are several bugs related to this:
> >
> >https://bugzilla.gnome.org/show_bug.cgi?id=784429
> >https://bugzilla.gnome.org/show_bug.cgi?id=783169
> >https://bugzilla.gnome.org/show_bug.cgi?id=781972
> >This is another issue, when using vaapisink with mutter:
> >
> >https://bugzilla.gnome.org/show_bug.cgi?id=775698
OK, thanks. I guess I could have tried harder to find these, but not 
much was showing up in Google, and I wasn't sure whether it was 
>> >> opengl-backend=wayland
>> >> vo=opengl
>> >> hwdec=vaapi
> >
> >This is like if you were doing this:
> >
> >GST_GL_WINDOW=wayland gst-play-1.0 /home/tony/Videos/paul.mkv -- > 
> videosink=glimagesink
> >
> >And it should work.
Sort of... I get some sort of picture, but it flickers badly, and I 
think it keeps alternating between the first frame and current frame. So 
it could be a deinterlacing issue, because it's a clip from a DVB 
recording, which is 1080i AFAIK. Then it segfaults at the end of the clip.
> >I also tried to make green-recorder (an alternative front-end for
> > GNOME's screencast feature) use vaapiv8enc and the system
[Correction: vaapivp8enc. ^^]
> > completely froze. I don't know if that has the same underlying> cause.
Judging by the links you posted, I think this is a separate issue, so 
it's probably worth keeping this ticket open for it, with a more 
specific title.

More information about the pkg-gstreamer-maintainers mailing list