Bug#866339: gstreamer1.0-plugins-ugly: fails to play mp3 files

Sebastian Dröge slomo at debian.org
Thu Jun 29 05:38:10 UTC 2017

On Thu, 2017-06-29 at 00:17 +0200, Martin Bergström wrote:
> Package: gstreamer1.0-plugins-ugly
> Version: 1.12.1-1
> Severity: normal
> (I am not confident diagnosing gstreamer issues, so please bear with me.)
> Other formats like ogg and flac works fine. Also non-gstreamer players 
> can play
> mp3 files.
> There is an error message in Quod Libet and Totem when attempting to 
> play mp3
> files. Totem says "MPEG-1 Layer 3 (MP3) decoder is required to play the 
> file,
> but it is not installed."
> gstreamer was recently upgraded to 1.12.1-1. (I think the problem manifested
> also in 1.10.4-1 but I might have that wrong.) It worked a couple a 
> weeks ago on  this machine running up-to-date "testing".
> 1.10.4-1 depends on libmad0 but 1.12.1-1 does not.
> libmad0 0.15.1b-8 is installed to satisfy dependencies of other packages.

1.12.1 does not have the mad plugin anymore but uses mpg123 instead. Is
your problem maybe that you had gst-plugins-ugly 1.12.1 installed
together with libgstreamer1.0-0 1.10 before?

You can check with
 $ gst-inspect-1.0 -b

Are any plugins blacklisted? If so, now that all versions are in sync
again you could try deleting
and then try again.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 963 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/pkg-gstreamer-maintainers/attachments/20170629/0664d8eb/attachment.sig>

More information about the pkg-gstreamer-maintainers mailing list