[Pkg-ime-devel] Bug#652040: Bug#652040: ibus doesn't recognize gtk windows

Osamu Aoki osamu at debian.org
Wed Dec 14 13:14:04 UTC 2011

On Wed, Dec 14, 2011 at 09:37:21PM +0900, Douglas P Perkins wrote:
> Package: ibus
> Version: 1.4.0-2

I know this is high risk upload. 

> Severity: important

Important for you but I can not reproduce this.

> Tags: l10n

This tag usage is wrong.  No bug in translation.

> Dear Maintainer,


> I have used ibus for a while to do Japanese input.  I currently have
> installed ibus, ibus-gtk, ibus-gtk3, ibus-qt4, and dependencies of
> these.  

Japanese with mozc or anthy or skk ??  (I use ibus-mozc)

> Until late last week, Japanese input worked as expected.  I updated to
> the most recent version if ibus, 1.4.0-2, and I believe this broke
> something in ibus-gtk or ibus-gtk3.  I've tried several things,
> including recreating ibus config files, but I cannot get ibus to work
> for many of my applications.

Hmmm... this is working OK here ... but this was big multi-arch upgrade.
Did you upgraded whole system to sid? 

> It works fine for LibreOffice and choqok.  However, it doesn't work
> for Terminal, Firefox, Gwaei, Claws-mail, or Bluefish (these are the
> only apps I've tested).  

Which terminal?  I use gnome-terminal-emulator and works fine.

> For these applications, I start the
> application (when ibus is already running), and when I click on the
> ibus icon in the taskbar, it shows only "No input window."

This is strange.  What does the icon's right click "about" menu tells you?

Do you have any other IM installed?

Did you try activating ibus with CTRL-SPACE or ALT-` ,...
> I speculate that there's something strange in 1.4.0-2 that is causing
> a problem somehow.

Strange but with this much info, I can do so much.  I know you are
facing problem but you have not given me enough to investigate further.

> Versions of packages ibus recommends:
> ii  ibus-clutter  <none>
> ii  ibus-gtk      1.4.0-2
> ii  ibus-gtk3     1.4.0-2
> ii  ibus-qt4      1.3.1-2+b1
> ii  im-config     0.7

Looks good here.


More information about the Pkg-ime-devel mailing list