[Pkg-ime-devel] Bug#652040: Bug#652040: ibus doesn't recognize gtk windows

bugs at dperkins.org bugs at dperkins.org
Wed Dec 14 13:51:30 UTC 2011

Perhaps my partial upgrade is leading to the problem.  Details below.
Thanks for your help!


On Wed, 14 Dec 2011 22:14:04 +0900
Osamu Aoki <osamu at debian.org> wrote:

> On Wed, Dec 14, 2011 at 09:37:21PM +0900, Douglas P Perkins wrote:
> > Package: ibus
> > Version: 1.4.0-2
> I know this is high risk upload.
> > Severity: important
> Important for you but I can not reproduce this.
> > Tags: l10n
> This tag usage is wrong.  No bug in translation.

Sorry, my mistake.

> > Dear Maintainer,
> Hi,
> > I have used ibus for a while to do Japanese input.  I currently 
> have
> > installed ibus, ibus-gtk, ibus-gtk3, ibus-qt4, and dependencies of
> > these.
> Japanese with mozc or anthy or skk ??  (I use ibus-mozc)

Japanese with anthy.  I will try mozc, but haven't done so yet.

> > Until late last week, Japanese input worked as expected.  I updated
> > to the most recent version if ibus, 1.4.0-2, and I believe this
> > broke something in ibus-gtk or ibus-gtk3.  I've tried several
> > things, including recreating ibus config files, but I cannot get
> > ibus to work for many of my applications.
> Hmmm... this is working OK here ... but this was big multi-arch
> upgrade. Did you upgraded whole system to sid?

I am not completely upgraded, because of some conflicts (ibus is not 
conflicting with anything here -- some other packages are).  Perhaps 
this is what is causing the problem.  Here is what will be upgraded and 
installed when I deal with the conflicts.

The following NEW packages will be installed:
   accountsservice{a} apg{a} dconf-service{a} gir1.2-clutter-gst-1.0{a}
   gir1.2-evince-3.0{a} gir1.2-gst-plugins-base-0.10{a}
   gir1.2-gtkclutter-1.0{a} gir1.2-gtksource-3.0{a} gir1.2-sushi-1.0{a}
   glib-networking-common{a} glib-networking-services{a}
   gnome-control-center-data{ab} gnome-icon-theme-symbolic{a}
   gnome-screensaver{a} gnome-sushi{a} gnome-sushi-common{a}
   gstreamer0.10-pulseaudio{a} gvfs-common{a} gvfs-daemons{a} 
   libaccountsservice0{a} libasound2-plugins{a} libbrasero-media3-1{a}
   libclutter-gst-1.0-0{a} libclutter-gtk-1.0-0{a} libdconf0{a}
   libevince3-3{ab} libgjs0b{a} libglib2.0-bin{a}
   libgnome-control-center1{a} libgnome-desktop-3-2{a}
   libgnome-media-profiles-3.0-0{a} libgnomekbd7{a}
   libgtksourceview-3.0-0{a} libgtksourceview-3.0-common{a}
   libmetacity-private0a{ab} libnautilus-extension1a{ab}
   libpackagekit-glib2-14{a} libsushi-1.0-0{a} 
   libvte-2.90-common{a} mousetweaks{a} pulseaudio{a}
   pulseaudio-esound-compat{a} pulseaudio-module-x11{a} 
   python-gi{a} python-gobject-2{a} rtkit{a}
The following packages will be upgraded:
   brasero brasero-common dconf-gsettings-backend evolution 
   evolution-plugins gdm3 gir1.2-freedesktop gir1.2-glib-2.0 
   glib-networking gnome-control-center gnome-desktop3-data 
   gnome-media gnome-power-manager gnome-settings-daemon gnome-terminal
   gnome-terminal-data gnome-utils-common gvfs gvfs-backends gvfs-fuse 
   libevolution libgail-3-0 libgdict-1.0-6 libgirepository-1.0-1
   libglib2.0-0 libglibmm-2.4-1c2a libgtk-3-0 libgtk-3-bin 
   libgtkmm-3.0-1 libpurple0 libseed-gtk3-0 libsoup-gnome2.4-1 
   libvte-2.90-9 libvte-common libvte9 metacity nautilus nautilus-data
   pidgin pidgin-data python-gobject upower
The following packages are RECOMMENDED but will NOT be installed:
48 packages upgraded, 49 newly installed, 0 to remove and 0 not 
Need to get 124 MB of archives. After unpacking 36.5 MB will be used.
The following packages have unmet dependencies:
   libgnome-desktop-3-0: Depends: gnome-desktop3-data (= 3.0.2-2) but 
3.2.1-3 is to be installed.
   libbrasero-media0: Depends: brasero-common (< 2.31) but 3.2.0-3 is to 
be installed.
   josm-plugins: Breaks: josm (>= 0.0.svn4488) but 0.0.svn4550+dfsg2-1 
is to be installed.
   libevince3-3: Breaks: libevince3 but 2.32.0-1 is installed.
   gnome-control-center-data: Conflicts: capplets-data but 1:2.30.1-3 is 
   libmetacity-private0a: Breaks: libmetacity-private0 but 1:2.34.1-1 is 
   libnautilus-extension1a: Conflicts: libnautilus-extension1 but 
2.30.1-3 is installed.

I'll figure out how to handle the conflicts, do the upgrade, and try it 

> > It works fine for LibreOffice and choqok.  However, it doesn't work
> > for Terminal, Firefox, Gwaei, Claws-mail, or Bluefish (these are 
> the
> > only apps I've tested).
> Which terminal?  I use gnome-terminal-emulator and works fine.

LXTerminal does not work.  lxterm works, though.

> > For these applications, I start the
> > application (when ibus is already running), and when I click on the
> > ibus icon in the taskbar, it shows only "No input window."
> This is strange.  What does the icon's right click "about" menu tells
> you?

IBus 1.4.0
IBus is an intelligent input bus for Linux/Unix.
Copyright (c) 2007-2010 Peng Huang
Copyright (c) 2007-2010 Red Hat, Inc.

> Do you have any other IM installed?


> Did you try activating ibus with CTRL-SPACE or ALT-` ,...

I've tried many variations.

> > I speculate that there's something strange in 1.4.0-2 that is
> > causing a problem somehow.
> Strange but with this much info, I can do so much.  I know you are
> facing problem but you have not given me enough to investigate
> further.
> >
> > Versions of packages ibus recommends:
> > ii  ibus-clutter  <none>
> > ii  ibus-gtk      1.4.0-2
> > ii  ibus-gtk3     1.4.0-2
> > ii  ibus-qt4      1.3.1-2+b1
> > ii  im-config     0.7
> Looks good here.
> Osamu

More information about the Pkg-ime-devel mailing list