[Pkg-ime-devel] Bug#770265: gir1.2-ibus-1.0: Re: gir1.2-ibus-1.0: fails to install in multiarch setting

Zack Orndorff zack at zackorndorff.com
Sat May 28 04:04:19 UTC 2016

Package: gir1.2-ibus-1.0
Version: 1.5.11-1
Followup-For: Bug #770265

Dear Maintainer,

(First of all, thanks to any Debian Developers that read this; you all do a ton
of awesome work!)

I'm also experiencing issue #770265, but I was able to sort of work around it,
so I figured I'd send some details in hopes that it will help you.

I'll go ahead and answer the reportbug template questions:

> What led up to the situation?

I was trying to compile OpenRCT2 from source on an amd64 system. OpenRCT2 only
compiles for i386, so I tried to install the packages the OpenRCT2 team
recommended. IIRC the one that depends on this package was libsdl2-dev:i386.

I already had libsdl2-dev:amd64 installed, and something in there is
incompatible, so with some work in aptitude, I managed to set it to remove the
correct packages to be able to install what I needed.

It installed normally until it went to set up gir1.2-ibus-1.0:i386, when I got
this error:

    Setting up gir1.2-ibus-1.0:i386 (1.5.11-1) ...
    dpkg-query: error: --listfiles needs a valid package name but 'gir1.2-ibus-1.0' is not: ambiguous package name 'gir1.2-ibus-1.0' with more than one installed instance

    Use --help for help about querying packages.
    Traceback (most recent call last):
      File "/usr/bin/py3compile", line 290, in <module>
      File "/usr/bin/py3compile", line 270, in main
        options.force, options.optimize, e_patterns)
      File "/usr/bin/py3compile", line 154, in compile
        for fn, versions_to_compile in filter_files(files, e_patterns, versions):
      File "/usr/bin/py3compile", line 106, in filter_files
        for fn in files:
      File "/usr/share/python3/debpython/files.py", line 71, in filter_public
        for fn in files:
      File "/usr/share/python3/debpython/files.py", line 53, in from_package
        raise Exception("cannot get content of %s" % package_name)
    Exception: cannot get content of gir1.2-ibus-1.0
    dpkg: error processing package gir1.2-ibus-1.0:i386 (--configure):
     subprocess installed post-installation script returned error exit status 1

> What exactly did you do (or not do) that was effective (or ineffective)?

I tried `sudo dpkg --configure -a`, but that gave me basically the same error.
So I did some googling and found that I could edit the postinst/prerm scripts in
/var/lib/dpkg/info. I found the following code (snippet) in
gir1.2-ibus-1.0:i386.prerm (IIRC):

    # Automatically added by dhpython:
    if which py3clean >/dev/null 2>&1; then
            py3clean -p gir1.2-ibus-1.0
            dpkg -L gir1.2-ibus-1.0 | perl -ne 's,/([^/]*)\.py$,/__pycache__/\1.*, or next; unlink $_ or die $! foreach glob($_)'
            find /usr/lib/python3/dist-packages/ -type d -name __pycache__ -empty -print0 | xargs --null --no-run-if-empty rmdir

    # End automatically added section

I figured the ambiguous package name was gir1.2-ibus-1.0, so I edited it to read
gir1.2-ibus-1.0:i386. I then made a similar change (with the architecture name
changed accordingly) to gir1.2-ibus-1.0:amd64.prerm,
gir1.2-ibus-1.0:i386.postinst, and the amd64 postinst.

> What was the outcome of this action?

After doing that, and undoing the various other things I did to try to solve the
issue, the package was configured correctly (at least as far as I can tell) by
running "sudo dpkg --configure gir1.2-ibus-1.0:i386", then "sudo dpkg
--configure -a".

I had messed around with removing various variations of the packages trying to
fix the problem, so I doubt I actually needed all those edits, but I'm guessing
something like that needs to be done to all of the scripts, maybe through

I'm not a Debian Developer, just a Linux nerd, so I'm not sure what the best
change to make is (although I doubt mine is a good one).

If there's anything I can do to make this clearer, or if I can test anything,
feel free to email you and I can probably give it a shot (although I'm not too
familiar with Debian packaging, so I may not be much help with testing).

Zack Orndorff

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.5.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gir1.2-ibus-1.0:amd64 depends on:
ii  gir1.2-glib-2.0        1.48.0-2
ii  libgirepository-1.0-1  1.48.0-2
ii  libibus-1.0-5          1.5.11-1
pn  python3:any            <none>

gir1.2-ibus-1.0:amd64 recommends no packages.

gir1.2-ibus-1.0:amd64 suggests no packages.

-- no debconf information

More information about the Pkg-ime-devel mailing list