[Pkg-ime-devel] Bug#865201: scim-chewing: please build-depend on automake, not obsolete automake1.11

Simon McVittie smcv at debian.org
Mon Jun 19 18:22:38 UTC 2017

Source: scim-chewing
Version: 0.5.1-1
Severity: normal
User: debian-qa at lists.debian.org
Usertags: automake1.11 automake1.11-only

This package Build-Depends on the obsolete automake1.11 package.

Please check whether this package can be built correctly with the
recommended automake version, as provided by the automake package
(currently version 1.15). If it can, please build-depend on automake
instead, with no automake1.11 alternative. automake (>= 1:1.11)
has been available since at least Debian 7 'wheezy' (oldoldstable).

If this package has an old build system, it is possible that it
will need build system changes for it to be able to autoreconf with
a current version of automake. If so, those changes should be
forwarded upstream. See `info automake Upgrading` or
for details. automake 1.15 was released in 2014 and is now widespread,
so most upstreams will probably not object to a dependency on
versions >= 1.15 at this point.

If automake1.11 is removed from Debian, this bug will become serious
(release-critical), since the Debian buildd infrastructure would be
unable to satisfy this package's build-dependencies. As far as I am
aware, there are no immediate plans to remove automake1.11.


More information about the Pkg-ime-devel mailing list