[Pkg-iscsi-maintainers] Bug#732587: debian expert install on iscsi-device

Ritesh Raj Sarraf rrs at debian.org
Thu Dec 19 10:08:52 UTC 2013

There has a half patch submitted for open-iscsi installer support.
Perhaps thats what you've seen. I have not used/tested it, so can't
comment on its real status.

On Thursday 19 December 2013 10:17 AM, Andrei POPESCU wrote:
> Control: reassign -1 open-iscsi 2.0.873
> On Jo, 19 dec 13, 03:50:46, Vyska Steve-Kai wrote:
>> Package: open-scsi
>> Version: 2.0.873
>> I’m trying to install an daily mini.iso net install (18.12.2013) testing (jessie).
>> The idea is to install an diskless client using an iscsi-lun as root partition and only /boot on a separate disk. The installer realizes this and set up an alternativ initramfs, so the trigger for this kind of installation is set in there expert guy. But there are several other problems, which are not triggered.

This is documented in the README.Debain file on how to do the same ROOT
on iSCSI setup.

>> 1. When the installation finishes, and the reboot starts you get an error, that there is no network. The reason here is, that the udevs are not filled completely when the networks fires up. This is an old known bug #693558 and can be easily solved by adding „wait_for_dev 10 in /usr/share/initramfs-tools/scripts/local-top/iscsi before the configure_networking line and restart update-initramfs -u
This one was fixed already
>> 2. When this is done the system will still not start. The Problem is the nodes definition. The nodes-information is written at the very last point of the installation process. just right before the system asks to reboot. The Problem here is that the nodes are set to be mounted manually (node.startup = manual instead of node-startup = automatic). Even when u have already in an console edit the file as soon as the system prompts to reboot this is set to manual and you can not alter this once you hit return without changing it before.

We don't run the daemon in the initrd..

>> 3. The next interesting issu is, that i was not able to use an login / password combination for the setup. When starting not as a root system everything works fine with the same configuration, but when u mount it in the initramfs you always get an auth error from there.

For login, it is supported. I'm not sure if the same is for discovery.

>> 4. I set up 3 iscsi nodes. The first node works fine when using the workarounds listed here. But the other 2 nodes are not connoted. The system says that there is a session error (Error 15 session exists) and exits the daemon, letting the first node being up. resulting fsck to crash because the device do not exists (work around here is of course the stab changing from default 0 2 to 0 0 for this device).

Only 1 connection is allowed in the initrd.
>> I hope i wrote everything correct here and it helps people either changing something or getting their system online, sorry for the bad english  :D it’s been a while i need to write stuff in english :D. When u need additional Infos / configs / data / whatever just send me an email and when it is possible i’ll provide the information you need
>> Greets
>> Steve

Ritesh Raj Sarraf | http://people.debian.org/~rrs
Debian - The Universal Operating System

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-iscsi-maintainers/attachments/20131219/dd6a85e8/attachment-0003.sig>

More information about the Pkg-iscsi-maintainers mailing list