[Pkg-iscsi-maintainers] Bug#756843: open-iscsi: 7e1ae42 patch only mounting first target disk, then always failing in the end even on success

Turbo Fredriksson turbo at bayour.com
Sat Aug 2 21:21:21 UTC 2014

On Aug 2, 2014, at 10:56 PM, Torben Frey wrote:

> Working perfectly for me now.
> Thanks for the quick fix and patch!

Sounds good and you're most welcome! Ritesh, mind applying it to the next package

Btw, you can close https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=688209,
because the part that fails there, is the part I removed and replaced with my
code instead...

On Aug 2, 2014, at 10:49 PM, Torben Frey wrote:

> I have tried once more and with the break command it is always stopping after the first mount, be it successful or not. Removing the break is mounting all 4 devices in my stab.

Weird! May I ask what your fstab entries look like (exactly)?

I know it works now, but just for my own satisfaction? :). You can send it
privately to me, without going through the bug system...

Mine looks like (just for posterity):

/dev/disk/by-uuid/e6e85244-f3b2-41f4-b4b9-7c779f7fa2c6  none            swap    sw,_netdev              0 0
/dev/disk/by-uuid/04c2830b-efac-41b1-9d87-647d399bc095  /mnt/dev2       ext4    defaults,_netdev        0 0
/dev/disk/by-uuid/434844fb-19be-46a2-bd78-f9e3311b6081  /mnt/dev3       ext4    defaults,_netdev        0 0

And I had to set

	node.startup = automatic



I had to set the "pass" column to 0, otherwise it kept failing in all
the wrong places (checkfs etc, because it was to early - the devices
didn't exist yet at that point).

More information about the Pkg-iscsi-maintainers mailing list