Bug#341452: marked as done (lvm2: v2.02.00-1: breaks VGs: "device-mapper ioctl cmd 9 failed: Invalid argument")

Debian Bug Tracking System owner at bugs.debian.org
Fri Dec 2 19:48:19 UTC 2005

Your message dated Fri, 02 Dec 2005 11:32:06 -0800
with message-id <E1EiGda-0001cb-O0 at spohr.debian.org>
and subject line Bug#341452: fixed in devmapper 2:1.02.02-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 30 Nov 2005 17:48:06 +0000
>From g35fckt001 at sneakemail.com Wed Nov 30 09:48:06 2005
Return-path: <g35fckt001 at sneakemail.com>
Received: from mxout01.versatel.de ([])
	by spohr.debian.org with esmtp (Exim 4.50)
	id 1EhW3q-0005cd-7D
	for submit at bugs.debian.org; Wed, 30 Nov 2005 09:48:06 -0800
Received: from mx01.versatel.de (mx01.versatel.de [])
	by mxout01.versatel.de (8.12.11/8.12.11) with ESMTP id jAUHlXBj006880;
	Wed, 30 Nov 2005 18:47:33 +0100
Received: from weissel2.dyndns.org (i5387D80F.versanet.de [])
	by mx01.versatel.de (8.12.11/8.12.11) with ESMTP id jAUHlVUq010148;
	Wed, 30 Nov 2005 18:47:31 +0100
Received: from weissel by weissel2.dyndns.org with local (Exim 4.60)
	(envelope-from <g35fckt001 at sneakemail.com>)
	id 1EhW36-0006vh-Lm; Wed, 30 Nov 2005 18:47:20 +0100
Date: Wed, 30 Nov 2005 18:47:12 +0100
From: Wolfgang Weisselberg <g35fckt001 at sneakemail.com>
To: Debian Bug Tracking System <submit at bugs.debian.org>
Subject: lvm2: v2.02.00-1: breaks VGs: "device-mapper ioctl cmd 9 failed: Invalid argument"
Message-ID: <20051130174712.GA6053 at weissel2.dyndns.org>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
X-Reportbug-Version: 3.17
User-Agent: Mutt/1.5.11
Delivered-To: submit at bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.3 required=4.0 tests=BAYES_00,FROM_ENDS_IN_NUMS,

Package: lvm2
Version: 2.02.00-1
Severity: critical
Justification: breaks the whole system

Problem description:
After upgrading to lvm2 2.02.00-1 and the required
libdevmapper1.02, the system was unable to complete booting,
as no LVs were reachable: the system was unusable and could not
be used to fix itself.
(The metadata is in lvm2 format.)

vgscan worked OK.
vgchange -a y was broken, spewing lots of:
    device-mapper: one of name or uuid must be supplied, cmd(9)
      device-mapper ioctl cmd 9 failed: Invalid argument
and finally claiming
     18 logical volume(s) in volume group "base_vg" now active 
However, they were not accessible and the boot process was
unable to finish.

vgchange -a n also failed: 
    device-mapper: one of name or uuid must be supplied, cmd(11)
      device-mapper ioctl cmd 11 failed: Invalid argument
      _deps: task run failed for (254:0)
      Failed to add device (254:0) to dtree
    device-mapper: one of name or uuid must be supplied, cmd(11)
      device-mapper ioctl cmd 11 failed: Invalid argument
      _deps: task run failed for (254:1)
      Failed to add device (254:1) to dtree

dmsetup ls was OK.
dmsetup table showed only:
i.e. the names were known, but the tables were missing.

After downgrading to lvm2 2.01.14-3 (and thus libdevmapper1.02)
the system worked again.  

To archive this, a rescue system was needed, as /usr/ (apt-get)
and /var/ (apt/sources.list) etc. were all unreachable.

I am not 100% sure if it is libdevmapper1.02 or lvm2, however,
lvm2 Version 2.01.14-3 works with:
    rm /lib/libdevmapper.so.1.01
    ln -s /lib/libdevmapper.so.1.02 /lib/libdevmapper.so.1.01
Thus the problem probably is within lvm2 v2.02.00-1.

PS: please CC me.

-- System Information:
Debian Release: testing/unstable
  APT prefers oldstable
  APT policy: (500, 'oldstable'), (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.4.27-2-k7
Locale: LANG=de_DE at euro, LC_CTYPE=de_DE at euro (charmap=ISO-8859-15)

[NOTE: bug report created with lvm2 v2.01.14-3!]
Versions of packages lvm2 depends on:
ii  debconf [debconf-2.0]        1.4.59      Debian configuration management sy
ii  libc6                        2.3.5-8.1   GNU C Library: Shared libraries an
ii  libdevmapper1.01             2:1.01.05-1 The Linux Kernel Device Mapper use
ii  libncurses5                  5.5-1       Shared libraries for terminal hand
ii  libreadline5                 5.0-11      GNU readline and history libraries
ii  libselinux1                  1.26-1      SELinux shared libraries
ii  lvm-common                   1.5.20      The Logical Volume Manager for Lin

lvm2 recommends no packages.

-- debconf information:

Received: (at 341452-close) by bugs.debian.org; 2 Dec 2005 19:42:41 +0000
>From katie at ftp-master.debian.org Fri Dec 02 11:42:41 2005
Return-path: <katie at ftp-master.debian.org>
Received: from katie by spohr.debian.org with local (Exim 4.50)
	id 1EiGda-0001cb-O0; Fri, 02 Dec 2005 11:32:06 -0800
From: Bastian Blank <waldi at debian.org>
To: 341452-close at bugs.debian.org
X-Katie: $Revision: 1.60 $
Subject: Bug#341452: fixed in devmapper 2:1.02.02-1
Message-Id: <E1EiGda-0001cb-O0 at spohr.debian.org>
Sender: Archive Administrator <katie at ftp-master.debian.org>
Date: Fri, 02 Dec 2005 11:32:06 -0800
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Source: devmapper
Source-Version: 2:1.02.02-1

We believe that the bug you reported is fixed in the latest version of
devmapper, which is due to be installed in the Debian FTP archive:

  to pool/main/d/devmapper/devmapper_1.02.02-1.diff.gz
  to pool/main/d/devmapper/devmapper_1.02.02-1.dsc
  to pool/main/d/devmapper/devmapper_1.02.02.orig.tar.gz
  to pool/main/d/devmapper/dmsetup-udeb_1.02.02-1_i386.udeb
  to pool/main/d/devmapper/dmsetup_1.02.02-1_i386.deb
  to pool/main/d/devmapper/libdevmapper-dev_1.02.02-1_i386.deb
  to pool/main/d/devmapper/libdevmapper1.02-udeb_1.02.02-1_i386.udeb
  to pool/main/d/devmapper/libdevmapper1.02_1.02.02-1_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 341452 at bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Bastian Blank <waldi at debian.org> (supplier of updated devmapper package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster at debian.org)

Hash: SHA1

Format: 1.7
Date: Fri, 02 Dec 2005 20:16:55 +0100
Source: devmapper
Binary: dmsetup libdevmapper1.02-udeb libdevmapper1.02 libdevmapper-dev dmsetup-udeb
Architecture: source i386
Version: 2:1.02.02-1
Distribution: unstable
Urgency: low
Maintainer: Debian LVM Team <pkg-lvm-maintainers at lists.alioth.debian.org>
Changed-By: Bastian Blank <waldi at debian.org>
 dmsetup    - The Linux Kernel Device Mapper userspace library
 dmsetup-udeb - The Linux Kernel Device Mapper userspace library (udeb)
 libdevmapper-dev - The Linux Kernel Device Mapper header files
 libdevmapper1.02 - The Linux Kernel Device Mapper userspace library
 libdevmapper1.02-udeb - The Linux Kernel Device Mapper userspace library (udeb)
Closes: 341452
 devmapper (2:1.02.02-1) unstable; urgency=low
   * New upstram version.
     - Use names instead of numbers in messages when ioctls fail.
       (closes: #341452)
 cb55c0e3f0c1aec065d6ec9167785b3d 759 admin optional devmapper_1.02.02-1.dsc
 c2a8bcd5e1129c2ff3f620bcdb202c61 916745 admin optional devmapper_1.02.02.orig.tar.gz
 23829c341b6a457e5e6af0b1ab2e96f1 42679 admin optional devmapper_1.02.02-1.diff.gz
 157d277b3a4c828ddf97368b9ebb5f73 43464 libdevel optional libdevmapper-dev_1.02.02-1_i386.deb
 13994b868e40e4caf16e5a6d2d114b54 33712 libs optional libdevmapper1.02_1.02.02-1_i386.deb
 cb00bba17c8d15c68470f1cecdaa2b92 22922 debian-installer optional libdevmapper1.02-udeb_1.02.02-1_i386.udeb
 c31b3ac2445f4a6710f3fd9724a19390 23834 admin optional dmsetup_1.02.02-1_i386.deb
 a5ac0690b8e62d5268effa77bccbbb11 10862 debian-installer optional dmsetup-udeb_1.02.02-1_i386.udeb
Package-Type: udeb

Version: GnuPG v1.4.2 (GNU/Linux)


More information about the pkg-lvm-maintainers mailing list